471,316 Members | 946 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,316 software developers and data experts.

getting Runtime error instead of custom errors

Pat
In my Web.config i have :-
<customErrors mode="On" defaultRedirect="genericerror.htm">
<error statusCode="404" redirect="pagenotfound.aspx"/>
</customErrors
to get page not found error but instead i keep getting a RUN TIME error
below:
Any ideas..
Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed.

Details: To enable the details of this specific error message to be viewable
on the local server machine, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the current
web application. This <customErrors> tag should then have its "mode"
attribute set to "RemoteOnly". To enable the details to be viewable on
remote machines, please set "mode" to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="On" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Nov 19 '05 #1
4 13367
Pat,

are you getting the runtime error when you attempt
to view the page locally ( from the same machine
which is running the web server ) or remotely ?

Juan T. Llibre
ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
==========================

"Pat" <na********@hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
In my Web.config i have :-
<customErrors mode="On" defaultRedirect="genericerror.htm">
<error statusCode="404" redirect="pagenotfound.aspx"/>
</customErrors
to get page not found error but instead i keep getting a RUN TIME error
below:
Any ideas..
Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed.

Details: To enable the details of this specific error message to be viewable
on the local server machine, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the current
web application. This <customErrors> tag should then have its "mode"
attribute set to "RemoteOnly". To enable the details to be viewable on
remote machines, please set "mode" to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="On" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Nov 19 '05 #2
Pat
On the same machine..
Patrick
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uK**************@tk2msftngp13.phx.gbl...
Pat,

are you getting the runtime error when you attempt
to view the page locally ( from the same machine
which is running the web server ) or remotely ?

Juan T. Llibre
ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
==========================

"Pat" <na********@hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
In my Web.config i have :-
<customErrors mode="On" defaultRedirect="genericerror.htm">
<error statusCode="404" redirect="pagenotfound.aspx"/>
</customErrors
to get page not found error but instead i keep getting a RUN TIME error
below:
Any ideas..
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode"
attribute set to "RemoteOnly". To enable the details to be viewable on
remote machines, please set "mode" to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="On" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>


Nov 19 '05 #3
Pat
Fixed it Juan..
found out that the pagenotfound.aspx had errors..
Guess i need a coffee..
Thx

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uK**************@tk2msftngp13.phx.gbl...
Pat,

are you getting the runtime error when you attempt
to view the page locally ( from the same machine
which is running the web server ) or remotely ?

Juan T. Llibre
ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
==========================

"Pat" <na********@hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
In my Web.config i have :-
<customErrors mode="On" defaultRedirect="genericerror.htm">
<error statusCode="404" redirect="pagenotfound.aspx"/>
</customErrors
to get page not found error but instead i keep getting a RUN TIME error
below:
Any ideas..
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode"
attribute set to "RemoteOnly". To enable the details to be viewable on
remote machines, please set "mode" to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="On" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>


Nov 19 '05 #4
Good news!

I was about to suggest that you check the redirection pages for errors,
since that's one of the steadiest-performing ASP.NET components.

Juan T. Llibre
ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
==========================

"Pat" <na********@hotmail.com> wrote in message
news:Ot**************@TK2MSFTNGP12.phx.gbl...
Fixed it Juan..
found out that the pagenotfound.aspx had errors..
Guess i need a coffee..
Thx

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uK**************@tk2msftngp13.phx.gbl...
Pat,

are you getting the runtime error when you attempt
to view the page locally ( from the same machine
which is running the web server ) or remotely ?

Juan T. Llibre
ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
==========================

"Pat" <na********@hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
> In my Web.config i have :-
> <customErrors mode="On" defaultRedirect="genericerror.htm">
> <error statusCode="404" redirect="pagenotfound.aspx"/>
> </customErrors
> to get page not found error but instead i keep getting a RUN TIME error
> below:
> Any ideas..
>
>
> Runtime Error
> Description: An application error occurred on the server. The current custom > error settings for this application prevent the details of the application > error from being viewed.
>
> Details: To enable the details of this specific error message to be viewable > on the local server machine, please create a <customErrors> tag within a
> "web.config" configuration file located in the root directory of the current > web application. This <customErrors> tag should then have its "mode"
> attribute set to "RemoteOnly". To enable the details to be viewable on
> remote machines, please set "mode" to "Off".
>
>
> <!-- Web.Config Configuration File -->
>
> <configuration>
> <system.web>
> <customErrors mode="RemoteOnly"/>
> </system.web>
> </configuration>
>
>
> Notes: The current error page you are seeing can be replaced by a custom
> error page by modifying the "defaultRedirect" attribute of the application's > <customErrors> configuration tag to point to a custom error page URL.
>
>
> <!-- Web.Config Configuration File -->
>
> <configuration>
> <system.web>
> <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
> </system.web>
> </configuration>
>
>
>



Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by John Lau | last post: by
9 posts views Thread by 47computers | last post: by
reply views Thread by Justin Dutoit | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.