By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,660 Members | 1,133 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,660 IT Pros & Developers. It's quick & easy.

Image Buttons not working after clicking one button once

P: n/a
Hi,

I have created a very simple ASP.NET application which has a couple of
ImageButtons which go to different SQL reports on clicking them. I have used
Response.Redirect to send the user to the SQL reports. Now after viewing the
report when I hit the Baxk Button on my browser. and then I click the image
buttons, nothing happens.

Any ideas why this is happening?

Any help is highly appreciated.

Thanks

--
pmud
Nov 19 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
pmud,

Would you be able to show some of the code?

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:2B**********************************@microsof t.com...
Hi,

I have created a very simple ASP.NET application which has a couple of
ImageButtons which go to different SQL reports on clicking them. I have
used
Response.Redirect to send the user to the SQL reports. Now after viewing
the
report when I hit the Baxk Button on my browser. and then I click the
image
buttons, nothing happens.

Any ideas why this is happening?

Any help is highly appreciated.

Thanks

--
pmud

Nov 19 '05 #2

P: n/a
Hi Justin,

Sure, the only code I am using is : private void ImageButton1_Click(object
sender, System.Web.UI ImageClickEventsArgs e)
{
Response.Redirect("URL of the SQL report here");
}

Only this code I am with different image buttons which on licking send the
user to different SQL reports. But when on the Browser, the user hits back
button and goes to the ASP.NET application , the image buttons dont work ,
i.e, on clicking them nothing happens.

Any ideas...

Thanks

--
pmud
"S. Justin Gengo" wrote:
pmud,

Would you be able to show some of the code?

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:2B**********************************@microsof t.com...
Hi,

I have created a very simple ASP.NET application which has a couple of
ImageButtons which go to different SQL reports on clicking them. I have
used
Response.Redirect to send the user to the SQL reports. Now after viewing
the
report when I hit the Baxk Button on my browser. and then I click the
image
buttons, nothing happens.

Any ideas why this is happening?

Any help is highly appreciated.

Thanks

--
pmud


Nov 19 '05 #3

P: n/a
Hmmm,

That certainly seems like it should be working. Based on that I can't think
of any reason your code shouldn't be working... Are you doing anything out
of the ordinary such as adding the button's to the page dynamically?

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:45**********************************@microsof t.com...
Hi Justin,

Sure, the only code I am using is : private void ImageButton1_Click(object
sender, System.Web.UI ImageClickEventsArgs e)
{
Response.Redirect("URL of the SQL report here");
}

Only this code I am with different image buttons which on licking send the
user to different SQL reports. But when on the Browser, the user hits back
button and goes to the ASP.NET application , the image buttons dont work ,
i.e, on clicking them nothing happens.

Any ideas...

Thanks

--
pmud
"S. Justin Gengo" wrote:
pmud,

Would you be able to show some of the code?

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:2B**********************************@microsof t.com...
> Hi,
>
> I have created a very simple ASP.NET application which has a couple of
> ImageButtons which go to different SQL reports on clicking them. I have
> used
> Response.Redirect to send the user to the SQL reports. Now after
> viewing
> the
> report when I hit the Baxk Button on my browser. and then I click the
> image
> buttons, nothing happens.
>
> Any ideas why this is happening?
>
> Any help is highly appreciated.
>
> Thanks
>
> --
> pmud


Nov 19 '05 #4

P: n/a
No Justin. The buttons work the first time.. before we view the report but
once we view the report in the broswer and then hit the BACK on browser..
and go to the .Net application, nothing happens on button click.. Do you
think it could be something to do with Microsoft Reporting Services?
--
pmud
"S. Justin Gengo" wrote:
Hmmm,

That certainly seems like it should be working. Based on that I can't think
of any reason your code shouldn't be working... Are you doing anything out
of the ordinary such as adding the button's to the page dynamically?

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:45**********************************@microsof t.com...
Hi Justin,

Sure, the only code I am using is : private void ImageButton1_Click(object
sender, System.Web.UI ImageClickEventsArgs e)
{
Response.Redirect("URL of the SQL report here");
}

Only this code I am with different image buttons which on licking send the
user to different SQL reports. But when on the Browser, the user hits back
button and goes to the ASP.NET application , the image buttons dont work ,
i.e, on clicking them nothing happens.

Any ideas...

Thanks

--
pmud
"S. Justin Gengo" wrote:
pmud,

Would you be able to show some of the code?

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:2B**********************************@microsof t.com...
> Hi,
>
> I have created a very simple ASP.NET application which has a couple of
> ImageButtons which go to different SQL reports on clicking them. I have
> used
> Response.Redirect to send the user to the SQL reports. Now after
> viewing
> the
> report when I hit the Baxk Button on my browser. and then I click the
> image
> buttons, nothing happens.
>
> Any ideas why this is happening?
>
> Any help is highly appreciated.
>
> Thanks
>
> --
> pmud


Nov 19 '05 #5

P: n/a
pmud,

Sorry, at this point I'm at a losss. I can't think of anything I've
encountered that could cause this problem...

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:AE**********************************@microsof t.com...
No Justin. The buttons work the first time.. before we view the report but
once we view the report in the broswer and then hit the BACK on browser..
and go to the .Net application, nothing happens on button click.. Do you
think it could be something to do with Microsoft Reporting Services?
--
pmud
"S. Justin Gengo" wrote:
Hmmm,

That certainly seems like it should be working. Based on that I can't
think
of any reason your code shouldn't be working... Are you doing anything
out
of the ordinary such as adding the button's to the page dynamically?

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:45**********************************@microsof t.com...
> Hi Justin,
>
> Sure, the only code I am using is : private void
> ImageButton1_Click(object
> sender, System.Web.UI ImageClickEventsArgs e)
> {
> Response.Redirect("URL of the SQL report here");
> }
>
> Only this code I am with different image buttons which on licking send
> the
> user to different SQL reports. But when on the Browser, the user hits
> back
> button and goes to the ASP.NET application , the image buttons dont
> work ,
> i.e, on clicking them nothing happens.
>
> Any ideas...
>
> Thanks
>
> --
> pmud
>
>
> "S. Justin Gengo" wrote:
>
>> pmud,
>>
>> Would you be able to show some of the code?
>>
>> --
>> Sincerely,
>>
>> S. Justin Gengo, MCP
>> Web Developer / Programmer
>>
>> www.aboutfortunate.com
>>
>> "Out of chaos comes order."
>> Nietzsche
>> "pmud" <pm**@discussions.microsoft.com> wrote in message
>> news:2B**********************************@microsof t.com...
>> > Hi,
>> >
>> > I have created a very simple ASP.NET application which has a couple
>> > of
>> > ImageButtons which go to different SQL reports on clicking them. I
>> > have
>> > used
>> > Response.Redirect to send the user to the SQL reports. Now after
>> > viewing
>> > the
>> > report when I hit the Baxk Button on my browser. and then I click
>> > the
>> > image
>> > buttons, nothing happens.
>> >
>> > Any ideas why this is happening?
>> >
>> > Any help is highly appreciated.
>> >
>> > Thanks
>> >
>> > --
>> > pmud
>>
>>
>>


Nov 19 '05 #6

P: n/a
Hi Justin,

The buttons are working today.Yesterday theyu were not. I changed the
settings on my browser . Maybe that helped.I disabled the automatic prompting
for ActiveX controls. It was just not working yestaerday no matter how many
times I tried.

Thanks for all your help. :)
--
pmud
"S. Justin Gengo" wrote:
pmud,

Sorry, at this point I'm at a losss. I can't think of anything I've
encountered that could cause this problem...

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:AE**********************************@microsof t.com...
No Justin. The buttons work the first time.. before we view the report but
once we view the report in the broswer and then hit the BACK on browser..
and go to the .Net application, nothing happens on button click.. Do you
think it could be something to do with Microsoft Reporting Services?
--
pmud
"S. Justin Gengo" wrote:
Hmmm,

That certainly seems like it should be working. Based on that I can't
think
of any reason your code shouldn't be working... Are you doing anything
out
of the ordinary such as adding the button's to the page dynamically?

--
Sincerely,

S. Justin Gengo, MCP
Web Developer / Programmer

www.aboutfortunate.com

"Out of chaos comes order."
Nietzsche
"pmud" <pm**@discussions.microsoft.com> wrote in message
news:45**********************************@microsof t.com...
> Hi Justin,
>
> Sure, the only code I am using is : private void
> ImageButton1_Click(object
> sender, System.Web.UI ImageClickEventsArgs e)
> {
> Response.Redirect("URL of the SQL report here");
> }
>
> Only this code I am with different image buttons which on licking send
> the
> user to different SQL reports. But when on the Browser, the user hits
> back
> button and goes to the ASP.NET application , the image buttons dont
> work ,
> i.e, on clicking them nothing happens.
>
> Any ideas...
>
> Thanks
>
> --
> pmud
>
>
> "S. Justin Gengo" wrote:
>
>> pmud,
>>
>> Would you be able to show some of the code?
>>
>> --
>> Sincerely,
>>
>> S. Justin Gengo, MCP
>> Web Developer / Programmer
>>
>> www.aboutfortunate.com
>>
>> "Out of chaos comes order."
>> Nietzsche
>> "pmud" <pm**@discussions.microsoft.com> wrote in message
>> news:2B**********************************@microsof t.com...
>> > Hi,
>> >
>> > I have created a very simple ASP.NET application which has a couple
>> > of
>> > ImageButtons which go to different SQL reports on clicking them. I
>> > have
>> > used
>> > Response.Redirect to send the user to the SQL reports. Now after
>> > viewing
>> > the
>> > report when I hit the Baxk Button on my browser. and then I click
>> > the
>> > image
>> > buttons, nothing happens.
>> >
>> > Any ideas why this is happening?
>> >
>> > Any help is highly appreciated.
>> >
>> > Thanks
>> >
>> > --
>> > pmud
>>
>>
>>


Nov 19 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.