By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,825 Members | 1,026 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,825 IT Pros & Developers. It's quick & easy.

How to set up privileges for VS.NET developers?

P: n/a
Hi All,

I generated a WebForm and created a Virtual Directory for it IIS. But I got
an error message (shown below) saying something like my app lacked
appropriate privileges.

David Wang replied to an earlier question about this issue, and he informed
me that I needed to include my UserID in the "VS Developers" group in order
to WebForm apps running under my account capable of accessing
\\server\wwwroot$.

That sounds like something I might be able to do on a server. However, I'm
doing WebForm development on WinXP-Pro/SP2 with IIS and FrontPage installed
(and FP integrated appropriately, I believe.) In addition I'm running MSDE
2002 which claims it's using .Net Framework 1.0 (although I'm sure I've got
1.1 installed ... maybe that's a key to my problem???)

I don't see anyway to add my account to VS Developers group. The message I
got is:

=======================
The default Web access mode for this project is set to file share, but the
project folder at http://localhost/MyVirtualProj cannot be opened with the
path "K:\_Projects\WebForms\MyWebProj". The error returned was:

Unable to created Web project "MyVirtualProj". The UNC share
"K:\_Projects\WebForms\MyWebProj" does not exist or you do not have access.
========================

Any further ideas?

Thanks in advance,
Richard

Nov 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
http://msdn.microsoft.com/library/de...luredialog.asp
read the above paper it will help you!
"Richard Lionheart" <No***@Nowhere.net> wrote in message
news:OJ**************@TK2MSFTNGP10.phx.gbl...
Hi All,

I generated a WebForm and created a Virtual Directory for it IIS. But I
got an error message (shown below) saying something like my app lacked
appropriate privileges.

David Wang replied to an earlier question about this issue, and he
informed me that I needed to include my UserID in the "VS Developers"
group in order to WebForm apps running under my account capable of
accessing \\server\wwwroot$.

That sounds like something I might be able to do on a server. However,
I'm doing WebForm development on WinXP-Pro/SP2 with IIS and FrontPage
installed (and FP integrated appropriately, I believe.) In addition I'm
running MSDE 2002 which claims it's using .Net Framework 1.0 (although I'm
sure I've got 1.1 installed ... maybe that's a key to my problem???)

I don't see anyway to add my account to VS Developers group. The message
I got is:

=======================
The default Web access mode for this project is set to file share, but
the
project folder at http://localhost/MyVirtualProj cannot be opened with the
path "K:\_Projects\WebForms\MyWebProj". The error returned was:

Unable to created Web project "MyVirtualProj". The UNC share
"K:\_Projects\WebForms\MyWebProj" does not exist or you do not have
access.
========================

Any further ideas?

Thanks in advance,
Richard

Nov 19 '05 #2

P: n/a
Hi David,

Thank you very much for hanging in there with me.

By now I can't even duplicate the problem I originally asked about. That's
because I subsequently "cracked the code" on creating WebForm apps:

When creating a new app via VS' File/New/Project, one need simply to change
the "WebApplication1" portion of the "Location". Having discovered that,
I've had no subsequent access-denied problem.

I confess, I didn't remedy my initial confusion by taking the "obvious" step
of click on the Help button.

My confusion, and perhaps other users' confusion could be avoided by a
modest change to the interface. This retired software engineer recommends
that Microsoft change the Name and Location fields to the following fields:

Base Location: Text Control initialized to http/local/host, read-only

Folder Name: DropDown Control, editable, initially blank, and browseable
only within the http://localhost area

Project Name: TextControl, editable, initialized to "WebApplication1"

Project Location: Text Control, read-only, dynamically reflecting the
combination of Base Location, Folder Name and Project Name (the equivalent
of the current label control.)

I recognize the Microsoft has bigger fish to fry than this simple interface
change, but I immodestly thought I'd make the suggestion anyway.

Thanks again for your expert help.

Best wishes,
Richard


"David Wang [Msft]" <so*****@online.microsoft.com> wrote in message
news:eZ**************@TK2MSFTNGP14.phx.gbl...
I wonder if you just have a bug in your VS.Net project file that has a path
of K:\ instead of UNC server name

--
//David
IIS
http://blogs.msdn.com/David.Wang
This posting is provided "AS IS" with no warranties, and confers no
rights.
//
"Richard Lionheart" <No***@Nowhere.net> wrote in message
news:er**************@TK2MSFTNGP12.phx.gbl...
Hi Annie,

Thanks for the reference. I didn't find an answer there, so I decided to
back to the "drawing board."

Previously, I had created my own virtual directory using IIS and then
created a new solution using the directory. That gave me access problems,
which I temporally solved by making the virtual directory for
Read/Write/Script/whatever. That solved my problem, though IIS warned me
that making the directory "wide open" was risky.

Today, I created a new project/solution by changing the virtual directory
name from http://localhost/WebApplication1 to
http://localhost/TestingWebAccess. After VS created the project, I
populated the window with a Label control and ran it. NO ACCESS PROBLEM!

Problem solved, at least for the moment. I don't like some of the
default
locations and in time I'll figure out how to relocate folders to my liking
without breaking anything, but at least I can get apps running!

Thanks again for your help.

Best wishes,
Richard
"Annie" <my**************@gmail.com> wrote in message
news:43********@dnews.tpgi.com.au...

http://msdn.microsoft.com/library/de...luredialog.asp
read the above paper it will help you!
"Richard Lionheart" <No***@Nowhere.net> wrote in message
news:OJ**************@TK2MSFTNGP10.phx.gbl...
Hi All,

I generated a WebForm and created a Virtual Directory for it IIS. But I
got an error message (shown below) saying something like my app lacked
appropriate privileges.

David Wang replied to an earlier question about this issue, and he
informed me that I needed to include my UserID in the "VS Developers"
group in order to WebForm apps running under my account capable of
accessing \\server\wwwroot$.

That sounds like something I might be able to do on a server. However,
I'm doing WebForm development on WinXP-Pro/SP2 with IIS and FrontPage
installed (and FP integrated appropriately, I believe.) In addition I'm
running MSDE 2002 which claims it's using .Net Framework 1.0 (although
I'm sure I've got 1.1 installed ... maybe that's a key to my problem???)

I don't see anyway to add my account to VS Developers group. The
message
I got is:

=======================
The default Web access mode for this project is set to file share, but
the
project folder at http://localhost/MyVirtualProj cannot be opened with
the
path "K:\_Projects\WebForms\MyWebProj". The error returned was:

Unable to created Web project "MyVirtualProj". The UNC share
"K:\_Projects\WebForms\MyWebProj" does not exist or you do not have
access.
========================

Any further ideas?

Thanks in advance,
Richard



Nov 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.