By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,185 Members | 1,420 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,185 IT Pros & Developers. It's quick & easy.

The Microsoft Jet database engine cannot open the file...

P: n/a
Hi All

I am trying to connect from ASP.Net app to an Access Db.
If i don't specify a userid an pwd.. I get this error

The Microsoft Jet database engine cannot open the file 'C:\Documents and
Settings\rogersn\My Documents\EEECourses.mdb'. It is already opened
exclusively by another user, or you need permission to view its data."

If i specify a userid (aspnet) no password I get

Cannot start your application. The workgroup information file is missing or
opened exclusively by another user

If I specify any other mdb on my machine...
NO Problem...???
I have subsequently used the mdw file, joined it , created an aspnet user,
all permissions under admins group for the whole bang shoot and still no joy.
??

Then used the permissions wizard and now all my db's pop up a login dialog,
which I really don't want and finding documentation on this especially
removing that is like expecting a miracle..

ie
Q1 How do Iresolve these errors on one mdb only (Access 2000, on Xp sp2
OS)and connect to the db
Q2 How do I get rid of the whole permissions, / login screen security.

TIA
Neal

--
Neal Rogers
University of Cape Town
Nov 19 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
maybe the user used by asp.net dont have access to the folder 'C:\Documents
and
Settings\rogersn\My Documents\
try moving the mdb to another location

"Neal" <Ne**@discussions.microsoft.com> wrote in message
news:39**********************************@microsof t.com...
Hi All

I am trying to connect from ASP.Net app to an Access Db.
If i don't specify a userid an pwd.. I get this error

The Microsoft Jet database engine cannot open the file 'C:\Documents and
Settings\rogersn\My Documents\EEECourses.mdb'. It is already opened
exclusively by another user, or you need permission to view its data."

If i specify a userid (aspnet) no password I get

Cannot start your application. The workgroup information file is missing
or
opened exclusively by another user

If I specify any other mdb on my machine...
NO Problem...???
I have subsequently used the mdw file, joined it , created an aspnet user,
all permissions under admins group for the whole bang shoot and still no
joy.
??

Then used the permissions wizard and now all my db's pop up a login
dialog,
which I really don't want and finding documentation on this especially
removing that is like expecting a miracle..

ie
Q1 How do Iresolve these errors on one mdb only (Access 2000, on Xp sp2
OS)and connect to the db
Q2 How do I get rid of the whole permissions, / login screen security.

TIA
Neal

--
Neal Rogers
University of Cape Town

Nov 19 '05 #2

P: n/a
Neal, what does your connection string look like ?

If you're using an mdw file, it should look like :
"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=\somepath\mydb.mdb;Jet OLEDB:System
Database=system.mdw;"

Bookmark this page : http://www.connectionstrings.com/
and check the connection string variations for Access MDB's.


Juan T. Llibre
ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
=============================

"Neal" <Ne**@discussions.microsoft.com> wrote in message
news:39**********************************@microsof t.com...
Hi All

I am trying to connect from ASP.Net app to an Access Db.
If i don't specify a userid an pwd.. I get this error

The Microsoft Jet database engine cannot open the file 'C:\Documents and
Settings\rogersn\My Documents\EEECourses.mdb'. It is already opened
exclusively by another user, or you need permission to view its data."

If i specify a userid (aspnet) no password I get

Cannot start your application. The workgroup information file is missing or
opened exclusively by another user

If I specify any other mdb on my machine...
NO Problem...???
I have subsequently used the mdw file, joined it , created an aspnet user,
all permissions under admins group for the whole bang shoot and still no joy.
??

Then used the permissions wizard and now all my db's pop up a login dialog,
which I really don't want and finding documentation on this especially
removing that is like expecting a miracle..

ie
Q1 How do Iresolve these errors on one mdb only (Access 2000, on Xp sp2
OS)and connect to the db
Q2 How do I get rid of the whole permissions, / login screen security.

TIA
Neal

--
Neal Rogers
University of Cape Town

Nov 19 '05 #3

P: n/a
On Fri, 2 Sep 2005 04:45:02 -0700, "Neal" <Ne**@discussions.microsoft.com> wrote:

Hi All

I am trying to connect from ASP.Net app to an Access Db.
If i don't specify a userid an pwd.. I get this error

The Microsoft Jet database engine cannot open the file 'C:\Documents and
Settings\rogersn\My Documents\EEECourses.mdb'. It is already opened
exclusively by another user, or you need permission to view its data."


This is a resource permissions problem. It has nothing to do with user-level security. See the
following:

http://support.microsoft.com/default...b;en-us;316675

If i specify a userid (aspnet) no password I get

Cannot start your application. The workgroup information file is missing or
opened exclusively by another user

If I specify any other mdb on my machine...
NO Problem...???


I have subsequently used the mdw file, joined it , created an aspnet user,
all permissions under admins group for the whole bang shoot and still no joy.
??

Then used the permissions wizard and now all my db's pop up a login dialog,
which I really don't want and finding documentation on this especially
removing that is like expecting a miracle..

Did you actually configure this database for user-level security? If so see the following to remove
it:

Remove user-level security (MDB)
http://office.microsoft.com/en-us/as...882401033.aspx
Paul
~~~~
Microsoft MVP (Visual Basic)
Nov 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.