468,161 Members | 1,946 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,161 developers. It's quick & easy.

Compilation error cs0011 with single aspx page in asp application

Hi,

after installing sp1 on windows 2003 I get the following error when
accessing an aspx page in an otherwise asp application:

error: Unable to generate a temporary class (result=1). error CS0011:
Referenced class 'ASP.InvoiceExport_aspx' has base class or interface
'System.Web.UI.Page' defined in an assembly that is not referenced. You must
add a reference to assembly 'System.Web'. error CS0011: Referenced class
'ASP.InvoiceExport_aspx' has base class or interface
'System.Web.SessionState.IRequiresSessionState' defined in an assembly that
is not referenced. You must add a reference to assembly 'System.Web'.

All other (asp) pages are working without a problem.

There is no code-behind file, so no bin directory and no global.asax file.

This is the .cmdline in the "Temporary Asp.Net files" directory:

/t:library /utf8output
/R:"c:\windows\assembly\gac\system.web.services\1.0 .5000.0__b03f5f7f11d50a3a\system.web.services.dll"
/R:"c:\windows\assembly\gac\system.xml\1.0.5000.0__ b77a5c561934e089\system.xml.dll"
/R:"c:\windows\assembly\gac\system.drawing\1.0.5000 .0__b03f5f7f11d50a3a\system.drawing.dll"
/R:"c:\windows\assembly\gac\system.web.mobile\1.0.5 000.0__b03f5f7f11d50a3a\system.web.mobile.dll"
/R:"c:\windows\assembly\gac\system.data\1.0.5000.0_ _b77a5c561934e089\system.data.dll"
/R:"c:\windows\assembly\gac\system.enterpriseservic es\1.0.5000.0__b03f5f7f11d50a3a\system.enterprises ervices.dll"
/R:"c:\windows\assembly\gac\system.web.ui.mobilecon trols.adapters\1.1.0.0__b03f5f7f11d50a3a\system.we b.ui.mobilecontrols.adapters.dll"
/R:"c:\windows\microsoft.net\framework\v1.1.4322\ms corlib.dll"
/R:"c:\windows\assembly\gac\system.web\1.0.5000.0__ b03f5f7f11d50a3a\system.web.dll"
/R:"c:\windows\assembly\gac\system\1.0.5000.0__b77a 5c561934e089\system.dll"
/out:"C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\ Temporary ASP.NET
Files\root\0929bfc9\6b8611c5\pgnru_ji.dll" /D:DEBUG /debug+ /optimize-
/warnaserror /w:1 "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temp orary
ASP.NET Files\root\0929bfc9\6b8611c5\pgnru_ji.0.cs"

which clearly shows a reference added to the system.web assembly, in the
correct location.

I added a reference to the assembly both as a page directive and in the
web.config compilation section, both didn't work.

Any suggestions how to resolve this. or is this a bug?

Paul
Nov 19 '05 #1
0 1132

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by thomson | last post: by
16 posts views Thread by clintonG | last post: by
25 posts views Thread by Blasting Cap | last post: by
reply views Thread by kamranasdasdas | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.