470,641 Members | 1,543 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,641 developers. It's quick & easy.

French Encoding

Hi,

Our Website is french website. When we search in google for our
site its showing the title name with some characters like -- droit
propriété industrielle, protection propriét ... But in our
default.aspx page we given title as droit proprit industrielle,
protection proprit intellectuelle. we have added french encoding
meta tag like below.

<meta http-equiv="content-type" content="text/html;
charset=iso-8859-1">
<meta name="language" content="France, French">

But its still not showing exactly what we given in title for
Default.aspx. I have tried this also <meta
http-equiv="content-language" content="FR"> instead of <meta
name="language" content="France, French">. But still its not showing.
What could be the problem. Is i have to add anything extra to get
exact frech characters. If i got solution for this problem then
immediately it will come in Google site or it will take some time.
Thanks,
Vinoth

Nov 19 '05 #1
4 3493
Not sure how to fix it.
But it will most definately NOT show up in google immeadiatly.

Google does periodic searches on websites and saves Cached versions of the
pages on there servers.
So your changes will take a while to show up in there search results. ...
how long, i don't think anyone can tell you.

"None" <vi********@gmail.com> wrote in message
news:11**********************@z14g2000cwz.googlegr oups.com...
Hi,

Our Website is french website. When we search in google for our
site its showing the title name with some characters like -- droit
propriété industrielle, protection propriét ... But in our
default.aspx page we given title as droit proprit industrielle,
protection proprit intellectuelle. we have added french encoding
meta tag like below.

<meta http-equiv="content-type" content="text/html;
charset=iso-8859-1">
<meta name="language" content="France, French">

But its still not showing exactly what we given in title for
Default.aspx. I have tried this also <meta
http-equiv="content-language" content="FR"> instead of <meta
name="language" content="France, French">. But still its not showing.
What could be the problem. Is i have to add anything extra to get
exact frech characters. If i got solution for this problem then
immediately it will come in Google site or it will take some time.
Thanks,
Vinoth
Nov 19 '05 #2
None wrote:
Hi,

Our Website is french website. When we search in google for our
site its showing the title name with some characters like -- droit
propriété industrielle, protection propriét ... But in our
default.aspx page we given title as droit proprit industrielle,
protection proprit intellectuelle. we have added french encoding
meta tag like below.

<meta http-equiv="content-type" content="text/html;
charset=iso-8859-1">
<meta name="language" content="France, French">

But its still not showing exactly what we given in title for
Default.aspx. I have tried this also <meta
http-equiv="content-language" content="FR"> instead of <meta
name="language" content="France, French">. But still its not showing.
What could be the problem. Is i have to add anything extra to get
exact frech characters. If i got solution for this problem then
immediately it will come in Google site or it will take some time.


ASP.NET uses UTF-8 encoding by default. Adding that particular META tag
could break it, if a browser applies the META tag instead of the HTTP
Content-Type's charset attribute.

Can you post the <globalization/> element of your web.config?

Cheers,
--
http://www.joergjooss.de
mailto:ne********@joergjooss.de
Nov 19 '05 #3
Hi,

This is my globalization element of my web.config <globalization
requestEncoding="utf-8" responseEncoding="utf-8" />

Thanks,
Vinoth
vi****@gsdindia.com

Nov 19 '05 #4
None wrote:
Hi,

This is my globalization element of my web.config <globalization
requestEncoding="utf-8" responseEncoding="utf-8" />

^^^^^

That combined with

<meta http-equiv="content-type" content="text/html;
charset=iso-8859-1">

won't work. Either remove the META tag or fix it:

<meta http-equiv="content-type" content="text/html;
charset=utf-8">
Cheers,
--
http://www.joergjooss.de
mailto:ne********@joergjooss.de
Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Jasmine | last post: by
5 posts views Thread by darin dimitrov | last post: by
8 posts views Thread by Ess355 | last post: by
7 posts views Thread by Yongjian | last post: by
6 posts views Thread by Vinoth | last post: by
5 posts views Thread by John C. | last post: by
3 posts views Thread by bss | last post: by
???
1 post views Thread by Stoney L | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.