By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,141 Members | 1,911 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,141 IT Pros & Developers. It's quick & easy.

I am missing something but cant think what

P: n/a
I am using VS2005 and ASP.NET 2
I want to use IIS to host some .NET remoting.

I have a website I created called RemotingHost. I created another class
project called RemotingServer and in there a class called TestClass
(inherits Marshallbyrefobject for remoting). I then added the built
assembly to the bin folder on the RemotingHost website.
I created a web config file with system.runtime.remoting wellknown service
for the testclass as follows:

<system.runtime.remoting>
<application>
<service>
<wellknown mode="Singleton" type="RemotingServer.TestClass,
RemotingServer" objecturi="TestClass.rem"/>
</service>
</application>
</system.runtime.remoting>

I then created a windows client with a reference to the RemotingServer (just
for the metadata).
I created an app config file for the client too as follows:

<system.runtime.remoting>
<application>
<client>
<wellknown
type="RemotingServer.TestClass, RemotingServer"
url="http://localhost/RemotingTestHost/TestClass.rem"
/>
</client>
</application>
</system.runtime.remoting>

I call RemotingConfiguration.Configure but when i try to instantiate the
class i get an error saying it cannot find the service.

I have done similar thousands of times in .NET1.1 with no problems so what
am i missing on .NET2? The only thing i do differently is create the
TestClass in a seperate assembly (i used to create it in the website in 1.1
and reference from there but you cant do that in .NET2 unfortunately.

Anyone spot where i am going wrong? Any ideas on hosting a single class for
remoting in IIS in .NET2?

Thanks
Mark
Nov 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.