By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,637 Members | 1,967 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,637 IT Pros & Developers. It's quick & easy.

Server Application Unavailable

P: n/a
I recentlymoved my asp and aspx webs to a new server. The asp webs
(developed in InterDev) come up fine. But I get the following message when
I try to view my donet asp (aspx) webs:
Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.

Is there something special I need to configure to for aspx pages?
Nov 19 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Hi,

Pls visit the following link:

http://support.microsoft.com/default...;en-us;Q315158

Hope this helps.

Prakash.NET

"Dave" wrote:
I recentlymoved my asp and aspx webs to a new server. The asp webs
(developed in InterDev) come up fine. But I get the following message when
I try to view my donet asp (aspx) webs:
Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.

Is there something special I need to configure to for aspx pages?

Nov 19 '05 #2

P: n/a
Thanks for Prakash's informative inputs.

Hi Dave,

Regarding on such issue, there're serveral possible causes which are also
depend on the detailed envirnoment and sceanrio. Anyway, I suggest we check
from the IIS log and Windows eventlog to see whether there has any
informative log entries there.

Please feel free to let me know if there're any new findings.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #3

P: n/a
Thanks guys

The error code in event viewer is event id 1081, Source ASP.NET 1.1.4322.0:
aspnet_wp.exe could not be started. The error code for the failure is
80070545. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure that the
..NET Framework is correctly installed and that the ACLs on the installation
directory allow access to the configured account.

S search for error 80070545 in the MS KB does not return anything.

I read "Article ID : 315158 FIX: ASP.NET does not work with the default
ASPNET account on a domain controller " but it does not help.

I created an ASPUser account and gave it rights to "log on as a batch job"
but I have Net Framework version v1.1.4322 and I do not see a username and
password attributes in the <processModel> section of the Machine.config
file.

Any ideas?

Thanks
Dave


"Steven Cheng[MSFT]" <v-******@online.microsoft.com> wrote in message
news:nN*************@TK2MSFTNGXA01.phx.gbl...
Thanks for Prakash's informative inputs.

Hi Dave,

Regarding on such issue, there're serveral possible causes which are also
depend on the detailed envirnoment and sceanrio. Anyway, I suggest we
check
from the IIS log and Windows eventlog to see whether there has any
informative log entries there.

Please feel free to let me know if there're any new findings.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #4

P: n/a
Hi Dave,

As you mentioned that you've tried following the things in the kb:

315158 FIX: ASP.NET does not work with the default
ASPNET account on a domain controller "

Is your server a DC machine? If so, you can switch the ASP.NET application
to running under LocalSystem account or a domain account. For how to create
a custom process Identity, here is a msdn reference for creating custom
ASP.NET worker process idenitty for IIS5 mode:

http://msdn.microsoft.com/library/de...us/secmod/html
/secmod15.asp

For w2k3 IIS6, we could just add a custom account into the IIS_WPG group to
make sure it has the sufficient permission s to run asp.net applciation.

If your server is not a DC box, we may need to looking for other things on
this issue.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "Dave" <da*******@newsgroup.nospam>
| References: <ex*************@TK2MSFTNGP09.phx.gbl>
<10**********************************@microsoft.co m>
<nN*************@TK2MSFTNGXA01.phx.gbl>
| Subject: Re: Server Application Unavailable
| Date: Sun, 10 Jul 2005 17:25:26 -0700
| Lines: 52
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2527
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2527
| X-RFC2646: Format=Flowed; Original
| Message-ID: <Ot**************@TK2MSFTNGP09.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: c-24-130-211-137.hsd1.ca.comcast.net 24.130.211.137
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP09.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:111429
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Thanks guys
|
| The error code in event viewer is event id 1081, Source ASP.NET
1.1.4322.0:
| aspnet_wp.exe could not be started. The error code for the failure is
| 80070545. This error can be caused when the worker process account has
| insufficient rights to read the .NET Framework files. Please ensure that
the
| .NET Framework is correctly installed and that the ACLs on the
installation
| directory allow access to the configured account.
|
| S search for error 80070545 in the MS KB does not return anything.
|
| I read "Article ID : 315158 FIX: ASP.NET does not work with the default
| ASPNET account on a domain controller " but it does not help.
|
| I created an ASPUser account and gave it rights to "log on as a batch
job"
| but I have Net Framework version v1.1.4322 and I do not see a username
and
| password attributes in the <processModel> section of the Machine.config
| file.
|
| Any ideas?
|
| Thanks
| Dave
|
|
|
|
| "Steven Cheng[MSFT]" <v-******@online.microsoft.com> wrote in message
| news:nN*************@TK2MSFTNGXA01.phx.gbl...
| > Thanks for Prakash's informative inputs.
| >
| > Hi Dave,
| >
| > Regarding on such issue, there're serveral possible causes which are
also
| > depend on the detailed envirnoment and sceanrio. Anyway, I suggest we
| > check
| > from the IIS log and Windows eventlog to see whether there has any
| > informative log entries there.
| >
| > Please feel free to let me know if there're any new findings.
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
|
|
|

Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.