By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,631 Members | 826 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,631 IT Pros & Developers. It's quick & easy.

Worker Process Write Permissions

P: n/a
Hi

I am trying to get an online gallery (www.ngallery.org - open source) to
upload image to a folder. At the moment I am using localhost but plan to
move to some web space when I get it all working.

I need to update my 'images' folder permissions so the ASP.NET worker
process has write permissions.

However, when I go to the folder permissions, there is not worker process
entry. I have IIS on my machine and I am running Windows XP Pro.

How can I get the worker process to show up in the security tab?
Would it help if I tried working with some web space rather than on a
desktop?

Regards, Carl Gilbert
Nov 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
It's not the worker process which needs write permissions.

It's the account the worker process is running as which needs
write permissions.

Run this short file I wrote :

identity.aspx
-----------------
<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = tmp
End Sub
</script>
<html>
<head>
<title>WindowsIdentity.GetCurrent.Name()</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
-------------

That will return the account the aspnet worker process is running under.
Then, give whatever write permissions you need to give to that account.

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Carl Gilbert" <no****@nospam.com> wrote in message
news:ui**************@TK2MSFTNGP10.phx.gbl...
Hi

I am trying to get an online gallery (www.ngallery.org - open source) to upload image to
a folder. At the moment I am using localhost but plan to move to some web space when I
get it all working.

I need to update my 'images' folder permissions so the ASP.NET worker process has write
permissions.

However, when I go to the folder permissions, there is not worker process entry. I have
IIS on my machine and I am running Windows XP Pro.

How can I get the worker process to show up in the security tab?
Would it help if I tried working with some web space rather than on a desktop?

Regards, Carl Gilbert

Nov 19 '05 #2

P: n/a
Cheers Juan

That page proved to be rather helpful.
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
It's not the worker process which needs write permissions.

It's the account the worker process is running as which needs
write permissions.

Run this short file I wrote :

identity.aspx
-----------------
<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = tmp
End Sub
</script>
<html>
<head>
<title>WindowsIdentity.GetCurrent.Name()</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
-------------

That will return the account the aspnet worker process is running under.
Then, give whatever write permissions you need to give to that account.

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Carl Gilbert" <no****@nospam.com> wrote in message
news:ui**************@TK2MSFTNGP10.phx.gbl...
Hi

I am trying to get an online gallery (www.ngallery.org - open source) to
upload image to a folder. At the moment I am using localhost but plan to
move to some web space when I get it all working.

I need to update my 'images' folder permissions so the ASP.NET worker
process has write permissions.

However, when I go to the folder permissions, there is not worker process
entry. I have IIS on my machine and I am running Windows XP Pro.

How can I get the worker process to show up in the security tab?
Would it help if I tried working with some web space rather than on a
desktop?

Regards, Carl Gilbert


Nov 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.