By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,904 Members | 925 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,904 IT Pros & Developers. It's quick & easy.

custom error page doesnt load

P: n/a
dee
Hi

In web.config I have to the following:

<configuration>
<system.web>
<customErrors defaultRedirect="error.htm" mode="On" />
</system.web>
</configuration>

I generated a forced error in my page. Instead of being
redirected to error.htm i get the following error message form dotnet:

**********
Runtime Error

Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed.

Details: ...

**********

Why don't I ger redirected to my error.htm page?

Thanks.
Dee
Nov 19 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Do this instead. On Global.asax.cs

protected void Application_Error(Object sender, EventArgs e)
{
Response.Redirect("error.htm");
}

However should be better you use Server.Transfer("error.aspx");

So you can log the error

Hope it helps

"dee" wrote:
Hi

In web.config I have to the following:

<configuration>
<system.web>
<customErrors defaultRedirect="error.htm" mode="On" />
</system.web>
</configuration>

I generated a forced error in my page. Instead of being
redirected to error.htm i get the following error message form dotnet:

**********
Runtime Error

Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed.

Details: ...

**********

Why don't I ger redirected to my error.htm page?

Thanks.
Dee

Nov 19 '05 #2

P: n/a
dee
Hi Albert
protected void Application_Error(Object sender, EventArgs e)
{
Response.Redirect("error.htm");
}
has still same result; it doesnt take me to error.htm but to dotnet page.
"Albert Pascual" <Al***********@discussions.microsoft.com> wrote in message
news:A1**********************************@microsof t.com...
Do this instead. On Global.asax.cs

protected void Application_Error(Object sender, EventArgs e)
{
Response.Redirect("error.htm");
}

However should be better you use Server.Transfer("error.aspx");

So you can log the error

Hope it helps

"dee" wrote:
Hi

In web.config I have to the following:

<configuration>
<system.web>
<customErrors defaultRedirect="error.htm" mode="On" />
</system.web>
</configuration>

I generated a forced error in my page. Instead of being
redirected to error.htm i get the following error message form dotnet:

**********
Runtime Error

Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed.

Details: ...

**********

Why don't I ger redirected to my error.htm page?

Thanks.
Dee

Nov 19 '05 #3

P: n/a
The donotpage? what's that?

"dee" wrote:
Hi Albert
protected void Application_Error(Object sender, EventArgs e)
{
Response.Redirect("error.htm");
}
has still same result; it doesnt take me to error.htm but to dotnet page.
"Albert Pascual" <Al***********@discussions.microsoft.com> wrote in message
news:A1**********************************@microsof t.com...
Do this instead. On Global.asax.cs

protected void Application_Error(Object sender, EventArgs e)
{
Response.Redirect("error.htm");
}

However should be better you use Server.Transfer("error.aspx");

So you can log the error

Hope it helps

"dee" wrote:
Hi

In web.config I have to the following:

<configuration>
<system.web>
<customErrors defaultRedirect="error.htm" mode="On" />
</system.web>
</configuration>

I generated a forced error in my page. Instead of being
redirected to error.htm i get the following error message form dotnet:

**********
Runtime Error

Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed.

Details: ...

**********

Why don't I ger redirected to my error.htm page?

Thanks.
Dee


Nov 19 '05 #4

P: n/a
dee
Here is the page:

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed.

Details: To enable the details of this specific error message to be viewable
on the local server machine, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the current
web application. This <customErrors> tag should then have its "mode"
attribute set to "RemoteOnly". To enable the details to be viewable on
remote machines, please set "mode" to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="On" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
"Albert Pascual" <Al***********@discussions.microsoft.com> wrote in message
news:4D**********************************@microsof t.com...
The donotpage? what's that?

"dee" wrote:
Hi Albert
protected void Application_Error(Object sender, EventArgs e)
{
Response.Redirect("error.htm");
}
has still same result; it doesnt take me to error.htm but to dotnet page.
"Albert Pascual" <Al***********@discussions.microsoft.com> wrote in
message
news:A1**********************************@microsof t.com...
> Do this instead. On Global.asax.cs
>
> protected void Application_Error(Object sender, EventArgs e)
> {
> Response.Redirect("error.htm");
> }
>
> However should be better you use Server.Transfer("error.aspx");
>
> So you can log the error
>
> Hope it helps
>
> "dee" wrote:
>
>> Hi
>>
>> In web.config I have to the following:
>>
>> <configuration>
>> <system.web>
>> <customErrors defaultRedirect="error.htm" mode="On" />
>> </system.web>
>> </configuration>
>>
>> I generated a forced error in my page. Instead of being
>> redirected to error.htm i get the following error message form dotnet:
>>
>> **********
>> Runtime Error
>>
>> Description: An application error occurred on the server. The
>> current
>> custom error settings for this application prevent the details of the
>> application error from being viewed.
>>
>> Details: ...
>>
>> **********
>>
>> Why don't I ger redirected to my error.htm page?
>>
>> Thanks.
>> Dee
>>
>>
>>


Nov 19 '05 #5

P: n/a
Oh! if you are using the Global.asax.cs, set it to "Off"

Al

"dee" wrote:
Here is the page:

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed.

Details: To enable the details of this specific error message to be viewable
on the local server machine, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the current
web application. This <customErrors> tag should then have its "mode"
attribute set to "RemoteOnly". To enable the details to be viewable on
remote machines, please set "mode" to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="On" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
"Albert Pascual" <Al***********@discussions.microsoft.com> wrote in message
news:4D**********************************@microsof t.com...
The donotpage? what's that?

"dee" wrote:
Hi Albert
protected void Application_Error(Object sender, EventArgs e)
{
Response.Redirect("error.htm");
}
has still same result; it doesnt take me to error.htm but to dotnet page.
"Albert Pascual" <Al***********@discussions.microsoft.com> wrote in
message
news:A1**********************************@microsof t.com...
> Do this instead. On Global.asax.cs
>
> protected void Application_Error(Object sender, EventArgs e)
> {
> Response.Redirect("error.htm");
> }
>
> However should be better you use Server.Transfer("error.aspx");
>
> So you can log the error
>
> Hope it helps
>
> "dee" wrote:
>
>> Hi
>>
>> In web.config I have to the following:
>>
>> <configuration>
>> <system.web>
>> <customErrors defaultRedirect="error.htm" mode="On" />
>> </system.web>
>> </configuration>
>>
>> I generated a forced error in my page. Instead of being
>> redirected to error.htm i get the following error message form dotnet:
>>
>> **********
>> Runtime Error
>>
>> Description: An application error occurred on the server. The
>> current
>> custom error settings for this application prevent the details of the
>> application error from being viewed.
>>
>> Details: ...
>>
>> **********
>>
>> Why don't I ger redirected to my error.htm page?
>>
>> Thanks.
>> Dee
>>
>>
>>


Nov 19 '05 #6

P: n/a
dee
When I set it to "off" it still shows dotnet error page but now it even
shows the lines.
Here is part of the error page:

------

Arithmetic operation resulted in an overflow.
Description: An unhandled exception occurred during the execution of the
current web request. Please review the stack trace for more information
about the error and where it originated in the code.

Exception Details: System.OverflowException: Arithmetic operation resulted
in an overflow.

Source Error:

Line 327: Dim n As Int16
Line 328: n = 0
Line 329: n = 1 / n
Line 330:
Line 331: Me.DataBind()
..
..
..

"Albert Pascual" <Al***********@discussions.microsoft.com> wrote in message
news:6F**********************************@microsof t.com...
Oh! if you are using the Global.asax.cs, set it to "Off"

Al

"dee" wrote:
Here is the page:

Runtime Error
Description: An application error occurred on the server. The current
custom
error settings for this application prevent the details of the
application
error from being viewed.

Details: To enable the details of this specific error message to be
viewable
on the local server machine, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the
current
web application. This <customErrors> tag should then have its "mode"
attribute set to "RemoteOnly". To enable the details to be viewable on
remote machines, please set "mode" to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the
application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="On" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
"Albert Pascual" <Al***********@discussions.microsoft.com> wrote in
message
news:4D**********************************@microsof t.com...
> The donotpage? what's that?
>
> "dee" wrote:
>
>> Hi Albert
>> protected void Application_Error(Object sender, EventArgs e)
>> {
>> Response.Redirect("error.htm");
>> }
>> has still same result; it doesnt take me to error.htm but to dotnet
>> page.
>>
>>
>> "Albert Pascual" <Al***********@discussions.microsoft.com> wrote in
>> message
>> news:A1**********************************@microsof t.com...
>> > Do this instead. On Global.asax.cs
>> >
>> > protected void Application_Error(Object sender, EventArgs e)
>> > {
>> > Response.Redirect("error.htm");
>> > }
>> >
>> > However should be better you use Server.Transfer("error.aspx");
>> >
>> > So you can log the error
>> >
>> > Hope it helps
>> >
>> > "dee" wrote:
>> >
>> >> Hi
>> >>
>> >> In web.config I have to the following:
>> >>
>> >> <configuration>
>> >> <system.web>
>> >> <customErrors defaultRedirect="error.htm" mode="On" />
>> >> </system.web>
>> >> </configuration>
>> >>
>> >> I generated a forced error in my page. Instead of being
>> >> redirected to error.htm i get the following error message form
>> >> dotnet:
>> >>
>> >> **********
>> >> Runtime Error
>> >>
>> >> Description: An application error occurred on the server. The
>> >> current
>> >> custom error settings for this application prevent the details of
>> >> the
>> >> application error from being viewed.
>> >>
>> >> Details: ...
>> >>
>> >> **********
>> >>
>> >> Why don't I ger redirected to my error.htm page?
>> >>
>> >> Thanks.
>> >> Dee
>> >>
>> >>
>> >>
>>
>>
>>


Nov 19 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.