By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
449,214 Members | 1,971 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 449,214 IT Pros & Developers. It's quick & easy.

Codepage problem

P: n/a
I saved my aspx with Encoding (Chinese Tranditional (Big5) - Codepage 950)
and I had set codepage="950" in Page tag. The content rendered incorrect
(all text changed to symbols), but some content those read from xml file
works correct.

How can I fix this problem?
Thanks
Nov 19 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Do you use a "Web.config" file? Try to set "requestEncoding" and
"responseEncoding" in that file.

Azat

"Daatmor" <mc********@yahoo.com.hk> schrieb im Newsbeitrag
news:Os**************@tk2msftngp13.phx.gbl...
I saved my aspx with Encoding (Chinese Tranditional (Big5) - Codepage 950)
and I had set codepage="950" in Page tag. The content rendered incorrect
(all text changed to symbols), but some content those read from xml file
works correct.

How can I fix this problem?
Thanks

Nov 19 '05 #2

P: n/a
Hi Azat,

Thanks for your help, its works.
But my site contains english pages and chinese pages. If set
"requestEncoding" and "responseEncoding" in "Web.config", all page will
encoded with Chinese Tranditional (Big5). English viewers will show
"download IE chinese language pack" dialog box when they browsing english
pages.
I tried set 'ResponseEncoding="Big5"' in each chinese page's @page tag,
but chinese characters cannot works correct. In @page tag, "requestEncoding"
property cannot be specified. Where can I set "requestEncoding" for certain
page? or has any other solutions?
Thanks

Hugo
"Azat" <az****@web.de> wrote in message
news:#m**************@TK2MSFTNGP12.phx.gbl...
Do you use a "Web.config" file? Try to set "requestEncoding" and
"responseEncoding" in that file.

Azat

"Daatmor" <mc********@yahoo.com.hk> schrieb im Newsbeitrag
news:Os**************@tk2msftngp13.phx.gbl...
I saved my aspx with Encoding (Chinese Tranditional (Big5) - Codepage 950) and I had set codepage="950" in Page tag. The content rendered incorrect
(all text changed to symbols), but some content those read from xml file
works correct.

How can I fix this problem?
Thanks


Nov 19 '05 #3

P: n/a
Dear Azat

I found solution:
I can add a new "Web.config" in my chinese pages folder. It just
contains following codes:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<system.web>
<globalization requestEncoding="Big5" responseEncoding="Big5"
fileEncoding="Big5" />
</system.web>
</configuration>

But if chinese pages and english pages stored in same folder, above
method cannot work.

Regards,
Hugo

"Daatmor" <mc********@yahoo.com.hk> wrote in message
news:e0**************@TK2MSFTNGP09.phx.gbl...
Hi Azat,

Thanks for your help, its works.
But my site contains english pages and chinese pages. If set
"requestEncoding" and "responseEncoding" in "Web.config", all page will
encoded with Chinese Tranditional (Big5). English viewers will show
"download IE chinese language pack" dialog box when they browsing english
pages.
I tried set 'ResponseEncoding="Big5"' in each chinese page's @page tag, but chinese characters cannot works correct. In @page tag, "requestEncoding" property cannot be specified. Where can I set "requestEncoding" for certain page? or has any other solutions?
Thanks

Hugo
"Azat" <az****@web.de> wrote in message
news:#m**************@TK2MSFTNGP12.phx.gbl...
Do you use a "Web.config" file? Try to set "requestEncoding" and
"responseEncoding" in that file.

Azat

"Daatmor" <mc********@yahoo.com.hk> schrieb im Newsbeitrag
news:Os**************@tk2msftngp13.phx.gbl...
I saved my aspx with Encoding (Chinese Tranditional (Big5) - Codepage 950) and I had set codepage="950" in Page tag. The content rendered incorrect (all text changed to symbols), but some content those read from xml file works correct.

How can I fix this problem?
Thanks



Nov 19 '05 #4

P: n/a
Daatmor wrote:
Dear Azat

I found solution:
I can add a new "Web.config" in my chinese pages folder. It just
contains following codes:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<system.web>
<globalization requestEncoding="Big5" responseEncoding="Big5"
fileEncoding="Big5" />
</system.web>
</configuration>

But if chinese pages and english pages stored in same folder, above
method cannot work.


Why not use a code set that covers both Latin and Chinese characters,
i.e. Unicode? You can use UTF-16 or UTF-8 as request and response
encoding here for example.

Cheers,
--
http://www.joergjooss.de
mailto:ne********@joergjooss.de
Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.