By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,836 Members | 2,059 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,836 IT Pros & Developers. It's quick & easy.

"DATA" Directory

P: n/a
Hi. I had previously installed VS2005 beta 1. I carefully followed all the
steps (I thought) to deinstall it and then installed beta 2. According to the
documentation, the "Data" directory which was to be a "special" directory in
the docroot of an ASP.NET app, has been renamed to "app_data". That's a GOOD
thing because you guys were using up too many normal words for reserved
purposes. Anyway, the problem is that I have a "Data" directory in the root
of my ASP.NET app but now I'm still getting a "HTTP 403.2 - Forbidden: Read
Access Forbidden" when I try to get to my Data directory. What's going on
here? I know it's not directory permissions 'cause if I rename the directory
"DataX" or something, then I have no problem.

Is there something left over from the bata 1 version?

Help!

Thanks.

Alex
Nov 19 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Sorry to be a pest but could someone please answer this question for me???

Alex

"Alex Maghen" wrote:
Hi. I had previously installed VS2005 beta 1. I carefully followed all the
steps (I thought) to deinstall it and then installed beta 2. According to the
documentation, the "Data" directory which was to be a "special" directory in
the docroot of an ASP.NET app, has been renamed to "app_data". That's a GOOD
thing because you guys were using up too many normal words for reserved
purposes. Anyway, the problem is that I have a "Data" directory in the root
of my ASP.NET app but now I'm still getting a "HTTP 403.2 - Forbidden: Read
Access Forbidden" when I try to get to my Data directory. What's going on
here? I know it's not directory permissions 'cause if I rename the directory
"DataX" or something, then I have no problem.

Is there something left over from the bata 1 version?

Help!

Thanks.

Alex

Nov 19 '05 #2

P: n/a
Hi Alex,

Welcome to ASPNET newsgroup.
From your description, you're just removed your ASP.NET WHIDBEY BETA1
environment and installed the beta2 on your machine. After that , when you
accessing pages in the "Data" folder under the app root, you got a

"HTTP 403.2 - Forbidden" access error ,yes?

based on my experience, the 403.2 forbidden error is mostly caused by a
certain IIS's virtual folder or the page in it dosn't grant "Read"
permission to the client visitors. This is not the SYSTEM's NTFS
permission, we should check it in the INETMGR management console, and
select the "Data" folder an right click to show th properties window. Check
in the "Directory" panel to see whether the "read" permission is checked.
Since the "Data" is treated as the well-known folders in beta1, it is
likely that it is still prevent from being read, so please have a look at
this.

Hope helps. Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #3

P: n/a
Steven -

YES! You were right about this. But let me ask you one other related
question: I created this new Virtual Site in IIS AFTER I upgraded to BETA 2.
Does this mean that from now on, whenever I create a new Virtual Web Site on
this machine and it has a "DATA" directory, it'll automatically set that with
no READ permissions in IIS? Is there any way to clean that setting out?

Thanks!

Alex

""WenJun Zhang[msft]"" wrote:
Hi Alex,

Welcome to ASPNET newsgroup.
From your description, you're just removed your ASP.NET WHIDBEY BETA1
environment and installed the beta2 on your machine. After that , when you
accessing pages in the "Data" folder under the app root, you got a

"HTTP 403.2 - Forbidden" access error ,yes?

based on my experience, the 403.2 forbidden error is mostly caused by a
certain IIS's virtual folder or the page in it dosn't grant "Read"
permission to the client visitors. This is not the SYSTEM's NTFS
permission, we should check it in the INETMGR management console, and
select the "Data" folder an right click to show th properties window. Check
in the "Directory" panel to see whether the "read" permission is checked.
Since the "Data" is treated as the well-known folders in beta1, it is
likely that it is still prevent from being read, so please have a look at
this.

Hope helps. Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


Nov 19 '05 #4

P: n/a
Hi Alex,

Thanks for the response.
As for the further question you mentioned, I'm afraid this could be true as
you mentioned. However the problem is still caused by the originally
installed beta1. In fact, on our internal test, we always install the beta
version softwares on VPC image so as not to affact our physical box.
Anyway, if feel it possible, I suggest you build a clear box (without the
former beta1 or any of its left things) and install the beta2, and using
VPC is much more recommended. If you have to keep on working on the current
box, I'm afraid we need to manually check all those well-known folders's
IIS permission setting before we start running beta2 web app.

BTW, have you tried using File System based virtual server, in the new
ASP.NET2.0, it's my favorite choice :-)

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
Nov 19 '05 #5

P: n/a
I don't know what a "File System Based Virtual Server" is. Can you point me
to documentation on that?

Thanks for your help.

Alex
"Steven Cheng[MSFT]" wrote:
Hi Alex,

Thanks for the response.
As for the further question you mentioned, I'm afraid this could be true as
you mentioned. However the problem is still caused by the originally
installed beta1. In fact, on our internal test, we always install the beta
version softwares on VPC image so as not to affact our physical box.
Anyway, if feel it possible, I suggest you build a clear box (without the
former beta1 or any of its left things) and install the beta2, and using
VPC is much more recommended. If you have to keep on working on the current
box, I'm afraid we need to manually check all those well-known folders's
IIS permission setting before we start running beta2 web app.

BTW, have you tried using File System based virtual server, in the new
ASP.NET2.0, it's my favorite choice :-)

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #6

P: n/a
It's an internal server-based website.

VS.NET uses a version of Cassini to support it,
using a random port for its implementation.

For more info on Cassini, see :
http://www.asp.net/Projects/Cassini/...ndex=0&tabid=1
and
http://forums.asp.net/67/ShowForum.aspx


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Alex Maghen" <Al********@newsgroup.nospam> wrote in message
news:55**********************************@microsof t.com...
I don't know what a "File System Based Virtual Server" is. Can you point me
to documentation on that?

Thanks for your help.

Alex
"Steven Cheng[MSFT]" wrote:
Hi Alex,

Thanks for the response.
As for the further question you mentioned, I'm afraid this could be true as
you mentioned. However the problem is still caused by the originally
installed beta1. In fact, on our internal test, we always install the beta
version softwares on VPC image so as not to affact our physical box.
Anyway, if feel it possible, I suggest you build a clear box (without the
former beta1 or any of its left things) and install the beta2, and using
VPC is much more recommended. If you have to keep on working on the current
box, I'm afraid we need to manually check all those well-known folders's
IIS permission setting before we start running beta2 web app.

BTW, have you tried using File System based virtual server, in the new
ASP.NET2.0, it's my favorite choice :-)

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #7

P: n/a
Thanks for Juan's informative inputs.

Hi Alex,

File server is just a new feature of VS.NET2005 which has a internal
webserver, so we can no longer reply on IIS when developing ASP.NET web app
in VS.NET 2005. When creating asp.net project, we can choose using File
System rather than HTTP url(mapp the virtual dir in IIS).

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.