By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,948 Members | 1,975 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,948 IT Pros & Developers. It's quick & easy.

Cannot connect to Access 2000 DB using impersonated user

P: n/a
When attempting to connect to an Access 2000 DB using ADO.Net from within
ASP.Net running under an impersonated local user account receiving the
following error.

ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver] Disk or network
error. ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver's
SQLSetConnectAttr failed ERROR [HY000] [Microsoft][ODBC Microsoft Access
Driver] Disk or network error

Oracle ODBC connection works fine under the same user so assuming this is
something to do with either Access specific registry permissions, or NTFS
file permissions. Assuming ODBC call is being made using the impersonated
user id?

Anybody ever come across this problem before

Nov 19 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Essentially, you need a TMP or TEMP environment variable
and assign access permissions to the ASP.NET account
for the folder(s) in question.

Please read
http://support.microsoft.com/default...b;en-us;251254
to get instructions for a possible fix for that problem.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"stueyh" <st****@discussions.microsoft.com> wrote in message
news:3B**********************************@microsof t.com...
When attempting to connect to an Access 2000 DB using ADO.Net from within
ASP.Net running under an impersonated local user account receiving the
following error.

ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver] Disk or network
error. ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver's
SQLSetConnectAttr failed ERROR [HY000] [Microsoft][ODBC Microsoft Access
Driver] Disk or network error

Oracle ODBC connection works fine under the same user so assuming this is
something to do with either Access specific registry permissions, or NTFS
file permissions. Assuming ODBC call is being made using the impersonated
user id?

Anybody ever come across this problem before

Nov 19 '05 #2

P: n/a
Thanks for the reply. Checked the system temp directory and this had the
required permissions. Then checked for any other profiles that may also
contain a temp directory that may be effecting this.

Discovered the C:\Documents and Settings\[MachineName]\ASPNET\Temp folder
for the ASPNET user profile. Added full permissions to the directory for the
impersonation user and this is now working fine. I have reversed the
registry changes I made to the SOFTWARE\ODBC key and still working Ok.

Not sure if this is what you meant but it lead me to the correct config.

Thankyou, much apprecated.
Nov 19 '05 #3

P: n/a
That wasn't exactly what I meant, but that's the way
things work when programmers help programmers.

One programmer has a problem and another one suggests something
which, even though it's not 100% on target, leads the questioner
to thinking in a parallel direction and to finding a solution.

I've seen that happen a lot and it's happened to me, too.

Sometimes seeing a solution to a *different* problem,
gets us thinking in a way which helps solve our *current* problem.

Glad to know that your problem was resolved.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"stueyh" <st****@discussions.microsoft.com> wrote in message
news:E8**********************************@microsof t.com...
Thanks for the reply. Checked the system temp directory and this had the
required permissions. Then checked for any other profiles that may also
contain a temp directory that may be effecting this.

Discovered the C:\Documents and Settings\[MachineName]\ASPNET\Temp folder
for the ASPNET user profile. Added full permissions to the directory for the
impersonation user and this is now working fine. I have reversed the
registry changes I made to the SOFTWARE\ODBC key and still working Ok.

Not sure if this is what you meant but it lead me to the correct config.

Thankyou, much apprecated.

Nov 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.