By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,500 Members | 1,571 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,500 IT Pros & Developers. It's quick & easy.

Data source not found by ASP.NET working process on IIS 6.0

P: n/a
Hi to all

I face the following problem,

the following code (very simple) is contained in
a referenced class method
Dim cn As New OdbcConnection("DSN=BOC;UID=Admin;PWD=;")
cn.Open()

When aspx page reaches the method containing those lines
I get the following server error:
ERROR [IM002] [Microsoft][ODBC Driver Manager]
Data source name not found and no default driver specified
Of course I have checked most possible reasons as DSN name and
it's existence in System DSN and User DSN.

Also checked that this DSN works for example with Access 2000 and
it does retrieve data from the source ot point (RM Relativity). Again I
checked
if the IIS 6.0 application working process is running as a user that has
also access to
those DSN's but I always get the same result.

It's strange cause there is no problem with IIS 5 and this came up when
the web app was transferred to an Win Server 2003 with IIS 6. Could
it be some security tuning that I have overseen?

Please any ideas on that error will save my day ;-).
Nick
np*****@hol.gr
Nov 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.