By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,327 Members | 2,661 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,327 IT Pros & Developers. It's quick & easy.

SelectedIndexChanged NOT Firing

P: n/a
Hi,

SelectedIndexChanged NOT Firing in my DropDown ListBox
AutoPostBack = true
EnableViewState = True

Autpostback works, but the SelectedIndexChanged Event does not fire !!!

regards
Paul

Nov 19 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Hi!

Have you tried to set breakpoint in both page load and drop down event
handler to see what happened?
Regards,
Sin Min

"Paul Matthews" wrote:
Hi,

SelectedIndexChanged NOT Firing in my DropDown ListBox
AutoPostBack = true
EnableViewState = True

Autpostback works, but the SelectedIndexChanged Event does not fire !!!

regards
Paul

Nov 19 '05 #2

P: n/a
yes i tried that,
the page load event gets fires,
but it just skips the SelectedIndexChanged event for the dropdown
"Paul Matthews" wrote:
Hi,

SelectedIndexChanged NOT Firing in my DropDown ListBox
AutoPostBack = true
EnableViewState = True

Autpostback works, but the SelectedIndexChanged Event does not fire !!!

regards
Paul

Nov 19 '05 #3

P: n/a
Paul Show some SelectedIndexChanged code.
Patrick

*** Sent via Developersdex http://www.developersdex.com ***
Nov 19 '05 #4

P: n/a
Dan
Make sure you're not databinding again on the postback; also make sure you
choose a different element--if you simply re-choose the same element (just
open the dropdown, the event won't get fired
"Patrick Olurotimi Ige" <na********@hotmail.com> wrote in message
news:ea**************@TK2MSFTNGP09.phx.gbl...
Paul Show some SelectedIndexChanged code.
Patrick

*** Sent via Developersdex http://www.developersdex.com ***

Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.