By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,934 Members | 1,449 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,934 IT Pros & Developers. It's quick & easy.

Error msg says "Web server not using ASP.Net ver 1.1" - Problem

P: n/a
I loaded visual studio.Net 2003 on a windows XP workstation, and I was able
to run aspx applications. Later I loaded JBuilder 2005 (Enterprise Java
builder 2005) which runs the Tomcat 5.0 web server (and some other servers -
for RMI, application servers). I was still able to run vb.net and C# apps in
vs2003. Then, yesterday (Thurs May 12, 2005), I tried running an old aspx
app for the first time in months since loading JBuilder and got the following
error message:

"The Web server is not using ASP.Net version 1.1 and you will not be able to
run aspx apps"

But I can still run asp apps. I downloaded asp.net version 1.1 from the
internet - basically re-installing the .net framework. Still get the error
message when trying to run an aspx app. So I re-loaded vs2003. Still
getting the error message. One question is if Tomcat has taken over the
default port 80 maybe? Does anyone know what the correct fix would be for
this problem? Is it a configuration/re-configuration thing for IIS? Is
there something else I need to re-install, or an update/upgrade? Any
suggestions appreciated.

Thanks,
Rich
Nov 19 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
re:
One question is if Tomcat has taken over the
default port 80 maybe?
If you can run asp apps OK, it's not a port problem
( Assuming you're not running asp apps on non-standard http ports ).

I question running two webservers simultaneously, though.

That almost always leads to configuration problems.
Usually they're solved by specifying different ports for each server.

I'd look into re-registering ASP.NET 1.1
( aspnet_regiis -i from the Framework directory... )


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Rich" <Ri**@discussions.microsoft.com> wrote in message
news:61**********************************@microsof t.com...I loaded visual studio.Net 2003 on a windows XP workstation, and I was able
to run aspx applications. Later I loaded JBuilder 2005 (Enterprise Java
builder 2005) which runs the Tomcat 5.0 web server (and some other servers -
for RMI, application servers). I was still able to run vb.net and C# apps in
vs2003. Then, yesterday (Thurs May 12, 2005), I tried running an old aspx
app for the first time in months since loading JBuilder and got the following
error message:

"The Web server is not using ASP.Net version 1.1 and you will not be able to
run aspx apps"

But I can still run asp apps. I downloaded asp.net version 1.1 from the
internet - basically re-installing the .net framework. Still get the error
message when trying to run an aspx app. So I re-loaded vs2003. Still
getting the error message. One question is if Tomcat has taken over the
default port 80 maybe? Does anyone know what the correct fix would be for
this problem? Is it a configuration/re-configuration thing for IIS? Is
there something else I need to re-install, or an update/upgrade? Any
suggestions appreciated.

Thanks,
Rich

Nov 19 '05 #2

P: n/a
Thanks. I will give that a try. May I ask how I go about re-registering
ASP.Net? I am not familiar with --- aspnet_regiis -i ---- this looks
like a command I type somewhere with a switch -i. I guess when I
re-installed the Framework - that alone did not re-register asp.net? or when
I re-installed vs2003?

Sorry for my ignorance here. My guess is that I type aspnet_regiis -i
in the Run window followed by the path to the framework. What is the path
to the framework directory that I need to include?

Thanks for your help.

Rich

"Juan T. Llibre" wrote:
re:
One question is if Tomcat has taken over the
default port 80 maybe?


If you can run asp apps OK, it's not a port problem
( Assuming you're not running asp apps on non-standard http ports ).

I question running two webservers simultaneously, though.

That almost always leads to configuration problems.
Usually they're solved by specifying different ports for each server.

I'd look into re-registering ASP.NET 1.1
( aspnet_regiis -i from the Framework directory... )


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Rich" <Ri**@discussions.microsoft.com> wrote in message
news:61**********************************@microsof t.com...
I loaded visual studio.Net 2003 on a windows XP workstation, and I was able
to run aspx applications. Later I loaded JBuilder 2005 (Enterprise Java
builder 2005) which runs the Tomcat 5.0 web server (and some other servers -
for RMI, application servers). I was still able to run vb.net and C# apps in
vs2003. Then, yesterday (Thurs May 12, 2005), I tried running an old aspx
app for the first time in months since loading JBuilder and got the following
error message:

"The Web server is not using ASP.Net version 1.1 and you will not be able to
run aspx apps"

But I can still run asp apps. I downloaded asp.net version 1.1 from the
internet - basically re-installing the .net framework. Still get the error
message when trying to run an aspx app. So I re-loaded vs2003. Still
getting the error message. One question is if Tomcat has taken over the
default port 80 maybe? Does anyone know what the correct fix would be for
this problem? Is it a configuration/re-configuration thing for IIS? Is
there something else I need to re-install, or an update/upgrade? Any
suggestions appreciated.

Thanks,
Rich


Nov 19 '05 #3

P: n/a
aspnet_regiis.exe is located, for ASP.NET 1.1, at
drive:\WINDOWSDirectory\Microsoft.NET\Framework\v1 .1.4322

Open a command window and run aspnet_regiis from it.

You can run aspnet_regiis by itself ( no parameters ),
and you'll get all the parameters you can use with it.

The one which registers asp.net is aspnet_regiis -i

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Rich" <Ri**@discussions.microsoft.com> wrote in message
news:2E**********************************@microsof t.com...
Thanks. I will give that a try. May I ask how I go about re-registering
ASP.Net? I am not familiar with --- aspnet_regiis -i ---- this looks
like a command I type somewhere with a switch -i. I guess when I
re-installed the Framework - that alone did not re-register asp.net? or when
I re-installed vs2003?

Sorry for my ignorance here. My guess is that I type aspnet_regiis -i
in the Run window followed by the path to the framework. What is the path
to the framework directory that I need to include?

Thanks for your help.

Rich

"Juan T. Llibre" wrote:
re:
> One question is if Tomcat has taken over the
> default port 80 maybe?


If you can run asp apps OK, it's not a port problem
( Assuming you're not running asp apps on non-standard http ports ).

I question running two webservers simultaneously, though.

That almost always leads to configuration problems.
Usually they're solved by specifying different ports for each server.

I'd look into re-registering ASP.NET 1.1
( aspnet_regiis -i from the Framework directory... )


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Rich" <Ri**@discussions.microsoft.com> wrote in message
news:61**********************************@microsof t.com...
>I loaded visual studio.Net 2003 on a windows XP workstation, and I was able
> to run aspx applications. Later I loaded JBuilder 2005 (Enterprise Java
> builder 2005) which runs the Tomcat 5.0 web server (and some other servers -
> for RMI, application servers). I was still able to run vb.net and C# apps in
> vs2003. Then, yesterday (Thurs May 12, 2005), I tried running an old aspx
> app for the first time in months since loading JBuilder and got the following
> error message:
>
> "The Web server is not using ASP.Net version 1.1 and you will not be able to
> run aspx apps"
>
> But I can still run asp apps. I downloaded asp.net version 1.1 from the
> internet - basically re-installing the .net framework. Still get the error
> message when trying to run an aspx app. So I re-loaded vs2003. Still
> getting the error message. One question is if Tomcat has taken over the
> default port 80 maybe? Does anyone know what the correct fix would be for
> this problem? Is it a configuration/re-configuration thing for IIS? Is
> there something else I need to re-install, or an update/upgrade? Any
> suggestions appreciated.
>
> Thanks,
> Rich


Nov 19 '05 #4

P: n/a
Thank you again for your help. I am not currently at the location of the
problem workstation, so I will have to try it later. I will post the
results. In the meantime, here is what I plan to type in the command window

C:\WINDOWSDirectory\Microsoft.NET\Framework\v1.1.4 322\aspnet_regiis -i

I sure hope this works. I would really like to keep JBuilder on that same
workstation (it is the only workstation I have with XP).

Thanks again,
Rich

"Juan T. Llibre" wrote:
aspnet_regiis.exe is located, for ASP.NET 1.1, at
drive:\WINDOWSDirectory\Microsoft.NET\Framework\v1 .1.4322

Open a command window and run aspnet_regiis from it.

You can run aspnet_regiis by itself ( no parameters ),
and you'll get all the parameters you can use with it.

The one which registers asp.net is aspnet_regiis -i

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Rich" <Ri**@discussions.microsoft.com> wrote in message
news:2E**********************************@microsof t.com...
Thanks. I will give that a try. May I ask how I go about re-registering
ASP.Net? I am not familiar with --- aspnet_regiis -i ---- this looks
like a command I type somewhere with a switch -i. I guess when I
re-installed the Framework - that alone did not re-register asp.net? or when
I re-installed vs2003?

Sorry for my ignorance here. My guess is that I type aspnet_regiis -i
in the Run window followed by the path to the framework. What is the path
to the framework directory that I need to include?

Thanks for your help.

Rich

"Juan T. Llibre" wrote:
re:
> One question is if Tomcat has taken over the
> default port 80 maybe?

If you can run asp apps OK, it's not a port problem
( Assuming you're not running asp apps on non-standard http ports ).

I question running two webservers simultaneously, though.

That almost always leads to configuration problems.
Usually they're solved by specifying different ports for each server.

I'd look into re-registering ASP.NET 1.1
( aspnet_regiis -i from the Framework directory... )


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Rich" <Ri**@discussions.microsoft.com> wrote in message
news:61**********************************@microsof t.com...
>I loaded visual studio.Net 2003 on a windows XP workstation, and I was able
> to run aspx applications. Later I loaded JBuilder 2005 (Enterprise Java
> builder 2005) which runs the Tomcat 5.0 web server (and some other servers -
> for RMI, application servers). I was still able to run vb.net and C# apps in
> vs2003. Then, yesterday (Thurs May 12, 2005), I tried running an old aspx
> app for the first time in months since loading JBuilder and got the following
> error message:
>
> "The Web server is not using ASP.Net version 1.1 and you will not be able to
> run aspx apps"
>
> But I can still run asp apps. I downloaded asp.net version 1.1 from the
> internet - basically re-installing the .net framework. Still get the error
> message when trying to run an aspx app. So I re-loaded vs2003. Still
> getting the error message. One question is if Tomcat has taken over the
> default port 80 maybe? Does anyone know what the correct fix would be for
> this problem? Is it a configuration/re-configuration thing for IIS? Is
> there something else I need to re-install, or an update/upgrade? Any
> suggestions appreciated.
>
> Thanks,
> Rich


Nov 19 '05 #5

P: n/a
That should be good.

Just remember to replace "WindowsDirectory"
with the *real name* of your Windows directory ... ;-)

It could be "windows" or "winnt", or anything else, if a different
installation directory was written in during windows setup.

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Rich" <Ri**@discussions.microsoft.com> wrote in message
news:91**********************************@microsof t.com...
Thank you again for your help. I am not currently at the location of the
problem workstation, so I will have to try it later. I will post the
results. In the meantime, here is what I plan to type in the command window

C:\WINDOWSDirectory\Microsoft.NET\Framework\v1.1.4 322\aspnet_regiis -i

I sure hope this works. I would really like to keep JBuilder on that same
workstation (it is the only workstation I have with XP).

Thanks again,
Rich

"Juan T. Llibre" wrote:
aspnet_regiis.exe is located, for ASP.NET 1.1, at
drive:\WINDOWSDirectory\Microsoft.NET\Framework\v1 .1.4322

Open a command window and run aspnet_regiis from it.

You can run aspnet_regiis by itself ( no parameters ),
and you'll get all the parameters you can use with it.

The one which registers asp.net is aspnet_regiis -i

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Rich" <Ri**@discussions.microsoft.com> wrote in message
news:2E**********************************@microsof t.com...
> Thanks. I will give that a try. May I ask how I go about re-registering
> ASP.Net? I am not familiar with --- aspnet_regiis -i ---- this looks
> like a command I type somewhere with a switch -i. I guess when I
> re-installed the Framework - that alone did not re-register asp.net? or when
> I re-installed vs2003?
>
> Sorry for my ignorance here. My guess is that I type aspnet_regiis -i
> in the Run window followed by the path to the framework. What is the path
> to the framework directory that I need to include?
>
> Thanks for your help.
>
> Rich
>
>
>
> "Juan T. Llibre" wrote:
>
>> re:
>> > One question is if Tomcat has taken over the
>> > default port 80 maybe?
>>
>> If you can run asp apps OK, it's not a port problem
>> ( Assuming you're not running asp apps on non-standard http ports ).
>>
>> I question running two webservers simultaneously, though.
>>
>> That almost always leads to configuration problems.
>> Usually they're solved by specifying different ports for each server.
>>
>> I'd look into re-registering ASP.NET 1.1
>> ( aspnet_regiis -i from the Framework directory... )
>>
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> http://asp.net.do/foros/
>> Foros de ASP.NET en Español
>> Ven, y hablemos de ASP.NET...
>> ======================
>>
>> "Rich" <Ri**@discussions.microsoft.com> wrote in message
>> news:61**********************************@microsof t.com...
>> >I loaded visual studio.Net 2003 on a windows XP workstation, and I was able
>> > to run aspx applications. Later I loaded JBuilder 2005 (Enterprise Java
>> > builder 2005) which runs the Tomcat 5.0 web server (and some other servers -
>> > for RMI, application servers). I was still able to run vb.net and C# apps in
>> > vs2003. Then, yesterday (Thurs May 12, 2005), I tried running an old aspx
>> > app for the first time in months since loading JBuilder and got the following
>> > error message:
>> >
>> > "The Web server is not using ASP.Net version 1.1 and you will not be able to
>> > run aspx apps"
>> >
>> > But I can still run asp apps. I downloaded asp.net version 1.1 from the
>> > internet - basically re-installing the .net framework. Still get the error
>> > message when trying to run an aspx app. So I re-loaded vs2003. Still
>> > getting the error message. One question is if Tomcat has taken over the
>> > default port 80 maybe? Does anyone know what the correct fix would be for
>> > this problem? Is it a configuration/re-configuration thing for IIS? Is
>> > there something else I need to re-install, or an update/upgrade? Any
>> > suggestions appreciated.
>> >
>> > Thanks,
>> > Rich
>>
>>
>>


Nov 19 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.