471,122 Members | 881 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,122 software developers and data experts.

File Upload Permissions

Jay
As described in http://support.microsoft.com/kb/323246 I set the
permissions on folder that I am uploading to as full control for
Computername\ASPNET. This worked on my development laptop but not on the
production server. I was very careful to make sure the permissions were set
correctly.

In order to upload files I had to add Everyone and set permissions to full
control. Obviously, I do not want that.

Any thoughts as to why using ASPNET does not work.

Jay

Nov 19 '05 #1
2 1234
If your production server is Windows 2003 then ASP.NET runs under a
different user account by default: NetworkService
That is the account that will need the elevated permissions.

--
I hope this helps,
Steve C. Orr, MCSD, MVP
http://SteveOrr.net
"Jay" <Ar***********@microsoft.com> wrote in message
news:e%****************@TK2MSFTNGP09.phx.gbl...
As described in http://support.microsoft.com/kb/323246 I set the
permissions on folder that I am uploading to as full control for
Computername\ASPNET. This worked on my development laptop but not on the
production server. I was very careful to make sure the permissions were
set
correctly.

In order to upload files I had to add Everyone and set permissions to full
control. Obviously, I do not want that.

Any thoughts as to why using ASPNET does not work.

Jay

Nov 19 '05 #2
The first thing to do would be to figure out what user account ASP.Net is
running under on the server machine. Then assign the same permissions to it
that you assigned to the account you used on your local machine.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Jay" <Ar***********@microsoft.com> wrote in message
news:e%****************@TK2MSFTNGP09.phx.gbl...
As described in http://support.microsoft.com/kb/323246 I set the
permissions on folder that I am uploading to as full control for
Computername\ASPNET. This worked on my development laptop but not on the
production server. I was very careful to make sure the permissions were
set
correctly.

In order to upload files I had to add Everyone and set permissions to full
control. Obviously, I do not want that.

Any thoughts as to why using ASPNET does not work.

Jay

Nov 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by balzano_1 | last post: by
6 posts views Thread by jonathanmcdougall | last post: by
1 post views Thread by BW | last post: by
4 posts views Thread by Tony B | last post: by
reply views Thread by Tim Payne | last post: by
2 posts views Thread by beary | last post: by
13 posts views Thread by eclipsme | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.