By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,905 Members | 1,616 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,905 IT Pros & Developers. It's quick & easy.

ERROR: 'HTTP/1.0 503 Service Unavailable'

P: n/a
Hi,

i'm trying to create my first ASP.NET project ( HelloASPWorld project) but
an error occured when I put OK button in NewProject.
ERROR:
"The Web server reported the following error when attempting to create or
open the Web project located at the following URL:
'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
I have installed IIS first and then reinstall Visual Studio
I don't know what I have to set yet to solve this problem.

Please help me!
--
Tomas
Nov 19 '05 #1
Share this Question
Share on Google+
11 Replies


P: n/a
When I replace localhost in: 'https://localhost/HelloASPWorld' with 127.0.0.1
'https://127.0.0.1/HelloASPWorld' an error accured:

The Web server reported the following error when attempting to create or
open the Web project located at the following URL:
'https://127.0.0.1/HelloASPWorld'.'A connection with the server could not be
established'.

So can anyone help me????

Thanx, Tomas

"Tomas Kepic" wrote:
Hi,

i'm trying to create my first ASP.NET project ( HelloASPWorld project) but
an error occured when I put OK button in NewProject.
ERROR:
"The Web server reported the following error when attempting to create or
open the Web project located at the following URL:
'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
I have installed IIS first and then reinstall Visual Studio
I don't know what I have to set yet to solve this problem.

Please help me!
--
Tomas

Nov 19 '05 #2

P: n/a
Are you trying to create a secure site ?

Try http://localhost/HelloASPWorld
or http://127.0.0.1/HelloASPWorld
and see if *those* work...


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa˝ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:53**********************************@microsof t.com...
When I replace localhost in: 'https://localhost/HelloASPWorld' with
127.0.0.1
'https://127.0.0.1/HelloASPWorld' an error accured:

The Web server reported the following error when attempting to create or
open the Web project located at the following URL:
'https://127.0.0.1/HelloASPWorld'.'A connection with the server could not
be
established'.

So can anyone help me????

Thanx, Tomas

"Tomas Kepic" wrote:
Hi,

i'm trying to create my first ASP.NET project ( HelloASPWorld project)
but
an error occured when I put OK button in NewProject.
ERROR:
"The Web server reported the following error when attempting to create or
open the Web project located at the following URL:
'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
I have installed IIS first and then reinstall Visual Studio
I don't know what I have to set yet to solve this problem.

Please help me!
--
Tomas

Nov 19 '05 #3

P: n/a
Hi Juan,

first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
Thanks.

Can you tell me why alias 'localhost' doesn't work? In
"C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
127.0.0.1 localhost

Thank you, Tomas
"Juan T. Llibre" wrote:
Are you trying to create a secure site ?

Try http://localhost/HelloASPWorld
or http://127.0.0.1/HelloASPWorld
and see if *those* work...


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa├▒ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:53**********************************@microsof t.com...
When I replace localhost in: 'https://localhost/HelloASPWorld' with
127.0.0.1
'https://127.0.0.1/HelloASPWorld' an error accured:

The Web server reported the following error when attempting to create or
open the Web project located at the following URL:
'https://127.0.0.1/HelloASPWorld'.'A connection with the server could not
be
established'.

So can anyone help me????

Thanx, Tomas

"Tomas Kepic" wrote:
Hi,

i'm trying to create my first ASP.NET project ( HelloASPWorld project)
but
an error occured when I put OK button in NewProject.
ERROR:
"The Web server reported the following error when attempting to create or
open the Web project located at the following URL:
'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
I have installed IIS first and then reinstall Visual Studio
I don't know what I have to set yet to solve this problem.

Please help me!
--
Tomas


Nov 19 '05 #4

P: n/a
Your hosts file doesn't have an extension, does it ?
( You don't have hosts.txt, I assume )

If your hosts file doesn't have an extension,
there might be something wrong with your TCP/IP stack.

It's difficult to diagnose the lack of recognition for localhost.

Can you ping 127.0.0.1 ?
Can you ping localhost ?

Does your machine name work ?
http://YourMachineName/ should work, too.

Can you ping YourMachineName ?

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa˝ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:A3**********************************@microsof t.com...
Hi Juan,

first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
Thanks.

Can you tell me why alias 'localhost' doesn't work? In
"C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
127.0.0.1 localhost

Thank you, Tomas
"Juan T. Llibre" wrote:
Are you trying to create a secure site ?

Try http://localhost/HelloASPWorld
or http://127.0.0.1/HelloASPWorld
and see if *those* work...


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa˝ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:53**********************************@microsof t.com...
> When I replace localhost in: 'https://localhost/HelloASPWorld' with
> 127.0.0.1
> 'https://127.0.0.1/HelloASPWorld' an error accured:
>
> The Web server reported the following error when attempting to create
> or
> open the Web project located at the following URL:
> 'https://127.0.0.1/HelloASPWorld'.'A connection with the server could
> not
> be
> established'.
>
> So can anyone help me????
>
> Thanx, Tomas
>
>
>
> "Tomas Kepic" wrote:
>
>> Hi,
>>
>> i'm trying to create my first ASP.NET project ( HelloASPWorld project)
>> but
>> an error occured when I put OK button in NewProject.
>> ERROR:
>> "The Web server reported the following error when attempting to create
>> or
>> open the Web project located at the following URL:
>> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
>>
>>
>> I have installed IIS first and then reinstall Visual Studio
>> I don't know what I have to set yet to solve this problem.
>>
>> Please help me!
>> --
>> Tomas


Nov 19 '05 #5

P: n/a
Hi,

I can ping all from this options:
ping 127.0.0.1
ping localhost
and also ping MyMachineName

but http://myMachineName/ doesn't work!!!
And you are true, my host file doesn't have an extension. Should I rename it
to host.txt?

Tomas

"Juan T. Llibre" wrote:
Your hosts file doesn't have an extension, does it ?
( You don't have hosts.txt, I assume )

If your hosts file doesn't have an extension,
there might be something wrong with your TCP/IP stack.

It's difficult to diagnose the lack of recognition for localhost.

Can you ping 127.0.0.1 ?
Can you ping localhost ?

Does your machine name work ?
http://YourMachineName/ should work, too.

Can you ping YourMachineName ?

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa├▒ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:A3**********************************@microsof t.com...
Hi Juan,

first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
Thanks.

Can you tell me why alias 'localhost' doesn't work? In
"C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
127.0.0.1 localhost

Thank you, Tomas
"Juan T. Llibre" wrote:
Are you trying to create a secure site ?

Try http://localhost/HelloASPWorld
or http://127.0.0.1/HelloASPWorld
and see if *those* work...


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa├▒ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:53**********************************@microsof t.com...
> When I replace localhost in: 'https://localhost/HelloASPWorld' with
> 127.0.0.1
> 'https://127.0.0.1/HelloASPWorld' an error accured:
>
> The Web server reported the following error when attempting to create
> or
> open the Web project located at the following URL:
> 'https://127.0.0.1/HelloASPWorld'.'A connection with the server could
> not
> be
> established'.
>
> So can anyone help me????
>
> Thanx, Tomas
>
>
>
> "Tomas Kepic" wrote:
>
>> Hi,
>>
>> i'm trying to create my first ASP.NET project ( HelloASPWorld project)
>> but
>> an error occured when I put OK button in NewProject.
>> ERROR:
>> "The Web server reported the following error when attempting to create
>> or
>> open the Web project located at the following URL:
>> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
>>
>>
>> I have installed IIS first and then reinstall Visual Studio
>> I don't know what I have to set yet to solve this problem.
>>
>> Please help me!
>> --
>> Tomas


Nov 19 '05 #6

P: n/a
re:
Should I rename it to host.txt?
No. Do *not* rename it.

It should *not* have an extension.
It's fine as it is.

If it *did* have an extension ( like .txt,
added almost automatically by Notepad ),
*That* could be a reason for it *not* to work.

Sorry if I wasn't clear enough.

re: but http://myMachineName/ doesn't work!!!
Then, it's pretty sure there's something
screwed up in your TCP/IP stack.

That happened to me a long time ago,
using Windows 98 and ASP 1.0.

It was a pain in the you-know-what,
and I was never able to fix it

Only when I changed the OS to a Server OS,
was I able to use localhost for a web address.

Which OS are you using ? Windows XP ?

There's a patch available from Microsoft
which covers precisely that problem.

You might want to apply it, if you're running
Windows XP and have applied SP2.

It's at

http://www.microsoft.com/downloads/d...DisplayLang=en

Try that, and let us know...


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa˝ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:C1**********************************@microsof t.com... Hi,

I can ping all from this options:
ping 127.0.0.1
ping localhost
and also ping MyMachineName

but http://myMachineName/ doesn't work!!!
And you are true, my host file doesn't have an extension. Should I rename
it
to host.txt?

Tomas

"Juan T. Llibre" wrote:
Your hosts file doesn't have an extension, does it ?
( You don't have hosts.txt, I assume )

If your hosts file doesn't have an extension,
there might be something wrong with your TCP/IP stack.

It's difficult to diagnose the lack of recognition for localhost.

Can you ping 127.0.0.1 ?
Can you ping localhost ?

Does your machine name work ?
http://YourMachineName/ should work, too.

Can you ping YourMachineName ?

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa˝ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:A3**********************************@microsof t.com...
> Hi Juan,
>
> first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
> Thanks.
>
> Can you tell me why alias 'localhost' doesn't work? In
> "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
> 127.0.0.1 localhost
>
> Thank you, Tomas
>
>
> "Juan T. Llibre" wrote:
>
>> Are you trying to create a secure site ?
>>
>> Try http://localhost/HelloASPWorld
>> or http://127.0.0.1/HelloASPWorld
>> and see if *those* work...
>>
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> http://asp.net.do/foros/
>> Foros de ASP.NET en Espa˝ol
>> Ven, y hablemos de ASP.NET...
>> ======================
>>
>> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
>> news:53**********************************@microsof t.com...
>> > When I replace localhost in: 'https://localhost/HelloASPWorld' with
>> > 127.0.0.1
>> > 'https://127.0.0.1/HelloASPWorld' an error accured:
>> >
>> > The Web server reported the following error when attempting to
>> > create
>> > or
>> > open the Web project located at the following URL:
>> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server
>> > could
>> > not
>> > be
>> > established'.
>> >
>> > So can anyone help me????
>> >
>> > Thanx, Tomas
>> >
>> >
>> >
>> > "Tomas Kepic" wrote:
>> >
>> >> Hi,
>> >>
>> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
>> >> project)
>> >> but
>> >> an error occured when I put OK button in NewProject.
>> >> ERROR:
>> >> "The Web server reported the following error when attempting to
>> >> create
>> >> or
>> >> open the Web project located at the following URL:
>> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
>> >> Unavailable'."
>> >>
>> >>
>> >> I have installed IIS first and then reinstall Visual Studio
>> >> I don't know what I have to set yet to solve this problem.
>> >>
>> >> Please help me!
>> >> --
>> >> Tomas
>>
>>
>>


Nov 19 '05 #7

P: n/a
Hi,

yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.

I'll try "your" patch and I'll give you an answer if it helps.

Tomas

"Juan T. Llibre" wrote:
re:
Should I rename it to host.txt?


No. Do *not* rename it.

It should *not* have an extension.
It's fine as it is.

If it *did* have an extension ( like .txt,
added almost automatically by Notepad ),
*That* could be a reason for it *not* to work.

Sorry if I wasn't clear enough.

re:
but http://myMachineName/ doesn't work!!!


Then, it's pretty sure there's something
screwed up in your TCP/IP stack.

That happened to me a long time ago,
using Windows 98 and ASP 1.0.

It was a pain in the you-know-what,
and I was never able to fix it

Only when I changed the OS to a Server OS,
was I able to use localhost for a web address.

Which OS are you using ? Windows XP ?

There's a patch available from Microsoft
which covers precisely that problem.

You might want to apply it, if you're running
Windows XP and have applied SP2.

It's at

http://www.microsoft.com/downloads/d...DisplayLang=en

Try that, and let us know...


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa├▒ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:C1**********************************@microsof t.com...
Hi,

I can ping all from this options:
ping 127.0.0.1
ping localhost
and also ping MyMachineName

but http://myMachineName/ doesn't work!!!
And you are true, my host file doesn't have an extension. Should I rename
it
to host.txt?

Tomas

"Juan T. Llibre" wrote:
Your hosts file doesn't have an extension, does it ?
( You don't have hosts.txt, I assume )

If your hosts file doesn't have an extension,
there might be something wrong with your TCP/IP stack.

It's difficult to diagnose the lack of recognition for localhost.

Can you ping 127.0.0.1 ?
Can you ping localhost ?

Does your machine name work ?
http://YourMachineName/ should work, too.

Can you ping YourMachineName ?

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa├▒ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:A3**********************************@microsof t.com...
> Hi Juan,
>
> first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
> Thanks.
>
> Can you tell me why alias 'localhost' doesn't work? In
> "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
> 127.0.0.1 localhost
>
> Thank you, Tomas
>
>
> "Juan T. Llibre" wrote:
>
>> Are you trying to create a secure site ?
>>
>> Try http://localhost/HelloASPWorld
>> or http://127.0.0.1/HelloASPWorld
>> and see if *those* work...
>>
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> http://asp.net.do/foros/
>> Foros de ASP.NET en Espa├▒ol
>> Ven, y hablemos de ASP.NET...
>> ======================
>>
>> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
>> news:53**********************************@microsof t.com...
>> > When I replace localhost in: 'https://localhost/HelloASPWorld' with
>> > 127.0.0.1
>> > 'https://127.0.0.1/HelloASPWorld' an error accured:
>> >
>> > The Web server reported the following error when attempting to
>> > create
>> > or
>> > open the Web project located at the following URL:
>> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server
>> > could
>> > not
>> > be
>> > established'.
>> >
>> > So can anyone help me????
>> >
>> > Thanx, Tomas
>> >
>> >
>> >
>> > "Tomas Kepic" wrote:
>> >
>> >> Hi,
>> >>
>> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
>> >> project)
>> >> but
>> >> an error occured when I put OK button in NewProject.
>> >> ERROR:
>> >> "The Web server reported the following error when attempting to
>> >> create
>> >> or
>> >> open the Web project located at the following URL:
>> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
>> >> Unavailable'."
>> >>
>> >>
>> >> I have installed IIS first and then reinstall Visual Studio
>> >> I don't know what I have to set yet to solve this problem.
>> >>
>> >> Please help me!
>> >> --
>> >> Tomas
>>
>>
>>


Nov 19 '05 #8

P: n/a
It's not "my" patch.

It's an "official" Microsoft patch.

Apparently, others have had
the same problem you're reporting.

It *clicked* for me, after we'd exchanged a couple of posts,
that this patch had been made available to Windows XP SP2
users, to solve -precisely- that problem, last September.

I'll be looking forward to your confirmation that installing the
patch does, indeed, make it possible for you to connect to
localhost and to your machinename in URL addresses.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa˝ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:ED**********************************@microsof t.com...
Hi,

yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.

I'll try "your" patch and I'll give you an answer if it helps.

Tomas

"Juan T. Llibre" wrote:
re:
> Should I rename it to host.txt?


No. Do *not* rename it.

It should *not* have an extension.
It's fine as it is.

If it *did* have an extension ( like .txt,
added almost automatically by Notepad ),
*That* could be a reason for it *not* to work.

Sorry if I wasn't clear enough.

re:
> but http://myMachineName/ doesn't work!!!


Then, it's pretty sure there's something
screwed up in your TCP/IP stack.

That happened to me a long time ago,
using Windows 98 and ASP 1.0.

It was a pain in the you-know-what,
and I was never able to fix it

Only when I changed the OS to a Server OS,
was I able to use localhost for a web address.

Which OS are you using ? Windows XP ?

There's a patch available from Microsoft
which covers precisely that problem.

You might want to apply it, if you're running
Windows XP and have applied SP2.

It's at

http://www.microsoft.com/downloads/d...DisplayLang=en

Try that, and let us know...


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa˝ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:C1**********************************@microsof t.com...
> Hi,
>
> I can ping all from this options:
> ping 127.0.0.1
> ping localhost
> and also ping MyMachineName
>
> but http://myMachineName/ doesn't work!!!
>
>
> And you are true, my host file doesn't have an extension. Should I
> rename
> it
> to host.txt?
>
> Tomas
>
> "Juan T. Llibre" wrote:
>
>> Your hosts file doesn't have an extension, does it ?
>> ( You don't have hosts.txt, I assume )
>>
>> If your hosts file doesn't have an extension,
>> there might be something wrong with your TCP/IP stack.
>>
>> It's difficult to diagnose the lack of recognition for localhost.
>>
>> Can you ping 127.0.0.1 ?
>> Can you ping localhost ?
>>
>> Does your machine name work ?
>> http://YourMachineName/ should work, too.
>>
>> Can you ping YourMachineName ?
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> http://asp.net.do/foros/
>> Foros de ASP.NET en Espa˝ol
>> Ven, y hablemos de ASP.NET...
>> ======================
>>
>> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
>> news:A3**********************************@microsof t.com...
>> > Hi Juan,
>> >
>> > first option failed, but second "http://127.0.0.1/HelloASPWorld"
>> > works.
>> > Thanks.
>> >
>> > Can you tell me why alias 'localhost' doesn't work? In
>> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP
>> > address:
>> > 127.0.0.1 localhost
>> >
>> > Thank you, Tomas
>> >
>> >
>> > "Juan T. Llibre" wrote:
>> >
>> >> Are you trying to create a secure site ?
>> >>
>> >> Try http://localhost/HelloASPWorld
>> >> or http://127.0.0.1/HelloASPWorld
>> >> and see if *those* work...
>> >>
>> >>
>> >>
>> >>
>> >> Juan T. Llibre
>> >> ASP.NET MVP
>> >> http://asp.net.do/foros/
>> >> Foros de ASP.NET en Espa˝ol
>> >> Ven, y hablemos de ASP.NET...
>> >> ======================
>> >>
>> >> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in
>> >> message
>> >> news:53**********************************@microsof t.com...
>> >> > When I replace localhost in: 'https://localhost/HelloASPWorld'
>> >> > with
>> >> > 127.0.0.1
>> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
>> >> >
>> >> > The Web server reported the following error when attempting to
>> >> > create
>> >> > or
>> >> > open the Web project located at the following URL:
>> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server
>> >> > could
>> >> > not
>> >> > be
>> >> > established'.
>> >> >
>> >> > So can anyone help me????
>> >> >
>> >> > Thanx, Tomas
>> >> >
>> >> >
>> >> >
>> >> > "Tomas Kepic" wrote:
>> >> >
>> >> >> Hi,
>> >> >>
>> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
>> >> >> project)
>> >> >> but
>> >> >> an error occured when I put OK button in NewProject.
>> >> >> ERROR:
>> >> >> "The Web server reported the following error when attempting to
>> >> >> create
>> >> >> or
>> >> >> open the Web project located at the following URL:
>> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
>> >> >> Unavailable'."
>> >> >>
>> >> >>
>> >> >> I have installed IIS first and then reinstall Visual Studio
>> >> >> I don't know what I have to set yet to solve this problem.
>> >> >>
>> >> >> Please help me!
>> >> >> --
>> >> >> Tomas
>> >>
>> >>
>> >>
>>
>>
>>


Nov 19 '05 #9

P: n/a
Hello Juan,

hmm, this patch doesn't work with my problem. I installed this patch,
restarted OS and then I tried again create a new project using 'localhost'
('http://localhost/TestProject') and the same error occured: 'HTTP/1.0 503
Service Unavailable'.
Also htttp://localhost/ and http://MyMachineName/ doesn't work.

So, seems that I have just use 127.0.0.1 address if I want create some ASP
project.

Thanks Juan for your time.
Tomas

"Juan T. Llibre" wrote:
It's not "my" patch.

It's an "official" Microsoft patch.

Apparently, others have had
the same problem you're reporting.

It *clicked* for me, after we'd exchanged a couple of posts,
that this patch had been made available to Windows XP SP2
users, to solve -precisely- that problem, last September.

I'll be looking forward to your confirmation that installing the
patch does, indeed, make it possible for you to connect to
localhost and to your machinename in URL addresses.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa├▒ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:ED**********************************@microsof t.com...
Hi,

yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.

I'll try "your" patch and I'll give you an answer if it helps.

Tomas

"Juan T. Llibre" wrote:
re:
> Should I rename it to host.txt?

No. Do *not* rename it.

It should *not* have an extension.
It's fine as it is.

If it *did* have an extension ( like .txt,
added almost automatically by Notepad ),
*That* could be a reason for it *not* to work.

Sorry if I wasn't clear enough.

re:
> but http://myMachineName/ doesn't work!!!

Then, it's pretty sure there's something
screwed up in your TCP/IP stack.

That happened to me a long time ago,
using Windows 98 and ASP 1.0.

It was a pain in the you-know-what,
and I was never able to fix it

Only when I changed the OS to a Server OS,
was I able to use localhost for a web address.

Which OS are you using ? Windows XP ?

There's a patch available from Microsoft
which covers precisely that problem.

You might want to apply it, if you're running
Windows XP and have applied SP2.

It's at

http://www.microsoft.com/downloads/d...DisplayLang=en

Try that, and let us know...


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa├▒ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:C1**********************************@microsof t.com...
> Hi,
>
> I can ping all from this options:
> ping 127.0.0.1
> ping localhost
> and also ping MyMachineName
>
> but http://myMachineName/ doesn't work!!!
>
>
> And you are true, my host file doesn't have an extension. Should I
> rename
> it
> to host.txt?
>
> Tomas
>
> "Juan T. Llibre" wrote:
>
>> Your hosts file doesn't have an extension, does it ?
>> ( You don't have hosts.txt, I assume )
>>
>> If your hosts file doesn't have an extension,
>> there might be something wrong with your TCP/IP stack.
>>
>> It's difficult to diagnose the lack of recognition for localhost.
>>
>> Can you ping 127.0.0.1 ?
>> Can you ping localhost ?
>>
>> Does your machine name work ?
>> http://YourMachineName/ should work, too.
>>
>> Can you ping YourMachineName ?
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> http://asp.net.do/foros/
>> Foros de ASP.NET en Espa├▒ol
>> Ven, y hablemos de ASP.NET...
>> ======================
>>
>> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
>> news:A3**********************************@microsof t.com...
>> > Hi Juan,
>> >
>> > first option failed, but second "http://127.0.0.1/HelloASPWorld"
>> > works.
>> > Thanks.
>> >
>> > Can you tell me why alias 'localhost' doesn't work? In
>> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP
>> > address:
>> > 127.0.0.1 localhost
>> >
>> > Thank you, Tomas
>> >
>> >
>> > "Juan T. Llibre" wrote:
>> >
>> >> Are you trying to create a secure site ?
>> >>
>> >> Try http://localhost/HelloASPWorld
>> >> or http://127.0.0.1/HelloASPWorld
>> >> and see if *those* work...
>> >>
>> >>
>> >>
>> >>
>> >> Juan T. Llibre
>> >> ASP.NET MVP
>> >> http://asp.net.do/foros/
>> >> Foros de ASP.NET en Espa├▒ol
>> >> Ven, y hablemos de ASP.NET...
>> >> ======================
>> >>
>> >> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in
>> >> message
>> >> news:53**********************************@microsof t.com...
>> >> > When I replace localhost in: 'https://localhost/HelloASPWorld'
>> >> > with
>> >> > 127.0.0.1
>> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
>> >> >
>> >> > The Web server reported the following error when attempting to
>> >> > create
>> >> > or
>> >> > open the Web project located at the following URL:
>> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server
>> >> > could
>> >> > not
>> >> > be
>> >> > established'.
>> >> >
>> >> > So can anyone help me????
>> >> >
>> >> > Thanx, Tomas
>> >> >
>> >> >
>> >> >
>> >> > "Tomas Kepic" wrote:
>> >> >
>> >> >> Hi,
>> >> >>
>> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
>> >> >> project)
>> >> >> but
>> >> >> an error occured when I put OK button in NewProject.
>> >> >> ERROR:
>> >> >> "The Web server reported the following error when attempting to
>> >> >> create
>> >> >> or
>> >> >> open the Web project located at the following URL:
>> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
>> >> >> Unavailable'."
>> >> >>
>> >> >>
>> >> >> I have installed IIS first and then reinstall Visual Studio
>> >> >> I don't know what I have to set yet to solve this problem.
>> >> >>
>> >> >> Please help me!
>> >> >> --
>> >> >> Tomas
>> >>
>> >>
>> >>
>>
>>
>>


Nov 19 '05 #10

P: n/a
Hmmm...

Sorry to hear that.
I was hopeful that the patch would be the solution.

I'll see what I can do to explain your problem to
the development teams, and see if some sort
of answer comes out of that.

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa˝ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:D6**********************************@microsof t.com...
Hello Juan,

hmm, this patch doesn't work with my problem. I installed this patch,
restarted OS and then I tried again create a new project using 'localhost'
('http://localhost/TestProject') and the same error occured: 'HTTP/1.0 503
Service Unavailable'.
Also htttp://localhost/ and http://MyMachineName/ doesn't work.

So, seems that I have just use 127.0.0.1 address if I want create some ASP
project.

Thanks Juan for your time.
Tomas "Juan T. Llibre" wrote:
It's not "my" patch.

It's an "official" Microsoft patch.

Apparently, others have had
the same problem you're reporting.

It *clicked* for me, after we'd exchanged a couple of posts,
that this patch had been made available to Windows XP SP2
users, to solve -precisely- that problem, last September.

I'll be looking forward to your confirmation that installing the
patch does, indeed, make it possible for you to connect to
localhost and to your machinename in URL addresses.

Juan T. Llibre
===========

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:ED**********************************@microsof t.com...
> Hi,
>
> yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.
>
> I'll try "your" patch and I'll give you an answer if it helps.
>
> Tomas
>
> "Juan T. Llibre" wrote:
>
>> re:
>> > Should I rename it to host.txt?
>>
>> No. Do *not* rename it.
>>
>> It should *not* have an extension.
>> It's fine as it is.
>>
>> If it *did* have an extension ( like .txt,
>> added almost automatically by Notepad ),
>> *That* could be a reason for it *not* to work.
>>
>> Sorry if I wasn't clear enough.
>>
>> re:
>> > but http://myMachineName/ doesn't work!!!
>>
>> Then, it's pretty sure there's something
>> screwed up in your TCP/IP stack.
>>
>> That happened to me a long time ago,
>> using Windows 98 and ASP 1.0.
>>
>> It was a pain in the you-know-what,
>> and I was never able to fix it
>>
>> Only when I changed the OS to a Server OS,
>> was I able to use localhost for a web address.
>>
>> Which OS are you using ? Windows XP ?
>>
>> There's a patch available from Microsoft
>> which covers precisely that problem.
>>
>> You might want to apply it, if you're running
>> Windows XP and have applied SP2.
>>
>> It's at
>>
>> http://www.microsoft.com/downloads/d...DisplayLang=en
>>
>> Try that, and let us know...
>>
>> Juan T. Llibre
>> ==========
>>
>> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
>> news:C1**********************************@microsof t.com...
>> > Hi,
>> >
>> > I can ping all from this options:
>> > ping 127.0.0.1
>> > ping localhost
>> > and also ping MyMachineName
>> >
>> > but http://myMachineName/ doesn't work!!!
>> >
>> >
>> > And you are true, my host file doesn't have an extension. Should I
>> > rename
>> > it
>> > to host.txt?
>> >
>> > Tomas
>> >
>> > "Juan T. Llibre" wrote:
>> >
>> >> Your hosts file doesn't have an extension, does it ?
>> >> ( You don't have hosts.txt, I assume )
>> >>
>> >> If your hosts file doesn't have an extension,
>> >> there might be something wrong with your TCP/IP stack.
>> >>
>> >> It's difficult to diagnose the lack of recognition for localhost.
>> >>
>> >> Can you ping 127.0.0.1 ?
>> >> Can you ping localhost ?
>> >>
>> >> Does your machine name work ?
>> >> http://YourMachineName/ should work, too.
>> >>
>> >> Can you ping YourMachineName ?
>> >>
>> >> Juan T. Llibre
>> >> ==========
>> >>
>> >> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in
>> >> message
>> >> news:A3**********************************@microsof t.com...
>> >> > Hi Juan,
>> >> >
>> >> > first option failed, but second "http://127.0.0.1/HelloASPWorld"
>> >> > works.
>> >> > Thanks.
>> >> >
>> >> > Can you tell me why alias 'localhost' doesn't work? In
>> >> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP
>> >> > address:
>> >> > 127.0.0.1 localhost
>> >> >
>> >> > Thank you, Tomas
>> >> >
>> >> >
>> >> > "Juan T. Llibre" wrote:
>> >> >
>> >> >> Are you trying to create a secure site ?
>> >> >>
>> >> >> Try http://localhost/HelloASPWorld
>> >> >> or http://127.0.0.1/HelloASPWorld
>> >> >> and see if *those* work...
>> >> >>
>> >> >> Juan T. Llibre
>> >> >> ===========
>> >> >>
>> >> >> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in
>> >> >> message
>> >> >> news:53**********************************@microsof t.com...
>> >> >> > When I replace localhost in: 'https://localhost/HelloASPWorld'
>> >> >> > with
>> >> >> > 127.0.0.1
>> >> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
>> >> >> >
>> >> >> > The Web server reported the following error when attempting to
>> >> >> > create
>> >> >> > or
>> >> >> > open the Web project located at the following URL:
>> >> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the
>> >> >> > server
>> >> >> > could
>> >> >> > not
>> >> >> > be
>> >> >> > established'.
>> >> >> >
>> >> >> > So can anyone help me????
>> >> >> >
>> >> >> > Thanx, Tomas
>> >> >> >
>> >> >> >
>> >> >> >
>> >> >> > "Tomas Kepic" wrote:
>> >> >> >
>> >> >> >> Hi,
>> >> >> >>
>> >> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
>> >> >> >> project)
>> >> >> >> but
>> >> >> >> an error occured when I put OK button in NewProject.
>> >> >> >> ERROR:
>> >> >> >> "The Web server reported the following error when attempting
>> >> >> >> to
>> >> >> >> create
>> >> >> >> or
>> >> >> >> open the Web project located at the following URL:
>> >> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
>> >> >> >> Unavailable'."
>> >> >> >>
>> >> >> >>
>> >> >> >> I have installed IIS first and then reinstall Visual Studio
>> >> >> >> I don't know what I have to set yet to solve this problem.
>> >> >> >>
>> >> >> >> Please help me!
>> >> >> >> --
>> >> >> >> Tomas

Nov 19 '05 #11

P: n/a
Thanx, Tomas

"Juan T. Llibre" wrote:
Hmmm...

Sorry to hear that.
I was hopeful that the patch would be the solution.

I'll see what I can do to explain your problem to
the development teams, and see if some sort
of answer comes out of that.

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Espa├▒ol
Ven, y hablemos de ASP.NET...
======================

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:D6**********************************@microsof t.com...
Hello Juan,

hmm, this patch doesn't work with my problem. I installed this patch,
restarted OS and then I tried again create a new project using 'localhost'
('http://localhost/TestProject') and the same error occured: 'HTTP/1.0 503
Service Unavailable'.
Also htttp://localhost/ and http://MyMachineName/ doesn't work.

So, seems that I have just use 127.0.0.1 address if I want create some ASP
project.

Thanks Juan for your time.
Tomas

"Juan T. Llibre" wrote:
It's not "my" patch.

It's an "official" Microsoft patch.

Apparently, others have had
the same problem you're reporting.

It *clicked* for me, after we'd exchanged a couple of posts,
that this patch had been made available to Windows XP SP2
users, to solve -precisely- that problem, last September.

I'll be looking forward to your confirmation that installing the
patch does, indeed, make it possible for you to connect to
localhost and to your machinename in URL addresses.

Juan T. Llibre
===========

"Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
news:ED**********************************@microsof t.com...
> Hi,
>
> yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.
>
> I'll try "your" patch and I'll give you an answer if it helps.
>
> Tomas
>
> "Juan T. Llibre" wrote:
>
>> re:
>> > Should I rename it to host.txt?
>>
>> No. Do *not* rename it.
>>
>> It should *not* have an extension.
>> It's fine as it is.
>>
>> If it *did* have an extension ( like .txt,
>> added almost automatically by Notepad ),
>> *That* could be a reason for it *not* to work.
>>
>> Sorry if I wasn't clear enough.
>>
>> re:
>> > but http://myMachineName/ doesn't work!!!
>>
>> Then, it's pretty sure there's something
>> screwed up in your TCP/IP stack.
>>
>> That happened to me a long time ago,
>> using Windows 98 and ASP 1.0.
>>
>> It was a pain in the you-know-what,
>> and I was never able to fix it
>>
>> Only when I changed the OS to a Server OS,
>> was I able to use localhost for a web address.
>>
>> Which OS are you using ? Windows XP ?
>>
>> There's a patch available from Microsoft
>> which covers precisely that problem.
>>
>> You might want to apply it, if you're running
>> Windows XP and have applied SP2.
>>
>> It's at
>>
>> http://www.microsoft.com/downloads/d...DisplayLang=en
>>
>> Try that, and let us know...
>>
>> Juan T. Llibre
>> ==========
>>
>> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in message
>> news:C1**********************************@microsof t.com...
>> > Hi,
>> >
>> > I can ping all from this options:
>> > ping 127.0.0.1
>> > ping localhost
>> > and also ping MyMachineName
>> >
>> > but http://myMachineName/ doesn't work!!!
>> >
>> >
>> > And you are true, my host file doesn't have an extension. Should I
>> > rename
>> > it
>> > to host.txt?
>> >
>> > Tomas
>> >
>> > "Juan T. Llibre" wrote:
>> >
>> >> Your hosts file doesn't have an extension, does it ?
>> >> ( You don't have hosts.txt, I assume )
>> >>
>> >> If your hosts file doesn't have an extension,
>> >> there might be something wrong with your TCP/IP stack.
>> >>
>> >> It's difficult to diagnose the lack of recognition for localhost.
>> >>
>> >> Can you ping 127.0.0.1 ?
>> >> Can you ping localhost ?
>> >>
>> >> Does your machine name work ?
>> >> http://YourMachineName/ should work, too.
>> >>
>> >> Can you ping YourMachineName ?
>> >>
>> >> Juan T. Llibre
>> >> ==========
>> >>
>> >> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in
>> >> message
>> >> news:A3**********************************@microsof t.com...
>> >> > Hi Juan,
>> >> >
>> >> > first option failed, but second "http://127.0.0.1/HelloASPWorld"
>> >> > works.
>> >> > Thanks.
>> >> >
>> >> > Can you tell me why alias 'localhost' doesn't work? In
>> >> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP
>> >> > address:
>> >> > 127.0.0.1 localhost
>> >> >
>> >> > Thank you, Tomas
>> >> >
>> >> >
>> >> > "Juan T. Llibre" wrote:
>> >> >
>> >> >> Are you trying to create a secure site ?
>> >> >>
>> >> >> Try http://localhost/HelloASPWorld
>> >> >> or http://127.0.0.1/HelloASPWorld
>> >> >> and see if *those* work...
>> >> >>
>> >> >> Juan T. Llibre
>> >> >> ===========
>> >> >>
>> >> >> "Tomas Kepic" <To********@discussions.microsoft.com> wrote in
>> >> >> message
>> >> >> news:53**********************************@microsof t.com...
>> >> >> > When I replace localhost in: 'https://localhost/HelloASPWorld'
>> >> >> > with
>> >> >> > 127.0.0.1
>> >> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
>> >> >> >
>> >> >> > The Web server reported the following error when attempting to
>> >> >> > create
>> >> >> > or
>> >> >> > open the Web project located at the following URL:
>> >> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the
>> >> >> > server
>> >> >> > could
>> >> >> > not
>> >> >> > be
>> >> >> > established'.
>> >> >> >
>> >> >> > So can anyone help me????
>> >> >> >
>> >> >> > Thanx, Tomas
>> >> >> >
>> >> >> >
>> >> >> >
>> >> >> > "Tomas Kepic" wrote:
>> >> >> >
>> >> >> >> Hi,
>> >> >> >>
>> >> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
>> >> >> >> project)
>> >> >> >> but
>> >> >> >> an error occured when I put OK button in NewProject.
>> >> >> >> ERROR:
>> >> >> >> "The Web server reported the following error when attempting
>> >> >> >> to
>> >> >> >> create
>> >> >> >> or
>> >> >> >> open the Web project located at the following URL:
>> >> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
>> >> >> >> Unavailable'."
>> >> >> >>
>> >> >> >>
>> >> >> >> I have installed IIS first and then reinstall Visual Studio
>> >> >> >> I don't know what I have to set yet to solve this problem.
>> >> >> >>
>> >> >> >> Please help me!
>> >> >> >> --
>> >> >> >> Tomas


Nov 19 '05 #12

This discussion thread is closed

Replies have been disabled for this discussion.