467,907 Members | 1,418 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,907 developers. It's quick & easy.

After upgrading, error 403.1

After upgrading to IIS 6.0 /Windows Server 2003 Standard
Ed, I get the following error message for regular .asp
pages. How can I fix this?

HTTP Error 403
403.1 Forbidden: Execute Access Forbidden

This error can be caused if you try to execute a CGI,
ISAPI, or other executable program from a directory that
does not allow programs to be executed.

Please contact the Web server's administrator if the
problem persists

Nov 19 '05 #1
  • viewed: 1586
Share:
13 Replies
This error can be caused if you try to execute a CGI, ISAPI, or other
executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory in
which this exception is occurring, to allow programs to be executed.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message
news:06****************************@phx.gbl...
After upgrading to IIS 6.0 /Windows Server 2003 Standard
Ed, I get the following error message for regular .asp
pages. How can I fix this?

HTTP Error 403
403.1 Forbidden: Execute Access Forbidden

This error can be caused if you try to execute a CGI,
ISAPI, or other executable program from a directory that
does not allow programs to be executed.

Please contact the Web server's administrator if the
problem persists

Nov 19 '05 #2
Kevin - He noted that he was running .asp pages and getting the error.

Shawn - This can be related to a myriad of things. First off, in the Home
Directory tab of your website settings, be sure that "Scripts Only" is
selected as the Execute Permissions (assuming you don't actually need
executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:
This error can be caused if you try to execute a CGI, ISAPI, or other
executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory in
which this exception is occurring, to allow programs to be executed.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message
news:06****************************@phx.gbl...
After upgrading to IIS 6.0 /Windows Server 2003 Standard
Ed, I get the following error message for regular .asp
pages. How can I fix this?

HTTP Error 403
403.1 Forbidden: Execute Access Forbidden

This error can be caused if you try to execute a CGI,
ISAPI, or other executable program from a directory that
does not allow programs to be executed.

Please contact the Web server's administrator if the
problem persists


Nov 19 '05 #3
This is set to "Scripts Only". ANy other suggestions?

The page is a simple webpage <%=date()%>
It is on the root of the directory called test.asp

Shawn

-----Original Message-----
Kevin - He noted that he was running .asp pages and getting the error.
Shawn - This can be related to a myriad of things. First off, in the HomeDirectory tab of your website settings, be sure that "Scripts Only" isselected as the Execute Permissions (assuming you don't actually needexecutables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:
This error can be caused if you try to execute a CGI, ISAPI, or other executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory in which this exception is occurring, to allow programs to be executed.
--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message news:06****************************@phx.gbl...
> After upgrading to IIS 6.0 /Windows Server 2003 Standard > Ed, I get the following error message for regular .asp
> pages. How can I fix this?
>
> HTTP Error 403
> 403.1 Forbidden: Execute Access Forbidden
>
> This error can be caused if you try to execute a CGI,
> ISAPI, or other executable program from a directory that > does not allow programs to be executed.
>
> Please contact the Web server's administrator if the
> problem persists
>


.

Nov 19 '05 #4
What users have persmissions on that folder after the upgrade?

Ian Suttle
http://www.IanSuttle.com

"Shawn" wrote:
This is set to "Scripts Only". ANy other suggestions?

The page is a simple webpage <%=date()%>
It is on the root of the directory called test.asp

Shawn

-----Original Message-----
Kevin - He noted that he was running .asp pages and

getting the error.

Shawn - This can be related to a myriad of things. First

off, in the Home
Directory tab of your website settings, be sure

that "Scripts Only" is
selected as the Execute Permissions (assuming you don't

actually need
executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:
This error can be caused if you try to execute a CGI, ISAPI, or other executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory in which this exception is occurring, to allow programs to be executed.
--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message news:06****************************@phx.gbl...
> After upgrading to IIS 6.0 /Windows Server 2003 Standard > Ed, I get the following error message for regular .asp
> pages. How can I fix this?
>
> HTTP Error 403
> 403.1 Forbidden: Execute Access Forbidden
>
> This error can be caused if you try to execute a CGI,
> ISAPI, or other executable program from a directory that > does not allow programs to be executed.
>
> Please contact the Web server's administrator if the
> problem persists
>

.

Nov 19 '05 #5
with iis manager, under application mapping check that .asp is still mapped
to asp.dll

-- bruce (sqlwork.com)
"Shawn" <an*******@discussions.microsoft.com> wrote in message
news:06****************************@phx.gbl...
This is set to "Scripts Only". ANy other suggestions?

The page is a simple webpage <%=date()%>
It is on the root of the directory called test.asp

Shawn

-----Original Message-----
Kevin - He noted that he was running .asp pages and

getting the error.

Shawn - This can be related to a myriad of things. First

off, in the Home
Directory tab of your website settings, be sure

that "Scripts Only" is
selected as the Execute Permissions (assuming you don't

actually need
executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:
This error can be caused if you try to execute a CGI, ISAPI, or other executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory in which this exception is occurring, to allow programs to be executed.
--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message news:06****************************@phx.gbl...
> After upgrading to IIS 6.0 /Windows Server 2003 Standard > Ed, I get the following error message for regular .asp
> pages. How can I fix this?
>
> HTTP Error 403
> 403.1 Forbidden: Execute Access Forbidden
>
> This error can be caused if you try to execute a CGI,
> ISAPI, or other executable program from a directory that > does not allow programs to be executed.
>
> Please contact the Web server's administrator if the
> problem persists
>

.

Nov 19 '05 #6
> Kevin - He noted that he was running .asp pages and getting the error.

Yes, he also noted the error, which was very specific.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Ian Suttle" <Ia*******@discussions.microsoft.com> wrote in message
news:59**********************************@microsof t.com...
Kevin - He noted that he was running .asp pages and getting the error.

Shawn - This can be related to a myriad of things. First off, in the Home
Directory tab of your website settings, be sure that "Scripts Only" is
selected as the Execute Permissions (assuming you don't actually need
executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:
This error can be caused if you try to execute a CGI, ISAPI, or other
executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory
in
which this exception is occurring, to allow programs to be executed.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message
news:06****************************@phx.gbl...
> After upgrading to IIS 6.0 /Windows Server 2003 Standard
> Ed, I get the following error message for regular .asp
> pages. How can I fix this?
>
> HTTP Error 403
> 403.1 Forbidden: Execute Access Forbidden
>
> This error can be caused if you try to execute a CGI,
> ISAPI, or other executable program from a directory that
> does not allow programs to be executed.
>
> Please contact the Web server's administrator if the
> problem persists
>


Nov 19 '05 #7
IUSR_ full control,
Administrators Full control,
System full control.

-----Original Message-----
What users have persmissions on that folder after the upgrade?
Ian Suttle
http://www.IanSuttle.com

"Shawn" wrote:
This is set to "Scripts Only". ANy other suggestions?

The page is a simple webpage <%=date()%>
It is on the root of the directory called test.asp

Shawn

>-----Original Message-----
>Kevin - He noted that he was running .asp pages and

getting the error.
>
>Shawn - This can be related to a myriad of things. First
off, in the Home
>Directory tab of your website settings, be sure

that "Scripts Only" is
>selected as the Execute Permissions (assuming you
don't actually need
>executables).
>
>Ian Suttle
>http://www.IanSuttle.com
>
>"Kevin Spencer" wrote:
>
>> This error can be caused if you try to execute a
CGI, ISAPI, or other
>> executable program from a directory that
>> does not allow programs to be executed.
>>
>> Just a wild guess here, but perhaps you should make
the virtual directory in
>> which this exception is occurring, to allow programs
to be executed.
>>
>> --
>> HTH,
>>
>> Kevin Spencer
>> Microsoft MVP
>> ..Net Developer
>> What You Seek Is What You Get.
>>
>> "Shawn" <an*******@discussions.microsoft.com> wrote
in message
>> news:06****************************@phx.gbl...
>> > After upgrading to IIS 6.0 /Windows Server 2003

Standard
>> > Ed, I get the following error message for
regular .asp >> > pages. How can I fix this?
>> >
>> > HTTP Error 403
>> > 403.1 Forbidden: Execute Access Forbidden
>> >
>> > This error can be caused if you try to execute a CGI, >> > ISAPI, or other executable program from a directory that
>> > does not allow programs to be executed.
>> >
>> > Please contact the Web server's administrator if

the >> > problem persists
>> >
>>
>>
>>
>.
>

.

Nov 19 '05 #8
IUSR_machine name has read, list and execute permissions,
actually they have full control while I'm trying to figure
out what 's going on.
-----Original Message-----
with iis manager, under application mapping check that .asp is still mappedto asp.dll

-- bruce (sqlwork.com)
"Shawn" <an*******@discussions.microsoft.com> wrote in messagenews:06****************************@phx.gbl...
This is set to "Scripts Only". ANy other suggestions?

The page is a simple webpage <%=date()%>
It is on the root of the directory called test.asp

Shawn

-----Original Message-----
Kevin - He noted that he was running .asp pages and

getting the error.

Shawn - This can be related to a myriad of things. First
off, in the Home
Directory tab of your website settings, be sure

that "Scripts Only" is
selected as the Execute Permissions (assuming you don't

actually need
executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:

This error can be caused if you try to execute a CGI,

ISAPI, or other
executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make
the virtual directory in
which this exception is occurring, to allow programs
to be executed.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in

message
news:06****************************@phx.gbl...
> After upgrading to IIS 6.0 /Windows Server 2003

Standard
> Ed, I get the following error message for

regular .asp > pages. How can I fix this?
>
> HTTP Error 403
> 403.1 Forbidden: Execute Access Forbidden
>
> This error can be caused if you try to execute a CGI, > ISAPI, or other executable program from a directory

that
> does not allow programs to be executed.
>
> Please contact the Web server's administrator if the
> problem persists
>

.

.

Nov 19 '05 #9
The error seems very specific, tells me that I don't have
execute permissions for that folder, but I do. Scripts
only is the option used and it still doesn not work. Any
suggestions?
-----Original Message-----
Kevin - He noted that he was running .asp pages and getting the error.

Yes, he also noted the error, which was very specific.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Ian Suttle" <Ia*******@discussions.microsoft.com> wrote in messagenews:59**********************************@microso ft.com...
Kevin - He noted that he was running .asp pages and

getting the error.
Shawn - This can be related to a myriad of things. First off, in the Home Directory tab of your website settings, be sure that "Scripts Only" is selected as the Execute Permissions (assuming you don't actually need executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:
This error can be caused if you try to execute a CGI, ISAPI, or other executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory in
which this exception is occurring, to allow programs to be executed.
--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message news:06****************************@phx.gbl...
> After upgrading to IIS 6.0 /Windows Server 2003 Standard > Ed, I get the following error message for regular .asp > pages. How can I fix this?
>
> HTTP Error 403
> 403.1 Forbidden: Execute Access Forbidden
>
> This error can be caused if you try to execute a CGI,
> ISAPI, or other executable program from a directory that > does not allow programs to be executed.
>
> Please contact the Web server's administrator if the
> problem persists
>

.

Nov 19 '05 #10
Have you allowed execution for
*.asp pages in the IIS MMC ?

IIS 6.0 is locked down by default,
and you must enable whatever you need to run.

Open the IIS MMC, and scroll to "Web Service Extensions"
There, allow whatever you need to run.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Shawn" <an*******@discussions.microsoft.com> wrote in message
news:0d****************************@phx.gbl...
The error seems very specific, tells me that I don't have
execute permissions for that folder, but I do. Scripts
only is the option used and it still doesn not work. Any
suggestions?
-----Original Message-----
Kevin - He noted that he was running .asp pages and getting the error.

Yes, he also noted the error, which was very specific.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Ian Suttle" <Ia*******@discussions.microsoft.com> wrote

in message
news:59**********************************@micros oft.com...
Kevin - He noted that he was running .asp pages and

getting the error.
Shawn - This can be related to a myriad of things. First off, in the Home Directory tab of your website settings, be sure that "Scripts Only" is selected as the Execute Permissions (assuming you don't actually need executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:

This error can be caused if you try to execute a CGI, ISAPI, or other executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory in
which this exception is occurring, to allow programs to be executed.
--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message news:06****************************@phx.gbl...
> After upgrading to IIS 6.0 /Windows Server 2003 Standard > Ed, I get the following error message for regular .asp > pages. How can I fix this?
>
> HTTP Error 403
> 403.1 Forbidden: Execute Access Forbidden
>
> This error can be caused if you try to execute a CGI,
> ISAPI, or other executable program from a directory that > does not allow programs to be executed.
>
> Please contact the Web server's administrator if the
> problem persists
>

.

Nov 19 '05 #11
Yes, I have allowed IIS to run .asp pages upon
installation, but it still doesn't work.
-----Original Message-----
Have you allowed execution for
*.asp pages in the IIS MMC ?

IIS 6.0 is locked down by default,
and you must enable whatever you need to run.

Open the IIS MMC, and scroll to "Web Service Extensions"
There, allow whatever you need to run.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Shawn" <an*******@discussions.microsoft.com> wrote in message news:0d****************************@phx.gbl...
The error seems very specific, tells me that I don't have execute permissions for that folder, but I do. Scripts
only is the option used and it still doesn not work. Any suggestions?
-----Original Message-----
Kevin - He noted that he was running .asp pages and

getting the error.

Yes, he also noted the error, which was very specific.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Ian Suttle" <Ia*******@discussions.microsoft.com> wrote

in message
news:594B16AC-3E51-45ED-8B8A- 3F**********@microsoft.com... Kevin - He noted that he was running .asp pages and

getting the error.

Shawn - This can be related to a myriad of things.

First off, in the Home
Directory tab of your website settings, be sure

that "Scripts Only" is
selected as the Execute Permissions (assuming you don't
actually need
executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:

> This error can be caused if you try to execute a CGI,

ISAPI, or other
> executable program from a directory that
> does not allow programs to be executed.
>
> Just a wild guess here, but perhaps you should make

the virtual directory
> in
> which this exception is occurring, to allow programs

to be executed.
>
> --
> HTH,
>
> Kevin Spencer
> Microsoft MVP
> ..Net Developer
> What You Seek Is What You Get.
>
> "Shawn" <an*******@discussions.microsoft.com> wrote
in message
> news:06****************************@phx.gbl...
> > After upgrading to IIS 6.0 /Windows Server 2003

Standard
> > Ed, I get the following error message for

regular .asp
> > pages. How can I fix this?
> >
> > HTTP Error 403
> > 403.1 Forbidden: Execute Access Forbidden
> >
> > This error can be caused if you try to execute a

CGI,> > ISAPI, or other executable program from a directory

that
> > does not allow programs to be executed.
> >
> > Please contact the Web server's administrator if the> > problem persists
> >
>
>
>
.

.

Nov 19 '05 #12
Have some patience with the users that need help. You are only "the man"
when everyone else thinks it, not when you think it about yourself.

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:
Kevin - He noted that he was running .asp pages and getting the error.


Yes, he also noted the error, which was very specific.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Ian Suttle" <Ia*******@discussions.microsoft.com> wrote in message
news:59**********************************@microsof t.com...
Kevin - He noted that he was running .asp pages and getting the error.

Shawn - This can be related to a myriad of things. First off, in the Home
Directory tab of your website settings, be sure that "Scripts Only" is
selected as the Execute Permissions (assuming you don't actually need
executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:
This error can be caused if you try to execute a CGI, ISAPI, or other
executable program from a directory that
does not allow programs to be executed.

Just a wild guess here, but perhaps you should make the virtual directory
in
which this exception is occurring, to allow programs to be executed.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Shawn" <an*******@discussions.microsoft.com> wrote in message
news:06****************************@phx.gbl...
> After upgrading to IIS 6.0 /Windows Server 2003 Standard
> Ed, I get the following error message for regular .asp
> pages. How can I fix this?
>
> HTTP Error 403
> 403.1 Forbidden: Execute Access Forbidden
>
> This error can be caused if you try to execute a CGI,
> ISAPI, or other executable program from a directory that
> does not allow programs to be executed.
>
> Please contact the Web server's administrator if the
> problem persists
>


Nov 19 '05 #13
Mind you, that is not the same as the
"Scripts Only" Execute Permissions, OK ?

If you've allowed the execution of asp pages
in the "Web Service Extensions" property page
of the IIS MMC, then you might want to try
re-registering asp.dll, in case there was a problem
with its registration :

regsvr32 asp.dll

Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Shawn" <an*******@discussions.microsoft.com> wrote in message
news:00****************************@phx.gbl...
Yes, I have allowed IIS to run .asp pages upon
installation, but it still doesn't work.
-----Original Message-----
Have you allowed execution for
*.asp pages in the IIS MMC ?

IIS 6.0 is locked down by default,
and you must enable whatever you need to run.

Open the IIS MMC, and scroll to "Web Service Extensions"
There, allow whatever you need to run.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Shawn" <an*******@discussions.microsoft.com> wrote in messagenews:0d****************************@phx.gbl...
The error seems very specific, tells me that I don't have execute permissions for that folder, but I do. Scripts
only is the option used and it still doesn not work. Any suggestions?
-----Original Message-----
Kevin - He noted that he was running .asp pages and

getting the error.

Yes, he also noted the error, which was very specific.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
What You Seek Is What You Get.

"Ian Suttle" <Ia*******@discussions.microsoft.com> wrote

in message
news:594B16AC-3E51-45ED-8B8A- 3F**********@microsoft.com... Kevin - He noted that he was running .asp pages and

getting the error.

Shawn - This can be related to a myriad of things.

First off, in the Home
Directory tab of your website settings, be sure

that "Scripts Only" is
selected as the Execute Permissions (assuming you don't
actually need
executables).

Ian Suttle
http://www.IanSuttle.com

"Kevin Spencer" wrote:

> This error can be caused if you try to execute a CGI,

ISAPI, or other
> executable program from a directory that
> does not allow programs to be executed.
>
> Just a wild guess here, but perhaps you should make

the virtual directory
> in
> which this exception is occurring, to allow programs

to be executed.
>
> --
> HTH,
>
> Kevin Spencer
> Microsoft MVP
> ..Net Developer
> What You Seek Is What You Get.
>
> "Shawn" <an*******@discussions.microsoft.com> wrote
in message
> news:06****************************@phx.gbl...
> > After upgrading to IIS 6.0 /Windows Server 2003

Standard
> > Ed, I get the following error message for

regular .asp
> > pages. How can I fix this?
> >
> > HTTP Error 403
> > 403.1 Forbidden: Execute Access Forbidden
> >
> > This error can be caused if you try to execute a

CGI,> > ISAPI, or other executable program from a directory

that
> > does not allow programs to be executed.
> >
> > Please contact the Web server's administrator if the> > problem persists

Nov 19 '05 #14

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

By using this site, you agree to our Privacy Policy and Terms of Use.