By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,357 Members | 982 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,357 IT Pros & Developers. It's quick & easy.

Problems with System.Web.Mail

P: n/a
Hi,

I am using System.Web.Mail for a email feature in an Intranet Application
(ASP.NET). I need to use NTLM Authentication:

ms.Fields.Add("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate", "2")

All work fine in my development machine, but when I run this application
from another client machine (my development machine is the "web server") it
generates the following error:

"...Could not access 'CDO.Message' object....The message could not be sent
to the SMTP Server. The transport error code was 0x80040217. The server
response was not available"

Notes: I am using "Integrated Windows authentication" at IIS level and
<authentication mode="Windows" /> , <identity impersonate="true"/> at ASP.NET
level. Other consideration, the SMTP Server is installed at another machine.

Thanks for your help.
Nov 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
ntlm does not allow credital forwarding. so the webserver must be setup as
basic (turn off ntlm), or a fixed account must be specified in the web
config.

if a fixed account is ok, then you can setup a local relay server on the iis
box, and use its creditals to email.

-- bruce (sqlwork.com)


"Tiabes" <Ti****@discussions.microsoft.com> wrote in message
news:69**********************************@microsof t.com...
| Hi,
|
| I am using System.Web.Mail for a email feature in an Intranet Application
| (ASP.NET). I need to use NTLM Authentication:
|
|
ms.Fields.Add("http://schemas.microsoft.com/cdo/configuration/smtpauthentica
te", "2")
|
| All work fine in my development machine, but when I run this application
| from another client machine (my development machine is the "web server")
it
| generates the following error:
|
| "...Could not access 'CDO.Message' object....The message could not be sent
| to the SMTP Server. The transport error code was 0x80040217. The server
| response was not available"
|
| Notes: I am using "Integrated Windows authentication" at IIS level and
| <authentication mode="Windows" /> , <identity impersonate="true"/> at
ASP.NET
| level. Other consideration, the SMTP Server is installed at another
machine.
|
| Thanks for your help.
Nov 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.