468,140 Members | 1,425 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,140 developers. It's quick & easy.

https and virtual directories

I've never done a login to a website so please bear with me. What is the
best way to go about this? Do I put all of the pages in a subdirectory that
I want secured and then put a different web.config file in there to specify
Forms authentication and deny all users? I tried to do that, but then I get
this error:

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.

So then I went into IIS and made that subdirectory a virtual directory. I
don't get that error, but no codebehind pages work then. I'm not sure why,
but then I get this error.

Parser Error
Description: An error occurred during the parsing of a resource required to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'realestate.members.WebForm2'.

Apparently the aspx page can't find the class in it's code-behind page. I
assume because it is it's own virtual directory and the path to the class
isn't correct. I've changed it to everything I could think of, but still no
go.

If anyone has any suggestions regarding this and possibly a good book that
deals with asp.net and ssl that would help, I would greatly appreciate it.

Dru

Nov 19 '05 #1
1 894
Hi Dru:

Back up and put the <authentication> element in the web.config in root
of your website - you can't use this in a subdirectory. You can use
the <authorization> element in a subdirectory.

You also need to undo making the sub-dir a v-dir. ASP.NET will think
the pages inside are in a different application and will try to load
compiled code from a bin directory that doesn't exist.

Make sense?

--
Scott
http://www.OdeToCode.com/blogs/scott/

On Tue, 15 Mar 2005 11:24:46 -0500, "Dru Snyder" <do**@neo.rr.com>
wrote:
I've never done a login to a website so please bear with me. What is the
best way to go about this? Do I put all of the pages in a subdirectory that
I want secured and then put a different web.config file in there to specify
Forms authentication and deny all users? I tried to do that, but then I get
this error:

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.

So then I went into IIS and made that subdirectory a virtual directory. I
don't get that error, but no codebehind pages work then. I'm not sure why,
but then I get this error.

Parser Error
Description: An error occurred during the parsing of a resource required to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'realestate.members.WebForm2'.

Apparently the aspx page can't find the class in it's code-behind page. I
assume because it is it's own virtual directory and the path to the class
isn't correct. I've changed it to everything I could think of, but still no
go.

If anyone has any suggestions regarding this and possibly a good book that
deals with asp.net and ssl that would help, I would greatly appreciate it.

Dru


Nov 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Gary Feldman | last post: by
14 posts views Thread by david | last post: by
27 posts views Thread by didacticone | last post: by
1 post views Thread by gcdp | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.