470,596 Members | 1,564 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,596 developers. It's quick & easy.

Auto-Format (HTML) in VS.NET

Hi. Is there any way to really disable that stupid HTML auto-formatting in
VS.NET ?

I have a page with a lot of complicated HTML (many complex tables etc) and
JScripts. If it's not formatted properly, I can get lost in a second. So I
spent probably half an hour to format my HTML to suit my tastes. I took care
to un-check both check-boxes under "Apply Automatic Formatting" -
Options/HTML-XML/Format ("When saving document" and "When switching from
design to HTML/XML view").

Still, after all my work, VS.NET re-formatted my code (i.e. made a
*COMPLETE* mess out of my carefully arranged tags).

Is there a way to completely kill this great "feature" ?

Thank you, Alex.
Nov 19 '05 #1
4 3577
Hi Alex,

Change the Page Layout of your document to FlowLayout (Default Grid Layout)

... Select Document from properties box. >> Go to Page Layout Property and
select Flow Layout.

Cheers,

Jerome. M
"Alex Nitulescu" wrote:
Hi. Is there any way to really disable that stupid HTML auto-formatting in
VS.NET ?

I have a page with a lot of complicated HTML (many complex tables etc) and
JScripts. If it's not formatted properly, I can get lost in a second. So I
spent probably half an hour to format my HTML to suit my tastes. I took care
to un-check both check-boxes under "Apply Automatic Formatting" -
Options/HTML-XML/Format ("When saving document" and "When switching from
design to HTML/XML view").

Still, after all my work, VS.NET re-formatted my code (i.e. made a
*COMPLETE* mess out of my carefully arranged tags).

Is there a way to completely kill this great "feature" ?

Thank you, Alex.

Nov 19 '05 #2
It *IS* FlowLayout already ! :-(((((((

"DotNetJerome" <reachjerome@_yahoo.com-remove-the-underscore-after@> wrote
in message news:1A**********************************@microsof t.com...
Hi Alex,

Change the Page Layout of your document to FlowLayout (Default Grid
Layout)

.. Select Document from properties box. >> Go to Page Layout Property and
select Flow Layout.

Cheers,

Jerome. M
"Alex Nitulescu" wrote:
Hi. Is there any way to really disable that stupid HTML auto-formatting
in
VS.NET ?

I have a page with a lot of complicated HTML (many complex tables etc)
and
JScripts. If it's not formatted properly, I can get lost in a second. So
I
spent probably half an hour to format my HTML to suit my tastes. I took
care
to un-check both check-boxes under "Apply Automatic Formatting" -
Options/HTML-XML/Format ("When saving document" and "When switching from
design to HTML/XML view").

Still, after all my work, VS.NET re-formatted my code (i.e. made a
*COMPLETE* mess out of my carefully arranged tags).

Is there a way to completely kill this great "feature" ?

Thank you, Alex.

Nov 19 '05 #3
I'm sorry buddy. Microsoft's answer to this is VS 2005. I would use either
dreamweaver or notepad to do your web layout. And just use VS.NET to do
your coding.

"Alex Nitulescu" <RE***********************@yahoo.com> wrote in message
news:u8*************@TK2MSFTNGP10.phx.gbl...
Hi. Is there any way to really disable that stupid HTML auto-formatting in
VS.NET ?

I have a page with a lot of complicated HTML (many complex tables etc) and
JScripts. If it's not formatted properly, I can get lost in a second. So I
spent probably half an hour to format my HTML to suit my tastes. I took
care to un-check both check-boxes under "Apply Automatic Formatting" -
Options/HTML-XML/Format ("When saving document" and "When switching from
design to HTML/XML view").

Still, after all my work, VS.NET re-formatted my code (i.e. made a
*COMPLETE* mess out of my carefully arranged tags).

Is there a way to completely kill this great "feature" ?

Thank you, Alex.

Nov 19 '05 #4
I was having the same problem and contacted MS. The solution that they
offerred was:

Insure that the <FORM> tag immediately follows the <BODY> tag.
Likewise the </FORM> tag must immediately precede the </BODY> tag.
If there are errors in the HTML (like a missing closing tag, a malformed
id, etc.)
the html will be reformatted to something you don't want.

I followed the suggestions and reformatting stopped.

I have been informed that this is a bug and that MS is looking into it. I
was also informed that .NET 2005 (Whidby) will fix the problem so it appears
that no fix will be made to .NET 2003.

HTH

Gus

"Alex Nitulescu" wrote:
Hi. Is there any way to really disable that stupid HTML auto-formatting in
VS.NET ?

I have a page with a lot of complicated HTML (many complex tables etc) and
JScripts. If it's not formatted properly, I can get lost in a second. So I
spent probably half an hour to format my HTML to suit my tastes. I took care
to un-check both check-boxes under "Apply Automatic Formatting" -
Options/HTML-XML/Format ("When saving document" and "When switching from
design to HTML/XML view").

Still, after all my work, VS.NET re-formatted my code (i.e. made a
*COMPLETE* mess out of my carefully arranged tags).

Is there a way to completely kill this great "feature" ?

Thank you, Alex.

Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Manlio Perillo | last post: by
9 posts views Thread by Alan Mackenzie | last post: by
20 posts views Thread by Vijay Kumar R. Zanvar | last post: by
5 posts views Thread by maya | last post: by
13 posts views Thread by S.Dickson | last post: by
22 posts views Thread by nospam_news | last post: by
2 posts views Thread by Piotr K | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.