By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,836 Members | 2,059 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,836 IT Pros & Developers. It's quick & easy.

State Server stopped working after installing .NET Framework 1.1 S

P: n/a
I am running an asp.net project on my localhost and using state server as
state management, it has the following code in web.config
<sessionState mode="StateServer"
stateConnectionString="tcpip=MyMachineName:42424" timeout="20"
cookieless="false" />

It had been working fine until I installed
Microsoft .Net Framework 1.1 SP1 (and Windows Update)

I got error"Unable to make the session state request to the session state
server"

I ensure that the ASP .NET State Service is running as .\ASPNET account.

Please advise.

--
Beve
Nov 19 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
Hello,

You may try to run

aspnet_regiis -r

from \Windows\Microsoft.Net\Framework\v1.1.4322 folder and reboot your
server. Will this help?

Also, you need to make if the problem occur when you save large data into
session varaint. Based on my experience, save too many data in session also
can cause such a problem.

Luke

Nov 19 '05 #2

P: n/a
Hi,
I did run aspnet_regiis -r and reboot, it did not help.

I am having a large ASP.NET app running on my localhost. The only thing I
know is my state server setting was working before I installed .Net framework
1.1 SP1 and stopped working after.

I couldn't get the login page come up so I don't think the session even get
started.
Here is the detailed trace message: (the ASP.NET State service is started on
my machine)

HttpException (0x8007274d): Unable to make the session state request to the
session state server. Please ensure that the ASP.NET State service is started
and that the client and server ports are the same. If the server is on a
remote machine, please ensure that it accepts remote requests by checking the
value of
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\aspnet_state\Parameters\AllowRemoteConnection.]

System.Web.SessionState.OutOfProcStateClientManage r.MakeRequest(StateProtocolVerb
verb, String id, StateProtocolExclusive exclusiveAccess, Int32 timeout, Int32
lockCookie, Byte[] buf, Int32 cb, Int32 networkTimeout,
SessionNDMakeRequestResults& results) +512
System.Web.SessionState.OutOfProcStateClientManage r.SetAsyncWorker(String
id, SessionStateItem item, Byte[] buf, Int32 length, Boolean inStorage) +57

System.Web.SessionState.OutOfProcStateClientManage r.System.Web.SessionState.IStateClientManager.Set( String
id, SessionStateItem item, Boolean inStorage) +142
System.Web.SessionState.SessionStateModule.OnRelea seState(Object source,
EventArgs eventArgs) +465
System.Web.SessionState.SessionStateModule.OnEndRe quest(Object source,
EventArgs eventArgs) +44

System.Web.SyncEventExecutionStep.System.Web.HttpA pplication+IExecutionStep.Execute() +60
System.Web.HttpApplication.ExecuteStep(IExecutionS tep step, Boolean&
completedSynchronously) +87

"[MSFT]" wrote:
Hello,

You may try to run

aspnet_regiis -r

from \Windows\Microsoft.Net\Framework\v1.1.4322 folder and reboot your
server. Will this help?

Also, you need to make if the problem occur when you save large data into
session varaint. Based on my experience, save too many data in session also
can cause such a problem.

Luke

Nov 19 '05 #3

P: n/a
Have you check the registry value
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servi ces\aspnet_state\Parameter
s\AllowRemoteConnection". It should be set to 1. Additionally, it the
problem occur with all the ASP.NET applications? if you create a new one,
will it also report such an problem?

Luke

Nov 19 '05 #4

P: n/a
Hi,

I reset AllowRemoteConnection = 1, it was 0. The problem still exists.

Also, I created another asp.net project. and the same problem appeared as
well.

Thanks
"[MSFT]" wrote:
Have you check the registry value
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servi ces\aspnet_state\Parameter
s\AllowRemoteConnection". It should be set to 1. Additionally, it the
problem occur with all the ASP.NET applications? if you create a new one,
will it also report such an problem?

Luke

Nov 19 '05 #5

P: n/a
If you change the config code like:

<configuration>
<sessionstate
mode="stateserver"
cookieless="false"
timeout="20"
server="127.0.0.1"
port="42424"
/>
</configuration>
What will be the result?

LUke

Nov 19 '05 #6

P: n/a
I ran without debugging and got Parser Error Message: "Unrecognized attribute
'server'".

If I changed to:

<sessionState
mode="StateServer"
cookieless="false"
timeout="20"
stateConnectionString="tcpip=127.0.0.1:42424"
/>

It was running fine.

"[MSFT]" wrote:
If you change the config code like:

<configuration>
<sessionstate
mode="stateserver"
cookieless="false"
timeout="20"
server="127.0.0.1"
port="42424"
/>
</configuration>
What will be the result?

LUke

Nov 19 '05 #7

P: n/a
Hello,

For further trouble shooting, I suggest you may download a tool named
"TCPVIEW". It can moniter the usage of TCP ports:

http://www.sysinternals.com/ntw2k/source/tcpview.shtml

You can check with the tool if the ASP.NET State Service in on the port
42424. You may find following in the log of TCPVIEW:

aspnet_state.exe:1340 TCP ComputerName:42424 sha-yxzhang-new:0 LISTENING

Also, I suggest you may try to add the account ASPNET to local
administrators group to see if this will help.

Luke

Nov 19 '05 #8

P: n/a
Thank you very much. It works after I added .ASPNET to local administrators
group.

"[MSFT]" wrote:
Hello,

For further trouble shooting, I suggest you may download a tool named
"TCPVIEW". It can moniter the usage of TCP ports:

http://www.sysinternals.com/ntw2k/source/tcpview.shtml

You can check with the tool if the ASP.NET State Service in on the port
42424. You may find following in the log of TCPVIEW:

aspnet_state.exe:1340 TCP ComputerName:42424 sha-yxzhang-new:0 LISTENING

Also, I suggest you may try to add the account ASPNET to local
administrators group to see if this will help.

Luke

Nov 19 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.