By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,948 Members | 838 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,948 IT Pros & Developers. It's quick & easy.

ProcessStartInfo & CreateNoWindow not launching new window

P: n/a
I have the following code:

Dim BrowserLauncher As New ProcessStartInfo
BrowserLauncher.FileName = URL BrowserLauncher.CreateNoWindow =
False
BrowserLauncher.UseShellExecute = True
BrowserLauncher.WindowStyle = ProcessWindowStyle.Maximized
Process.Start(BrowserLauncher)

Each time I run this, IE does NOT open a new browser window but instead
uses a current browser I already have open.

Anyone know away around this? I'm coding from VB.NET windows form
trying to launch a web page.

Note: If I don't have any browser open at all, a new browser IS
launched.

Any help would be appreciated.

7078895

Nov 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Because you are passing the url as the filename to execute, I am sure the
windows shell see's a process already exists to handle this command then
routes it straight there.

It is the same as going to start->run, then typing in a url.

If you want a new window to open each time, you will need to start the
iexplore.exe process. If you pass the URL as a command argument it will
open a new window each time as it is actually starting the iexplore.exe
process.

BrowserLauncher.Filename = "c:\program files\internet explorer\iexplore.exe"
(your own path will probably be here.)
BrowserLauncher.Arguments = URL

HTH,

bill

PS, nice cross post.

<sp***********@yahoo.com> wrote in message
news:11**********************@z14g2000cwz.googlegr oups.com...
I have the following code:

Dim BrowserLauncher As New ProcessStartInfo
BrowserLauncher.FileName = URL BrowserLauncher.CreateNoWindow =
False
BrowserLauncher.UseShellExecute = True
BrowserLauncher.WindowStyle = ProcessWindowStyle.Maximized
Process.Start(BrowserLauncher)

Each time I run this, IE does NOT open a new browser window but instead
uses a current browser I already have open.

Anyone know away around this? I'm coding from VB.NET windows form
trying to launch a web page.

Note: If I don't have any browser open at all, a new browser IS
launched.

Any help would be appreciated.

7078895

Nov 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.