By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,109 Members | 1,007 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,109 IT Pros & Developers. It's quick & easy.

ASPNET can't write in event log on win XP

P: n/a
Hi,

I'm sorry, this question is also posted in dotnet.framework, I don't know in
which newsgroup my question belongs to...

I'm trying to write in the event log and it looks like it's any of my
applications which are called by ASP.NET that are having trouble with event
log. Here's the
error:

System.InvalidOperationException: Cannot open log for source {0}. You may
not have write access. ---> System.ComponentModel.Win32Exception: Access is
denied

I didn't have this problem on windows 2000. But since I'm on Win XP now, I
have to solve this. I set full control to everyone on every drive of my
computer and it still not working...

Any idea of how to set permissions so ASPNET can write in event log in Win Xp?

Thanks,

Steph
Nov 19 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Hi,

I think, the following try-outs may help you:-

1. Thoroughly check the access is given to the user ASP.NET and appropriate
groups are in member-of tab.
2. Switch off the inbuild xp firewall and check whether it is working, if it
is working then your firewall configuration has to changed accordingly.
3. Run Asp setup shipped with the .net framework again.

Plz post a reply if you have any further clarifications.

Cheers!
Vadivel Kumar

"Stephane" <St******@discussions.microsoft.com> wrote in message
news:A5**********************************@microsof t.com...
Hi,

I'm sorry, this question is also posted in dotnet.framework, I don't know
in
which newsgroup my question belongs to...

I'm trying to write in the event log and it looks like it's any of my
applications which are called by ASP.NET that are having trouble with
event
log. Here's the
error:

System.InvalidOperationException: Cannot open log for source {0}. You may
not have write access. ---> System.ComponentModel.Win32Exception: Access
is
denied

I didn't have this problem on windows 2000. But since I'm on Win XP now, I
have to solve this. I set full control to everyone on every drive of my
computer and it still not working...

Any idea of how to set permissions so ASPNET can write in event log in Win
Xp?

Thanks,

Steph

Nov 19 '05 #2

P: n/a
> I didn't have this problem on windows 2000. But since I'm on Win XP now, I
have to solve this. I set full control to everyone on every drive of my
computer and it still not working...
You might want to undo that. Kind of dodgy in terms of security.

Changing file and folder permissions isn't going to help anything. You need
to change permissions for the Event Log. That's not a drive, and it's not a
folder. See the following article (which I Googled) to find out how:

http://searchvb.techtarget.com/vsnet...293033,00.html

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
Neither a follower nor a lender be.

"Stephane" <St******@discussions.microsoft.com> wrote in message
news:A5**********************************@microsof t.com... Hi,

I'm sorry, this question is also posted in dotnet.framework, I don't know
in
which newsgroup my question belongs to...

I'm trying to write in the event log and it looks like it's any of my
applications which are called by ASP.NET that are having trouble with
event
log. Here's the
error:

System.InvalidOperationException: Cannot open log for source {0}. You may
not have write access. ---> System.ComponentModel.Win32Exception: Access
is
denied

I didn't have this problem on windows 2000. But since I'm on Win XP now, I
have to solve this. I set full control to everyone on every drive of my
computer and it still not working...

Any idea of how to set permissions so ASPNET can write in event log in Win
Xp?

Thanks,

Steph

Nov 19 '05 #3

P: n/a
Indeed, I remove full control for everyone... ;-)

I tried your solution and it didn't work. I also put ASPNET in adminstrator
group and it still not working... I get the same error.

I running short of ideas!!

any other idea?

Thanks,

Steph

"Kevin Spencer" wrote:
I didn't have this problem on windows 2000. But since I'm on Win XP now, I
have to solve this. I set full control to everyone on every drive of my
computer and it still not working...


You might want to undo that. Kind of dodgy in terms of security.

Changing file and folder permissions isn't going to help anything. You need
to change permissions for the Event Log. That's not a drive, and it's not a
folder. See the following article (which I Googled) to find out how:

http://searchvb.techtarget.com/vsnet...293033,00.html

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
Neither a follower nor a lender be.

"Stephane" <St******@discussions.microsoft.com> wrote in message
news:A5**********************************@microsof t.com...
Hi,

I'm sorry, this question is also posted in dotnet.framework, I don't know
in
which newsgroup my question belongs to...

I'm trying to write in the event log and it looks like it's any of my
applications which are called by ASP.NET that are having trouble with
event
log. Here's the
error:

System.InvalidOperationException: Cannot open log for source {0}. You may
not have write access. ---> System.ComponentModel.Win32Exception: Access
is
denied

I didn't have this problem on windows 2000. But since I'm on Win XP now, I
have to solve this. I set full control to everyone on every drive of my
computer and it still not working...

Any idea of how to set permissions so ASPNET can write in event log in Win
Xp?

Thanks,

Steph


Nov 19 '05 #4

P: n/a
> I tried your solution and it didn't work. I also put ASPNET in
adminstrator
group and it still not working... I get the same error.
If you tried it and it didn't work, you didn't try it right. You might want
to make sure that the account you assigned permissions to is the account
under which your local ASP.Net app is running. Other than that, GIGO.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
Neither a follower nor a lender be.

"Stephane" <St******@discussions.microsoft.com> wrote in message
news:9D**********************************@microsof t.com... Indeed, I remove full control for everyone... ;-)

I tried your solution and it didn't work. I also put ASPNET in
adminstrator
group and it still not working... I get the same error.

I running short of ideas!!

any other idea?

Thanks,

Steph

"Kevin Spencer" wrote:
> I didn't have this problem on windows 2000. But since I'm on Win XP
> now, I
> have to solve this. I set full control to everyone on every drive of
> my
> computer and it still not working...


You might want to undo that. Kind of dodgy in terms of security.

Changing file and folder permissions isn't going to help anything. You
need
to change permissions for the Event Log. That's not a drive, and it's not
a
folder. See the following article (which I Googled) to find out how:

http://searchvb.techtarget.com/vsnet...293033,00.html

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
Neither a follower nor a lender be.

"Stephane" <St******@discussions.microsoft.com> wrote in message
news:A5**********************************@microsof t.com...
> Hi,
>
> I'm sorry, this question is also posted in dotnet.framework, I don't
> know
> in
> which newsgroup my question belongs to...
>
> I'm trying to write in the event log and it looks like it's any of my
> applications which are called by ASP.NET that are having trouble with
> event
> log. Here's the
> error:
>
> System.InvalidOperationException: Cannot open log for source {0}. You
> may
> not have write access. ---> System.ComponentModel.Win32Exception:
> Access
> is
> denied
>
> I didn't have this problem on windows 2000. But since I'm on Win XP
> now, I
> have to solve this. I set full control to everyone on every drive of
> my
> computer and it still not working...
>
> Any idea of how to set permissions so ASPNET can write in event log in
> Win
> Xp?
>
> Thanks,
>
> Steph
>
>


Nov 19 '05 #5

P: n/a
Hi,

Where can I know for sur on which account ASP.net is running?

However, I used the impersonation in web.config to solve my problem. I guess
it's not the best way to solve that, but at least it works on my developement
server.

<identity impersonate="true" userName="stephane" password="12345"/>

Thanks,

Steph
"Kevin Spencer" wrote:
I tried your solution and it didn't work. I also put ASPNET in
adminstrator
group and it still not working... I get the same error.


If you tried it and it didn't work, you didn't try it right. You might want
to make sure that the account you assigned permissions to is the account
under which your local ASP.Net app is running. Other than that, GIGO.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
Neither a follower nor a lender be.

"Stephane" <St******@discussions.microsoft.com> wrote in message
news:9D**********************************@microsof t.com...
Indeed, I remove full control for everyone... ;-)

I tried your solution and it didn't work. I also put ASPNET in
adminstrator
group and it still not working... I get the same error.

I running short of ideas!!

any other idea?

Thanks,

Steph

"Kevin Spencer" wrote:
> I didn't have this problem on windows 2000. But since I'm on Win XP
> now, I
> have to solve this. I set full control to everyone on every drive of
> my
> computer and it still not working...

You might want to undo that. Kind of dodgy in terms of security.

Changing file and folder permissions isn't going to help anything. You
need
to change permissions for the Event Log. That's not a drive, and it's not
a
folder. See the following article (which I Googled) to find out how:

http://searchvb.techtarget.com/vsnet...293033,00.html

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
Neither a follower nor a lender be.

"Stephane" <St******@discussions.microsoft.com> wrote in message
news:A5**********************************@microsof t.com...
> Hi,
>
> I'm sorry, this question is also posted in dotnet.framework, I don't
> know
> in
> which newsgroup my question belongs to...
>
> I'm trying to write in the event log and it looks like it's any of my
> applications which are called by ASP.NET that are having trouble with
> event
> log. Here's the
> error:
>
> System.InvalidOperationException: Cannot open log for source {0}. You
> may
> not have write access. ---> System.ComponentModel.Win32Exception:
> Access
> is
> denied
>
> I didn't have this problem on windows 2000. But since I'm on Win XP
> now, I
> have to solve this. I set full control to everyone on every drive of
> my
> computer and it still not working...
>
> Any idea of how to set permissions so ASPNET can write in event log in
> Win
> Xp?
>
> Thanks,
>
> Steph
>
>


Nov 19 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.