By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,943 Members | 1,921 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,943 IT Pros & Developers. It's quick & easy.

SmtpMail.Send not working. Held in Mailroot/Queue folder.

P: n/a
rh
I am not able to send email using SmtpMail.Send. I imagine that it is a
configuration issue. I see that the emails that I attempt to send are in the
Mailroot/Queue folder but they never actually get sent. I have an anti-virus
program that I disabled but it still doesn't work.

I also know that we have a spam filtering program called AppRiver SpamLab.
Could it be this?

Any suggestions? Thanks.
Nov 19 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
RH,

Some parts of your message bring me in doubt that you are using Smtp mail.
Can you show a little piece of code.

Cor
Nov 19 '05 #2

P: n/a
rh
Thanks for any assistance. Here is part of the code:

Dim loMail As New MailMessage()

loMail.From = "Fr*******@yahoo.com"

loMail.To = "To*****@yahoo.com"

loMail.Subject = "Test Email Subject"

loMail.Body = "Test Email Body"

loMail.BodyFormat = MailFormat.Html

SmtpMail.SmtpServer = "localhost"

SmtpMail.Send(loMail)
"Cor Ligthert" <no************@planet.nl> wrote in message
news:up**************@TK2MSFTNGP09.phx.gbl...
RH,

Some parts of your message bring me in doubt that you are using Smtp mail.
Can you show a little piece of code.

Cor

Nov 19 '05 #3

P: n/a
Rh,

That "localhost" is has to be an mailserver by instance IIS mailserver.

In this situation it will work only on your test environment when you have a
mailserver installed on that.

It has to be an dns name or an ip adres from a real smtp mailserver.

Cor
Nov 19 '05 #4

P: n/a
rh
Here is more info: I just checked the Event Viewer-->System and it show a
Warning that says:

"Message delivery to the remote domain 'yahoo.com' failed for the following
reason: The remote server did not respond to a connection attempt."
"Cor Ligthert" <no************@planet.nl> wrote in message
news:up**************@TK2MSFTNGP09.phx.gbl...
RH,

Some parts of your message bring me in doubt that you are using Smtp mail.
Can you show a little piece of code.

Cor

Nov 19 '05 #5

P: n/a
rh
That was it. Thanks!

"Cor Ligthert" <no************@planet.nl> wrote in message
news:eH**************@tk2msftngp13.phx.gbl...
Rh,

That "localhost" is has to be an mailserver by instance IIS mailserver.

In this situation it will work only on your test environment when you have
a mailserver installed on that.

It has to be an dns name or an ip adres from a real smtp mailserver.

Cor

Nov 19 '05 #6

P: n/a
I know you already have this solved, but for others out there who might be
experiencing the same trouble, a little more info:

I am going under the assumption here that maybe you are using an ISP who
blocks direct SMTP connections.

When you were using Localhost, you said it got to your mail queue, so that
means the local IIS SMTP host is indeed up and running. IIS can only
deliver how it is configured to deliver, so without a smart host, IIS will
attempt direct delivery. In other words, if you send a message to
yahoo.com, IIS will attempt an outbound connection on port 25 (SMTP)
directly to Yahoo!'s mail servers. As soon as you put in your ISP's mail
server into SmtpMail.SmtpServer, it started connecting through your ISP and
thus the email got through. The other alternative in this scenario is to
configure IIS to use your ISP as a smart host (in Internet Services Manager,
right click Default SMTP Virtual Server, hit properties and under the
advanced button on the delivery tab, you can put your ISP's mail server in
that box.

HTH

"rh" <rh******@smci.com> wrote in message
news:OH****************@TK2MSFTNGP10.phx.gbl...
Here is more info: I just checked the Event Viewer-->System and it show a
Warning that says:

"Message delivery to the remote domain 'yahoo.com' failed for the following reason: The remote server did not respond to a connection attempt."
"Cor Ligthert" <no************@planet.nl> wrote in message
news:up**************@TK2MSFTNGP09.phx.gbl...
RH,

Some parts of your message bring me in doubt that you are using Smtp mail. Can you show a little piece of code.

Cor


Nov 19 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.