By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,616 Members | 2,026 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,616 IT Pros & Developers. It's quick & easy.

Session.Clear not working?!

P: n/a
I have an app I'm a trying to roll out to production in which
Session.Clear() doesn't seem to be working for me.

Basically we have multiple forms that make up a registration process.
At the end of the process Session.Clear gets called and another blank
registration process is started.

This seemed to work fine on the dev box - but when we moved it to
production ... the first registration process would work fine and then
the 2nd one would start but the session was apparantly not cleared as
the previous registrants info appeared in the forms.

Session.Abandon is overkill.

I'm not sure what the difference between Session.RemoveAll and
Session.Clear is.

Anyone know what may be going on? Is there a setting I'm missing on the
production server? Session seems to be fine working on the server...
only session clear does not.

At first I thought it may be the client (browser) cacheing pages some
how so I put the no-cache meta tag on and got the same results.
Any ideas/paths to trouble shoot would be appreciated.

Nov 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.