By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,871 Members | 2,418 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,871 IT Pros & Developers. It's quick & easy.

Table within a Table - spacing

P: n/a
Sometimes I want to put a table inside a cell of another table (say, to
create 3 equal divisions, etc.).
When I want the inner table's edges to correspond exactly with the edges of
the cell, I set the border (top, left, bottom, right) to zero for both the
inner table and outer table. Also padding to 0 and spacing to 0.

But, for some reason, there is still some space between the bottom of the
inner table and the bottom of the containing cell. (Equal to about 20
pixels or so). I can't figure out how to make that space go away!

---Selden McCabe
Nov 19 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Selden, I recall experiencing something similar. If you're embedding the
tables manually, try removing all the whitespace (spaces, cr's, lf's)
between the inner </table> tag and the hosting </td>.

/// M

"Selden McCabe" <se*****@msn.com> wrote in message
news:Oe**************@TK2MSFTNGP09.phx.gbl...
Sometimes I want to put a table inside a cell of another table (say, to
create 3 equal divisions, etc.).
When I want the inner table's edges to correspond exactly with the edges of the cell, I set the border (top, left, bottom, right) to zero for both the
inner table and outer table. Also padding to 0 and spacing to 0.

But, for some reason, there is still some space between the bottom of the
inner table and the bottom of the containing cell. (Equal to about 20
pixels or so). I can't figure out how to make that space go away!

---Selden McCabe

Nov 19 '05 #2

P: n/a
Thanks for the tip.

I also found this (by trial and error):
In the table style (select table, format\build style), there is a
line-spacing property for text.
Select custom, and set this to 0.
Even though there was no text and no other types of spaces, etc. in the
table, that last row of space went away!

Thanks again, maybe these items will help others...

---Selden
"MWells" <outbound__at_sygnal.com> wrote in message
news:%2******************@TK2MSFTNGP09.phx.gbl...
Selden, I recall experiencing something similar. If you're embedding the
tables manually, try removing all the whitespace (spaces, cr's, lf's)
between the inner </table> tag and the hosting </td>.

/// M

"Selden McCabe" <se*****@msn.com> wrote in message
news:Oe**************@TK2MSFTNGP09.phx.gbl...
Sometimes I want to put a table inside a cell of another table (say, to
create 3 equal divisions, etc.).
When I want the inner table's edges to correspond exactly with the edges

of
the cell, I set the border (top, left, bottom, right) to zero for both
the
inner table and outer table. Also padding to 0 and spacing to 0.

But, for some reason, there is still some space between the bottom of the
inner table and the bottom of the containing cell. (Equal to about 20
pixels or so). I can't figure out how to make that space go away!

---Selden McCabe


Nov 19 '05 #3

P: n/a
Thanks Selden, I like your approach better. It's a much cleaner than
hacking all the whitespace from your HTML...

Great work on the research.

/// M
"Selden McCabe" <se*****@msn.com> wrote in message
news:ef**************@TK2MSFTNGP10.phx.gbl...
Thanks for the tip.

I also found this (by trial and error):
In the table style (select table, format\build style), there is a
line-spacing property for text.
Select custom, and set this to 0.
Even though there was no text and no other types of spaces, etc. in the
table, that last row of space went away!

Thanks again, maybe these items will help others...

---Selden
"MWells" <outbound__at_sygnal.com> wrote in message
news:%2******************@TK2MSFTNGP09.phx.gbl...
Selden, I recall experiencing something similar. If you're embedding the tables manually, try removing all the whitespace (spaces, cr's, lf's)
between the inner </table> tag and the hosting </td>.

/// M

"Selden McCabe" <se*****@msn.com> wrote in message
news:Oe**************@TK2MSFTNGP09.phx.gbl...
Sometimes I want to put a table inside a cell of another table (say, to
create 3 equal divisions, etc.).
When I want the inner table's edges to correspond exactly with the edges
of
the cell, I set the border (top, left, bottom, right) to zero for both
the
inner table and outer table. Also padding to 0 and spacing to 0.

But, for some reason, there is still some space between the bottom of

the inner table and the bottom of the containing cell. (Equal to about 20
pixels or so). I can't figure out how to make that space go away!

---Selden McCabe



Nov 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.