By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,058 Members | 1,217 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,058 IT Pros & Developers. It's quick & easy.

Debugging with Web.config

P: n/a
I am running Visual Studio .Net 2003 with Windows XP Pro and SP2. I am tying
to run an ASP .Net application in debug mode. In Web.Config file I have set
debug="true" but I am getting an error:
"Error while trying to run project: Unable to start debugging on the web
server. The project is not configured to be debugged." Not sure why I am
getting this error. Here is my Web.Config file:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>

<system.web>

<!-- DYNAMIC DEBUG COMPILATION
Set compilation debug="true" to insert debugging symbols (.pdb
information)
into the compiled page. Because this creates a larger file that
executes
more slowly, you should set this value to true only when debugging
and to
false at all other times. For more information, refer to the
documentation about
debugging ASP.NET files.
-->
<compilation defaultLanguage="vb" debug="true" />

<!-- CUSTOM ERROR MESSAGES
Set customErrors mode="On" or "RemoteOnly" to enable custom error
messages, "Off" to disable.
Add <error> tags for each of the errors you want to handle.
-->
<customErrors mode="RemoteOnly" />

<!-- AUTHENTICATION
This section sets the authentication policies of the application.
Possible modes are "Windows",
"Forms", "Passport" and "None"
-->
<authentication mode="Windows" />
<!-- AUTHORIZATION
This section sets the authorization policies of the application.
You can allow or deny access
to application resources by user or role. Wildcards: "*" mean
everyone, "?" means anonymous
(unauthenticated) users.
-->
<authorization>
<allow users="*" /> <!-- Allow all users -->

<!-- <allow users="[*]"
roles="[*]"/>
<deny users="[*]"
roles="[*]"/>
-->
</authorization>

<!-- APPLICATION-LEVEL TRACE LOGGING
Application-level tracing enables trace log output for every page
within an application.
Set trace enabled="true" to enable application trace logging. If
pageOutput="true", the
trace information will be displayed at the bottom of each page.
Otherwise, you can view the
application trace log by browsing the "trace.axd" page from your
web application
root.
-->
<trace enabled="true" requestLimit="10" pageOutput="true"
traceMode="SortByTime" localOnly="true" />
<!-- SESSION STATE SETTINGS
By default ASP.NET uses cookies to identify which requests belong
to a particular session.
If cookies are not available, a session can be tracked by adding a
session identifier to the URL.
To disable cookies, set sessionState cookieless="true".
-->
<sessionState
mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;user id=sa;password="
cookieless="false"
timeout="20"
/>

<!-- GLOBALIZATION
This section sets the globalization settings of the application.
-->
<globalization requestEncoding="utf-8" responseEncoding="utf-8" />

</system.web>

</configuration>

Nov 19 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Open your Internet Information Services manager and from the [your
machine]/Web Sites/ Default Web Site node select the virtual folder
which stores your project. Right Click and select Properties to select
the ASP.NET tab page. Make sure the correct version ASP.NET Version is
selected.

Hope it helps!
** If error persist post it**
Patrick

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 19 '05 #2

P: n/a
gaugust another solution is by going to:-
IE security (Tools-> Internet options-> Security -> Internet or Intranet
-> Custom level -> User authentication) is set to anonymous logon ..try
changing it to Aoutomatic or prompt. ..
GDLUCK
Patrick

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 19 '05 #3

P: n/a
Also try this (this worked for me when using VS.NET 2003):-

Run "Internet Services Manager" (under Control Panel > Administrative
Tools). If you are running on a server rather than a workstation then
this will instead be called "Internet Information Services (IIS)
Manager".
Find the project/application in the list of web sites. (Open up your
computer in the list, and look under "Default Web Site" - or "Web Sites"
if on a server).
Bring up its properties (Right click > Properties).
If the 'application name' (under "Application Settings" on the
"Directory" tab) is greyed out then click '[Create]' and then '[OK]'.

** the other solutions i posted works with VS.NET 2005 when i used it on
the same MACHINE with VS/Net 2002

Patrick

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.