By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,078 Members | 1,846 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,078 IT Pros & Developers. It's quick & easy.

Error running ASPNET_RegIIS -c

P: n/a
On one of my localhost sites I'm getting a message to run aspnet_regiis -c to
correct some scripting issues.
When I try to run the listed command I get another error:

"You must have administrative rights on this machine in order to run this
tool."

I have verified that I have administrative rights on the box as my normal
login. I have also logged in as the local administrator, tried the same thing
and get the same message.
I'm running XP Pro SP2 with VS2003. I believe the problem started after
applying SP2.

Anyone have any ideas on how to correct this?
Nov 19 '05 #1
Share this Question
Share on Google+
17 Replies


P: n/a
Did u give the ASPNET account access?
OR are u under the acct..
Enjoy
Patrick
"JStemper" wrote:
On one of my localhost sites I'm getting a message to run aspnet_regiis -c to
correct some scripting issues.
When I try to run the listed command I get another error:

"You must have administrative rights on this machine in order to run this
tool."

I have verified that I have administrative rights on the box as my normal
login. I have also logged in as the local administrator, tried the same thing
and get the same message.
I'm running XP Pro SP2 with VS2003. I believe the problem started after
applying SP2.

Anyone have any ideas on how to correct this?

Nov 19 '05 #2

P: n/a
I'm not sure what you're asking. Which directories/site/etc.. does ASPNET
need access to?

The site runs fine, except for not having the correct validation jscript
files.

When I run the ASPNET_regiis app I am logged in as the administrator or a
member of the administrator group.

Thanks for the help.
John

"Patrick.O.Ige" wrote:
Did u give the ASPNET account access?
OR are u under the acct..
Enjoy
Patrick
"JStemper" wrote:
On one of my localhost sites I'm getting a message to run aspnet_regiis -c to
correct some scripting issues.
When I try to run the listed command I get another error:

"You must have administrative rights on this machine in order to run this
tool."

I have verified that I have administrative rights on the box as my normal
login. I have also logged in as the local administrator, tried the same thing
and get the same message.
I'm running XP Pro SP2 with VS2003. I believe the problem started after
applying SP2.

Anyone have any ideas on how to correct this?

Nov 19 '05 #3

P: n/a
I'm getting the same issue when running aspnet_regiis -c. Any one from MS out
there to help?

"JStemper" wrote:
I'm not sure what you're asking. Which directories/site/etc.. does ASPNET
need access to?

The site runs fine, except for not having the correct validation jscript
files.

When I run the ASPNET_regiis app I am logged in as the administrator or a
member of the administrator group.

Thanks for the help.
John

"Patrick.O.Ige" wrote:
Did u give the ASPNET account access?
OR are u under the acct..
Enjoy
Patrick
"JStemper" wrote:
On one of my localhost sites I'm getting a message to run aspnet_regiis -c to
correct some scripting issues.
When I try to run the listed command I get another error:

"You must have administrative rights on this machine in order to run this
tool."

I have verified that I have administrative rights on the box as my normal
login. I have also logged in as the local administrator, tried the same thing
and get the same message.
I'm running XP Pro SP2 with VS2003. I believe the problem started after
applying SP2.

Anyone have any ideas on how to correct this?

Nov 19 '05 #4

P: n/a
Which error message do you get ?

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:AD**********************************@microsof t.com...
I'm getting the same issue when running aspnet_regiis -c. Any one from MS
out
there to help?

"JStemper" wrote:

I'm not sure what you're asking. Which directories/site/etc.. does ASPNET
need access to?

The site runs fine, except for not having the correct validation jscript
files.

When I run the ASPNET_regiis app I am logged in as the administrator or a
member of the administrator group.

Thanks for the help.
John

"Patrick.O.Ige" wrote:
> Did u give the ASPNET account access?
> OR are u under the acct..
> Enjoy
> Patrick
>
>
> "JStemper" wrote:
>
> > On one of my localhost sites I'm getting a message to run
> > aspnet_regiis -c to
> > correct some scripting issues.
> > When I try to run the listed command I get another error:
> >
> > "You must have administrative rights on this machine in order to run
> > this
> > tool."
> >
> > I have verified that I have administrative rights on the box as my
> > normal
> > login. I have also logged in as the local administrator, tried the
> > same thing
> > and get the same message.
> > I'm running XP Pro SP2 with VS2003. I believe the problem started
> > after
> > applying SP2.
> >
> > Anyone have any ideas on how to correct this?

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
Nov 19 '05 #5

P: n/a
An error has occurred (0x80070005).
You must have administrative rights on this machine in order to run this tool.

"Juan T. Llibre" wrote:
Which error message do you get ?

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:AD**********************************@microsof t.com...
I'm getting the same issue when running aspnet_regiis -c. Any one from MS
out
there to help?

"JStemper" wrote:

I'm not sure what you're asking. Which directories/site/etc.. does ASPNET
need access to?

The site runs fine, except for not having the correct validation jscript
files.

When I run the ASPNET_regiis app I am logged in as the administrator or a
member of the administrator group.

Thanks for the help.
John

"Patrick.O.Ige" wrote:

> Did u give the ASPNET account access?
> OR are u under the acct..
> Enjoy
> Patrick
>
>
> "JStemper" wrote:
>
> > On one of my localhost sites I'm getting a message to run
> > aspnet_regiis -c to
> > correct some scripting issues.
> > When I try to run the listed command I get another error:
> >
> > "You must have administrative rights on this machine in order to run
> > this
> > tool."
> >
> > I have verified that I have administrative rights on the box as my
> > normal
> > login. I have also logged in as the local administrator, tried the
> > same thing
> > and get the same message.
> > I'm running XP Pro SP2 with VS2003. I believe the problem started
> > after
> > applying SP2.
> >
> > Anyone have any ideas on how to correct this?

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

Nov 19 '05 #6

P: n/a
Hi, Jorriss.

Try this If you're using .NET Framework 1.1 :

Find the "system_web" directory under wwwroot.
Under it, you should find a directory named "1_1_4322".
Delete it.
Run apsnet_regiis -ea from
drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
That should kill all old 1.1.4322 scripts.

Then, run aspnet_regiis -c
That should re-install the 1_1_4322 directory and client scripts.

Let us know how you do.


Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:46**********************************@microsof t.com...
An error has occurred (0x80070005).
You must have administrative rights on this machine in order to run this
tool.

"Juan T. Llibre" wrote:
Which error message do you get ?

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:AD**********************************@microsof t.com...
> I'm getting the same issue when running aspnet_regiis -c. Any one from
> MS
> out
> there to help?
>
> "JStemper" wrote:

>> I'm not sure what you're asking. Which directories/site/etc.. does
>> ASPNET
>> need access to?
>>
>> The site runs fine, except for not having the correct validation
>> jscript
>> files.
>>
>> When I run the ASPNET_regiis app I am logged in as the administrator
>> or a
>> member of the administrator group.
>>
>> Thanks for the help.
>> John
>>
>> "Patrick.O.Ige" wrote:
>>
>> > Did u give the ASPNET account access?
>> > OR are u under the acct..
>> > Enjoy
>> > Patrick
>> >
>> >
>> > "JStemper" wrote:
>> >
>> > > On one of my localhost sites I'm getting a message to run
>> > > aspnet_regiis -c to
>> > > correct some scripting issues.
>> > > When I try to run the listed command I get another error:
>> > >
>> > > "You must have administrative rights on this machine in order to
>> > > run
>> > > this
>> > > tool."
>> > >
>> > > I have verified that I have administrative rights on the box as my
>> > > normal
>> > > login. I have also logged in as the local administrator, tried the
>> > > same thing
>> > > and get the same message.
>> > > I'm running XP Pro SP2 with VS2003. I believe the problem started
>> > > after
>> > > applying SP2.
>> > >
>> > > Anyone have any ideas on how to correct this?


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
Nov 19 '05 #7

P: n/a
Forgot to add...

Make sure the [Web Root]\aspnet_client\system_web\1_1_4322\*.js
files are NOT read-only BEFORE running the aspnet_regiis -ea
and the aspnet_regiis -c commands.
Juan T. Llibre
ASP.NET MVP
===========
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uf**************@TK2MSFTNGP11.phx.gbl...
Hi, Jorriss.

Try this If you're using .NET Framework 1.1 :

Find the "system_web" directory under wwwroot.
Under it, you should find a directory named "1_1_4322".
Delete it.
Run apsnet_regiis -ea from
drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
That should kill all old 1.1.4322 scripts.

Then, run aspnet_regiis -c
That should re-install the 1_1_4322 directory and client scripts.

Let us know how you do.


Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:46**********************************@microsof t.com...
An error has occurred (0x80070005).
You must have administrative rights on this machine in order to run this
tool.

"Juan T. Llibre" wrote:
Which error message do you get ?

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:AD**********************************@microsof t.com...
> I'm getting the same issue when running aspnet_regiis -c. Any one from
> MS
> out
> there to help?
>
> "JStemper" wrote:

>> I'm not sure what you're asking. Which directories/site/etc.. does
>> ASPNET
>> need access to?
>>
>> The site runs fine, except for not having the correct validation
>> jscript
>> files.
>>
>> When I run the ASPNET_regiis app I am logged in as the administrator
>> or a
>> member of the administrator group.
>>
>> Thanks for the help.
>> John
>>
>> "Patrick.O.Ige" wrote:
>>
>> > Did u give the ASPNET account access?
>> > OR are u under the acct..
>> > Enjoy
>> > Patrick
>> >
>> >
>> > "JStemper" wrote:
>> >
>> > > On one of my localhost sites I'm getting a message to run
>> > > aspnet_regiis -c to
>> > > correct some scripting issues.
>> > > When I try to run the listed command I get another error:
>> > >
>> > > "You must have administrative rights on this machine in order to
>> > > run
>> > > this
>> > > tool."
>> > >
>> > > I have verified that I have administrative rights on the box as
>> > > my
>> > > normal
>> > > login. I have also logged in as the local administrator, tried
>> > > the
>> > > same thing
>> > > and get the same message.
>> > > I'm running XP Pro SP2 with VS2003. I believe the problem started
>> > > after
>> > > applying SP2.
>> > >
>> > > Anyone have any ideas on how to correct this?


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
Nov 19 '05 #8

P: n/a
That was it. Thanks Juan for your help!

Jorriss

"Juan T. Llibre" wrote:
Hi, Jorriss.

Try this If you're using .NET Framework 1.1 :

Find the "system_web" directory under wwwroot.
Under it, you should find a directory named "1_1_4322".
Delete it.
Run apsnet_regiis -ea from
drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
That should kill all old 1.1.4322 scripts.

Then, run aspnet_regiis -c
That should re-install the 1_1_4322 directory and client scripts.

Let us know how you do.


Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:46**********************************@microsof t.com...
An error has occurred (0x80070005).
You must have administrative rights on this machine in order to run this
tool.

"Juan T. Llibre" wrote:
Which error message do you get ?

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:AD**********************************@microsof t.com...
> I'm getting the same issue when running aspnet_regiis -c. Any one from
> MS
> out
> there to help?
>
> "JStemper" wrote:

>> I'm not sure what you're asking. Which directories/site/etc.. does
>> ASPNET
>> need access to?
>>
>> The site runs fine, except for not having the correct validation
>> jscript
>> files.
>>
>> When I run the ASPNET_regiis app I am logged in as the administrator
>> or a
>> member of the administrator group.
>>
>> Thanks for the help.
>> John
>>
>> "Patrick.O.Ige" wrote:
>>
>> > Did u give the ASPNET account access?
>> > OR are u under the acct..
>> > Enjoy
>> > Patrick
>> >
>> >
>> > "JStemper" wrote:
>> >
>> > > On one of my localhost sites I'm getting a message to run
>> > > aspnet_regiis -c to
>> > > correct some scripting issues.
>> > > When I try to run the listed command I get another error:
>> > >
>> > > "You must have administrative rights on this machine in order to
>> > > run
>> > > this
>> > > tool."
>> > >
>> > > I have verified that I have administrative rights on the box as my
>> > > normal
>> > > login. I have also logged in as the local administrator, tried the
>> > > same thing
>> > > and get the same message.
>> > > I'm running XP Pro SP2 with VS2003. I believe the problem started
>> > > after
>> > > applying SP2.
>> > >
>> > > Anyone have any ideas on how to correct this?


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

Nov 19 '05 #9

P: n/a
You're more than welcome.

Glad to have been of help!

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:CD**********************************@microsof t.com...
That was it. Thanks Juan for your help!

Jorriss

"Juan T. Llibre" wrote:
Hi, Jorriss.

Try this If you're using .NET Framework 1.1 :

Find the "system_web" directory under wwwroot.
Under it, you should find a directory named "1_1_4322".
Delete it.
Run apsnet_regiis -ea from
drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
That should kill all old 1.1.4322 scripts.

Then, run aspnet_regiis -c
That should re-install the 1_1_4322 directory and client scripts.

Let us know how you do.
Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:46**********************************@microsof t.com...
> An error has occurred (0x80070005).
> You must have administrative rights on this machine in order to run
> this
> tool.
>
> "Juan T. Llibre" wrote:
>
>> Which error message do you get ?
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> ===========
>> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
>> news:AD**********************************@microsof t.com...
>> > I'm getting the same issue when running aspnet_regiis -c. Any one
>> > from
>> > MS
>> > out
>> > there to help?
>> >
>> > "JStemper" wrote:
>>
>> >> I'm not sure what you're asking. Which directories/site/etc.. does
>> >> ASPNET
>> >> need access to?
>> >>
>> >> The site runs fine, except for not having the correct validation
>> >> jscript
>> >> files.
>> >>
>> >> When I run the ASPNET_regiis app I am logged in as the
>> >> administrator
>> >> or a
>> >> member of the administrator group.
>> >>
>> >> Thanks for the help.
>> >> John
>> >>
>> >> "Patrick.O.Ige" wrote:
>> >>
>> >> > Did u give the ASPNET account access?
>> >> > OR are u under the acct..
>> >> > Enjoy
>> >> > Patrick
>> >> >
>> >> >
>> >> > "JStemper" wrote:
>> >> >
>> >> > > On one of my localhost sites I'm getting a message to run
>> >> > > aspnet_regiis -c to
>> >> > > correct some scripting issues.
>> >> > > When I try to run the listed command I get another error:
>> >> > >
>> >> > > "You must have administrative rights on this machine in order
>> >> > > to
>> >> > > run
>> >> > > this
>> >> > > tool."
>> >> > >
>> >> > > I have verified that I have administrative rights on the box as
>> >> > > my
>> >> > > normal
>> >> > > login. I have also logged in as the local administrator, tried
>> >> > > the
>> >> > > same thing
>> >> > > and get the same message.
>> >> > > I'm running XP Pro SP2 with VS2003. I believe the problem
>> >> > > started
>> >> > > after
>> >> > > applying SP2.
>> >> > >
>> >> > > Anyone have any ideas on how to correct this?


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
Nov 19 '05 #10

P: n/a
I've also blogged the solution on my blog
(http://jorriss.com/dottext/jorriss/a...1/06/400.aspx). Hopefully,
the next person who has this problem will find the solution through Google.

Jorriss

"Juan T. Llibre" wrote:
You're more than welcome.

Glad to have been of help!

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:CD**********************************@microsof t.com...
That was it. Thanks Juan for your help!

Jorriss

"Juan T. Llibre" wrote:
Hi, Jorriss.

Try this If you're using .NET Framework 1.1 :

Find the "system_web" directory under wwwroot.
Under it, you should find a directory named "1_1_4322".
Delete it.
Run apsnet_regiis -ea from
drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
That should kill all old 1.1.4322 scripts.

Then, run aspnet_regiis -c
That should re-install the 1_1_4322 directory and client scripts.

Let us know how you do.
Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:46**********************************@microsof t.com...
> An error has occurred (0x80070005).
> You must have administrative rights on this machine in order to run
> this
> tool.
>
> "Juan T. Llibre" wrote:
>
>> Which error message do you get ?
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> ===========
>> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
>> news:AD**********************************@microsof t.com...
>> > I'm getting the same issue when running aspnet_regiis -c. Any one
>> > from
>> > MS
>> > out
>> > there to help?
>> >
>> > "JStemper" wrote:
>>
>> >> I'm not sure what you're asking. Which directories/site/etc.. does
>> >> ASPNET
>> >> need access to?
>> >>
>> >> The site runs fine, except for not having the correct validation
>> >> jscript
>> >> files.
>> >>
>> >> When I run the ASPNET_regiis app I am logged in as the
>> >> administrator
>> >> or a
>> >> member of the administrator group.
>> >>
>> >> Thanks for the help.
>> >> John
>> >>
>> >> "Patrick.O.Ige" wrote:
>> >>
>> >> > Did u give the ASPNET account access?
>> >> > OR are u under the acct..
>> >> > Enjoy
>> >> > Patrick
>> >> >
>> >> >
>> >> > "JStemper" wrote:
>> >> >
>> >> > > On one of my localhost sites I'm getting a message to run
>> >> > > aspnet_regiis -c to
>> >> > > correct some scripting issues.
>> >> > > When I try to run the listed command I get another error:
>> >> > >
>> >> > > "You must have administrative rights on this machine in order
>> >> > > to
>> >> > > run
>> >> > > this
>> >> > > tool."
>> >> > >
>> >> > > I have verified that I have administrative rights on the box as
>> >> > > my
>> >> > > normal
>> >> > > login. I have also logged in as the local administrator, tried
>> >> > > the
>> >> > > same thing
>> >> > > and get the same message.
>> >> > > I'm running XP Pro SP2 with VS2003. I believe the problem
>> >> > > started
>> >> > > after
>> >> > > applying SP2.
>> >> > >
>> >> > > Anyone have any ideas on how to correct this?

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

Nov 19 '05 #11

P: n/a
Oz
Juan -- I don't understand the sequence.

It looks to me like you've said to delete the 1-1-4322 directory in its
entirety, THEN to be sure the files in it (which are now gone) are not
read-only, and THEN run aspnet_regiis -ea. Obviously the above sequence is
impossible.

But even when I follow any combination of these, I still get the
"administrative privileges" message. Even running the "-ea" process fails
because of this. I am definitely a local administrator (win 2K Server).

What is it that needs admin permissions exactly -- obviously it isn't me...?

"Juan T. Llibre" wrote:
Forgot to add...

Make sure the [Web Root]\aspnet_client\system_web\1_1_4322\*.js
files are NOT read-only BEFORE running the aspnet_regiis -ea
and the aspnet_regiis -c commands.
Juan T. Llibre
ASP.NET MVP
===========
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uf**************@TK2MSFTNGP11.phx.gbl...
Hi, Jorriss.

Try this If you're using .NET Framework 1.1 :

Find the "system_web" directory under wwwroot.
Under it, you should find a directory named "1_1_4322".
Delete it.
Run apsnet_regiis -ea from
drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
That should kill all old 1.1.4322 scripts.

Then, run aspnet_regiis -c
That should re-install the 1_1_4322 directory and client scripts.

Let us know how you do.


Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:46**********************************@microsof t.com...
An error has occurred (0x80070005).
You must have administrative rights on this machine in order to run this
tool.

"Juan T. Llibre" wrote:

Which error message do you get ?

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:AD**********************************@microsof t.com...
> I'm getting the same issue when running aspnet_regiis -c. Any one from
> MS
> out
> there to help?
>
> "JStemper" wrote:

>> I'm not sure what you're asking. Which directories/site/etc.. does
>> ASPNET
>> need access to?
>>
>> The site runs fine, except for not having the correct validation
>> jscript
>> files.
>>
>> When I run the ASPNET_regiis app I am logged in as the administrator
>> or a
>> member of the administrator group.
>>
>> Thanks for the help.
>> John
>>
>> "Patrick.O.Ige" wrote:
>>
>> > Did u give the ASPNET account access?
>> > OR are u under the acct..
>> > Enjoy
>> > Patrick
>> >
>> >
>> > "JStemper" wrote:
>> >
>> > > On one of my localhost sites I'm getting a message to run
>> > > aspnet_regiis -c to
>> > > correct some scripting issues.
>> > > When I try to run the listed command I get another error:
>> > >
>> > > "You must have administrative rights on this machine in order to
>> > > run
>> > > this
>> > > tool."
>> > >
>> > > I have verified that I have administrative rights on the box as
>> > > my
>> > > normal
>> > > login. I have also logged in as the local administrator, tried
>> > > the
>> > > same thing
>> > > and get the same message.
>> > > I'm running XP Pro SP2 with VS2003. I believe the problem started
>> > > after
>> > > applying SP2.
>> > >
>> > > Anyone have any ideas on how to correct this?


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

Nov 19 '05 #12

P: n/a
Oz
BTW, I've tried giving ASPNET admin rights, but same problem.

-oz

"Juan T. Llibre" wrote:
Forgot to add...

Make sure the [Web Root]\aspnet_client\system_web\1_1_4322\*.js
files are NOT read-only BEFORE running the aspnet_regiis -ea
and the aspnet_regiis -c commands.
Juan T. Llibre
ASP.NET MVP
===========
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uf**************@TK2MSFTNGP11.phx.gbl...
Hi, Jorriss.

Try this If you're using .NET Framework 1.1 :

Find the "system_web" directory under wwwroot.
Under it, you should find a directory named "1_1_4322".
Delete it.
Run apsnet_regiis -ea from
drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
That should kill all old 1.1.4322 scripts.

Then, run aspnet_regiis -c
That should re-install the 1_1_4322 directory and client scripts.

Let us know how you do.


Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:46**********************************@microsof t.com...
An error has occurred (0x80070005).
You must have administrative rights on this machine in order to run this
tool.

"Juan T. Llibre" wrote:

Which error message do you get ?

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:AD**********************************@microsof t.com...
> I'm getting the same issue when running aspnet_regiis -c. Any one from
> MS
> out
> there to help?
>
> "JStemper" wrote:

>> I'm not sure what you're asking. Which directories/site/etc.. does
>> ASPNET
>> need access to?
>>
>> The site runs fine, except for not having the correct validation
>> jscript
>> files.
>>
>> When I run the ASPNET_regiis app I am logged in as the administrator
>> or a
>> member of the administrator group.
>>
>> Thanks for the help.
>> John
>>
>> "Patrick.O.Ige" wrote:
>>
>> > Did u give the ASPNET account access?
>> > OR are u under the acct..
>> > Enjoy
>> > Patrick
>> >
>> >
>> > "JStemper" wrote:
>> >
>> > > On one of my localhost sites I'm getting a message to run
>> > > aspnet_regiis -c to
>> > > correct some scripting issues.
>> > > When I try to run the listed command I get another error:
>> > >
>> > > "You must have administrative rights on this machine in order to
>> > > run
>> > > this
>> > > tool."
>> > >
>> > > I have verified that I have administrative rights on the box as
>> > > my
>> > > normal
>> > > login. I have also logged in as the local administrator, tried
>> > > the
>> > > same thing
>> > > and get the same message.
>> > > I'm running XP Pro SP2 with VS2003. I believe the problem started
>> > > after
>> > > applying SP2.
>> > >
>> > > Anyone have any ideas on how to correct this?


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

Nov 19 '05 #13

P: n/a
heh, heh...

Clearly, you can't make sure
that deleted files are not read-only :-)

You should check that *before* deleting them.

When you say that you are a "local administrator",
are you *the* "Administrator", or an account which
has been granted administrative privilege ?


Juan T. Llibre
ASP.NET MVP
===========
"Oz" <Oz@discussions.microsoft.com> wrote in message
news:A7**********************************@microsof t.com...
Juan -- I don't understand the sequence.

It looks to me like you've said to delete the 1-1-4322 directory in its
entirety, THEN to be sure the files in it (which are now gone) are not
read-only, and THEN run aspnet_regiis -ea. Obviously the above sequence is
impossible.

But even when I follow any combination of these, I still get the
"administrative privileges" message. Even running the "-ea" process fails
because of this. I am definitely a local administrator (win 2K Server).

What is it that needs admin permissions exactly -- obviously it isn't
me...?

"Juan T. Llibre" wrote:
Forgot to add...

Make sure the [Web Root]\aspnet_client\system_web\1_1_4322\*.js
files are NOT read-only BEFORE running the aspnet_regiis -ea
and the aspnet_regiis -c commands.
Juan T. Llibre
ASP.NET MVP
===========
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uf**************@TK2MSFTNGP11.phx.gbl...
> Hi, Jorriss.
>
> Try this If you're using .NET Framework 1.1 :
>
> Find the "system_web" directory under wwwroot.
> Under it, you should find a directory named "1_1_4322".
> Delete it.
> Run apsnet_regiis -ea from
> drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
> That should kill all old 1.1.4322 scripts.
>
> Then, run aspnet_regiis -c
> That should re-install the 1_1_4322 directory and client scripts.
>
> Let us know how you do.
>
>
>
>
> Juan T. Llibre
> ASP.NET MVP
> ===========
> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
> news:46**********************************@microsof t.com...
>> An error has occurred (0x80070005).
>> You must have administrative rights on this machine in order to run
>> this
>> tool.
>>
>> "Juan T. Llibre" wrote:
>>
>>> Which error message do you get ?
>>>
>>>
>>>
>>> Juan T. Llibre
>>> ASP.NET MVP
>>> ===========
>>> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
>>> news:AD**********************************@microsof t.com...
>>> > I'm getting the same issue when running aspnet_regiis -c. Any one
>>> > from
>>> > MS
>>> > out
>>> > there to help?
>>> >
>>> > "JStemper" wrote:
>>>
>>> >> I'm not sure what you're asking. Which directories/site/etc.. does
>>> >> ASPNET
>>> >> need access to?
>>> >>
>>> >> The site runs fine, except for not having the correct validation
>>> >> jscript
>>> >> files.
>>> >>
>>> >> When I run the ASPNET_regiis app I am logged in as the
>>> >> administrator
>>> >> or a
>>> >> member of the administrator group.
>>> >>
>>> >> Thanks for the help.
>>> >> John
>>> >>
>>> >> "Patrick.O.Ige" wrote:
>>> >>
>>> >> > Did u give the ASPNET account access?
>>> >> > OR are u under the acct..
>>> >> > Enjoy
>>> >> > Patrick
>>> >> >
>>> >> >
>>> >> > "JStemper" wrote:
>>> >> >
>>> >> > > On one of my localhost sites I'm getting a message to run
>>> >> > > aspnet_regiis -c to
>>> >> > > correct some scripting issues.
>>> >> > > When I try to run the listed command I get another error:
>>> >> > >
>>> >> > > "You must have administrative rights on this machine in order
>>> >> > > to
>>> >> > > run
>>> >> > > this
>>> >> > > tool."
>>> >> > >
>>> >> > > I have verified that I have administrative rights on the box
>>> >> > > as
>>> >> > > my
>>> >> > > normal
>>> >> > > login. I have also logged in as the local administrator, tried
>>> >> > > the
>>> >> > > same thing
>>> >> > > and get the same message.
>>> >> > > I'm running XP Pro SP2 with VS2003. I believe the problem
>>> >> > > started
>>> >> > > after
>>> >> > > applying SP2.
>>> >> > >
>>> >> > > Anyone have any ideas on how to correct this?
>
>
>
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 10/11/2004
Nov 19 '05 #14

P: n/a
That would not accomplish anything, since it's not the
ASPNET account which is executing aspnet_regiis


Juan T. Llibre
ASP.NET MVP
===========
"Oz" <Oz@discussions.microsoft.com> wrote in message
news:73**********************************@microsof t.com...
BTW, I've tried giving ASPNET admin rights, but same problem.

-oz

"Juan T. Llibre" wrote:
Forgot to add...

Make sure the [Web Root]\aspnet_client\system_web\1_1_4322\*.js
files are NOT read-only BEFORE running the aspnet_regiis -ea
and the aspnet_regiis -c commands.
Juan T. Llibre
ASP.NET MVP
===========
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uf**************@TK2MSFTNGP11.phx.gbl...
> Hi, Jorriss.
>
> Try this If you're using .NET Framework 1.1 :
>
> Find the "system_web" directory under wwwroot.
> Under it, you should find a directory named "1_1_4322".
> Delete it.
> Run apsnet_regiis -ea from
> drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
> That should kill all old 1.1.4322 scripts.
>
> Then, run aspnet_regiis -c
> That should re-install the 1_1_4322 directory and client scripts.
>
> Let us know how you do.
>
>
>
>
> Juan T. Llibre
> ASP.NET MVP
> ===========
> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
> news:46**********************************@microsof t.com...
>> An error has occurred (0x80070005).
>> You must have administrative rights on this machine in order to run
>> this
>> tool.
>>
>> "Juan T. Llibre" wrote:
>>
>>> Which error message do you get ?
>>>
>>>
>>>
>>> Juan T. Llibre
>>> ASP.NET MVP
>>> ===========
>>> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
>>> news:AD**********************************@microsof t.com...
>>> > I'm getting the same issue when running aspnet_regiis -c. Any one
>>> > from
>>> > MS
>>> > out
>>> > there to help?
>>> >
>>> > "JStemper" wrote:
>>>
>>> >> I'm not sure what you're asking. Which directories/site/etc.. does
>>> >> ASPNET
>>> >> need access to?
>>> >>
>>> >> The site runs fine, except for not having the correct validation
>>> >> jscript
>>> >> files.
>>> >>
>>> >> When I run the ASPNET_regiis app I am logged in as the
>>> >> administrator
>>> >> or a
>>> >> member of the administrator group.
>>> >>
>>> >> Thanks for the help.
>>> >> John
>>> >>
>>> >> "Patrick.O.Ige" wrote:
>>> >>
>>> >> > Did u give the ASPNET account access?
>>> >> > OR are u under the acct..
>>> >> > Enjoy
>>> >> > Patrick
>>> >> >
>>> >> >
>>> >> > "JStemper" wrote:
>>> >> >
>>> >> > > On one of my localhost sites I'm getting a message to run
>>> >> > > aspnet_regiis -c to
>>> >> > > correct some scripting issues.
>>> >> > > When I try to run the listed command I get another error:
>>> >> > >
>>> >> > > "You must have administrative rights on this machine in order
>>> >> > > to
>>> >> > > run
>>> >> > > this
>>> >> > > tool."
>>> >> > >
>>> >> > > I have verified that I have administrative rights on the box
>>> >> > > as
>>> >> > > my
>>> >> > > normal
>>> >> > > login. I have also logged in as the local administrator, tried
>>> >> > > the
>>> >> > > same thing
>>> >> > > and get the same message.
>>> >> > > I'm running XP Pro SP2 with VS2003. I believe the problem
>>> >> > > started
>>> >> > > after
>>> >> > > applying SP2.
>>> >> > >
>>> >> > > Anyone have any ideas on how to correct this?
>
>
>
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 10/11/2004
Nov 19 '05 #15

P: n/a
Oz
Got it. Here's what's extra strange: it appears it DID the -c, but still (I
suppose afterwards) gave the error.

I am a member of the administrators group on the machine. The error message
says one needs "administrative privileges", not that one must log in with the
user name "Administrator" (or whatever that user may have been renamed as).
So far there has been no operation I can not do on that machine other than
this, including installing any software, accessing any registry key, etc.
Wouldn't make much sense with those privileges to be denied some part of the
-ea or -c operations!

In any case, since the files WERE properly placed by -c, despite the error,
I just created a virtual directory in the web app to point to it for the
aspnet client, and it is working fine so far.

-oz

"Juan T. Llibre" wrote:
heh, heh...

Clearly, you can't make sure
that deleted files are not read-only :-)

You should check that *before* deleting them.

When you say that you are a "local administrator",
are you *the* "Administrator", or an account which
has been granted administrative privilege ?


Juan T. Llibre
ASP.NET MVP
===========
"Oz" <Oz@discussions.microsoft.com> wrote in message
news:A7**********************************@microsof t.com...
Juan -- I don't understand the sequence.

It looks to me like you've said to delete the 1-1-4322 directory in its
entirety, THEN to be sure the files in it (which are now gone) are not
read-only, and THEN run aspnet_regiis -ea. Obviously the above sequence is
impossible.

But even when I follow any combination of these, I still get the
"administrative privileges" message. Even running the "-ea" process fails
because of this. I am definitely a local administrator (win 2K Server).

What is it that needs admin permissions exactly -- obviously it isn't
me...?

"Juan T. Llibre" wrote:
Forgot to add...

Make sure the [Web Root]\aspnet_client\system_web\1_1_4322\*.js
files are NOT read-only BEFORE running the aspnet_regiis -ea
and the aspnet_regiis -c commands.
Juan T. Llibre
ASP.NET MVP
===========
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:uf**************@TK2MSFTNGP11.phx.gbl...
> Hi, Jorriss.
>
> Try this If you're using .NET Framework 1.1 :
>
> Find the "system_web" directory under wwwroot.
> Under it, you should find a directory named "1_1_4322".
> Delete it.
> Run apsnet_regiis -ea from
> drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
> That should kill all old 1.1.4322 scripts.
>
> Then, run aspnet_regiis -c
> That should re-install the 1_1_4322 directory and client scripts.
>
> Let us know how you do.
>
>
>
>
> Juan T. Llibre
> ASP.NET MVP
> ===========
> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
> news:46**********************************@microsof t.com...
>> An error has occurred (0x80070005).
>> You must have administrative rights on this machine in order to run
>> this
>> tool.
>>
>> "Juan T. Llibre" wrote:
>>
>>> Which error message do you get ?
>>>
>>>
>>>
>>> Juan T. Llibre
>>> ASP.NET MVP
>>> ===========
>>> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
>>> news:AD**********************************@microsof t.com...
>>> > I'm getting the same issue when running aspnet_regiis -c. Any one
>>> > from
>>> > MS
>>> > out
>>> > there to help?
>>> >
>>> > "JStemper" wrote:
>>>
>>> >> I'm not sure what you're asking. Which directories/site/etc.. does
>>> >> ASPNET
>>> >> need access to?
>>> >>
>>> >> The site runs fine, except for not having the correct validation
>>> >> jscript
>>> >> files.
>>> >>
>>> >> When I run the ASPNET_regiis app I am logged in as the
>>> >> administrator
>>> >> or a
>>> >> member of the administrator group.
>>> >>
>>> >> Thanks for the help.
>>> >> John
>>> >>
>>> >> "Patrick.O.Ige" wrote:
>>> >>
>>> >> > Did u give the ASPNET account access?
>>> >> > OR are u under the acct..
>>> >> > Enjoy
>>> >> > Patrick
>>> >> >
>>> >> >
>>> >> > "JStemper" wrote:
>>> >> >
>>> >> > > On one of my localhost sites I'm getting a message to run
>>> >> > > aspnet_regiis -c to
>>> >> > > correct some scripting issues.
>>> >> > > When I try to run the listed command I get another error:
>>> >> > >
>>> >> > > "You must have administrative rights on this machine in order
>>> >> > > to
>>> >> > > run
>>> >> > > this
>>> >> > > tool."
>>> >> > >
>>> >> > > I have verified that I have administrative rights on the box
>>> >> > > as
>>> >> > > my
>>> >> > > normal
>>> >> > > login. I have also logged in as the local administrator, tried
>>> >> > > the
>>> >> > > same thing
>>> >> > > and get the same message.
>>> >> > > I'm running XP Pro SP2 with VS2003. I believe the problem
>>> >> > > started
>>> >> > > after
>>> >> > > applying SP2.
>>> >> > >
>>> >> > > Anyone have any ideas on how to correct this?
>
>
>
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 10/11/2004

Nov 19 '05 #16

P: n/a
Great!

Thanks for following through.

Juan T. Llibre
ASP.NET MVP
===========
"Oz" <Oz@discussions.microsoft.com> wrote in message
news:4C**********************************@microsof t.com...
Got it. Here's what's extra strange: it appears it DID the -c, but still
(I
suppose afterwards) gave the error.

I am a member of the administrators group on the machine. The error
message
says one needs "administrative privileges", not that one must log in with
the
user name "Administrator" (or whatever that user may have been renamed
as).
So far there has been no operation I can not do on that machine other than
this, including installing any software, accessing any registry key, etc.
Wouldn't make much sense with those privileges to be denied some part of
the
-ea or -c operations!

In any case, since the files WERE properly placed by -c, despite the
error,
I just created a virtual directory in the web app to point to it for the
aspnet client, and it is working fine so far.

-oz

"Juan T. Llibre" wrote:
heh, heh...

Clearly, you can't make sure
that deleted files are not read-only :-)

You should check that *before* deleting them.

When you say that you are a "local administrator",
are you *the* "Administrator", or an account which
has been granted administrative privilege ?


Juan T. Llibre
ASP.NET MVP
===========
"Oz" <Oz@discussions.microsoft.com> wrote in message
news:A7**********************************@microsof t.com...
> Juan -- I don't understand the sequence.
>
> It looks to me like you've said to delete the 1-1-4322 directory in its
> entirety, THEN to be sure the files in it (which are now gone) are not
> read-only, and THEN run aspnet_regiis -ea. Obviously the above sequence
> is
> impossible.
>
> But even when I follow any combination of these, I still get the
> "administrative privileges" message. Even running the "-ea" process
> fails
> because of this. I am definitely a local administrator (win 2K Server).
>
> What is it that needs admin permissions exactly -- obviously it isn't
> me...?
>
>
>
> "Juan T. Llibre" wrote:
>
>> Forgot to add...
>>
>> Make sure the [Web Root]\aspnet_client\system_web\1_1_4322\*.js
>> files are NOT read-only BEFORE running the aspnet_regiis -ea
>> and the aspnet_regiis -c commands.
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> ===========
>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>> news:uf**************@TK2MSFTNGP11.phx.gbl...
>> > Hi, Jorriss.
>> >
>> > Try this If you're using .NET Framework 1.1 :
>> >
>> > Find the "system_web" directory under wwwroot.
>> > Under it, you should find a directory named "1_1_4322".
>> > Delete it.
>> > Run apsnet_regiis -ea from
>> > drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
>> > That should kill all old 1.1.4322 scripts.
>> >
>> > Then, run aspnet_regiis -c
>> > That should re-install the 1_1_4322 directory and client scripts.
>> >
>> > Let us know how you do.
>> >
>> >
>> >
>> >
>> > Juan T. Llibre
>> > ASP.NET MVP
>> > ===========
>> > "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
>> > news:46**********************************@microsof t.com...
>> >> An error has occurred (0x80070005).
>> >> You must have administrative rights on this machine in order to run
>> >> this
>> >> tool.
>> >>
>> >> "Juan T. Llibre" wrote:
>> >>
>> >>> Which error message do you get ?
>> >>>
>> >>>
>> >>>
>> >>> Juan T. Llibre
>> >>> ASP.NET MVP
>> >>> ===========
>> >>> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
>> >>> news:AD**********************************@microsof t.com...
>> >>> > I'm getting the same issue when running aspnet_regiis -c. Any
>> >>> > one
>> >>> > from
>> >>> > MS
>> >>> > out
>> >>> > there to help?
>> >>> >
>> >>> > "JStemper" wrote:
>> >>>
>> >>> >> I'm not sure what you're asking. Which directories/site/etc..
>> >>> >> does
>> >>> >> ASPNET
>> >>> >> need access to?
>> >>> >>
>> >>> >> The site runs fine, except for not having the correct
>> >>> >> validation
>> >>> >> jscript
>> >>> >> files.
>> >>> >>
>> >>> >> When I run the ASPNET_regiis app I am logged in as the
>> >>> >> administrator
>> >>> >> or a
>> >>> >> member of the administrator group.
>> >>> >>
>> >>> >> Thanks for the help.
>> >>> >> John
>> >>> >>
>> >>> >> "Patrick.O.Ige" wrote:
>> >>> >>
>> >>> >> > Did u give the ASPNET account access?
>> >>> >> > OR are u under the acct..
>> >>> >> > Enjoy
>> >>> >> > Patrick
>> >>> >> >
>> >>> >> >
>> >>> >> > "JStemper" wrote:
>> >>> >> >
>> >>> >> > > On one of my localhost sites I'm getting a message to run
>> >>> >> > > aspnet_regiis -c to
>> >>> >> > > correct some scripting issues.
>> >>> >> > > When I try to run the listed command I get another error:
>> >>> >> > >
>> >>> >> > > "You must have administrative rights on this machine in
>> >>> >> > > order
>> >>> >> > > to
>> >>> >> > > run
>> >>> >> > > this
>> >>> >> > > tool."
>> >>> >> > >
>> >>> >> > > I have verified that I have administrative rights on the
>> >>> >> > > box
>> >>> >> > > as
>> >>> >> > > my
>> >>> >> > > normal
>> >>> >> > > login. I have also logged in as the local administrator,
>> >>> >> > > tried
>> >>> >> > > the
>> >>> >> > > same thing
>> >>> >> > > and get the same message.
>> >>> >> > > I'm running XP Pro SP2 with VS2003. I believe the problem
>> >>> >> > > started
>> >>> >> > > after
>> >>> >> > > applying SP2.
>> >>> >> > >
>> >>> >> > > Anyone have any ideas on how to correct this?
>> >
>> >
>> >
>> > ---
>> > Outgoing mail is certified Virus Free.
>> > Checked by AVG anti-virus system (http://www.grisoft.com).
>> > Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>> >
>>
>>
>> ---
>> Outgoing mail is certified Virus Free.
>> Checked by AVG anti-virus system (http://www.grisoft.com).
>> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>>
>>
>>

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 10/11/2004

Nov 19 '05 #17

P: n/a
Still having the problem here. I've checked my rights in the appropriate
subdirectorys (full), deleted the recommended directories (they were
recreated but no script files were moved into them), tried running with the
-ea switch followed by the -c switch (no luck, in fact got the same error
trying to run the -ea switch).
Anyone from MS or elsewhere have any other suggestions or a nice answer?

Thanks

"Jorriss" wrote:
I've also blogged the solution on my blog
(http://jorriss.com/dottext/jorriss/a...1/06/400.aspx). Hopefully,
the next person who has this problem will find the solution through Google.

Jorriss

"Juan T. Llibre" wrote:
You're more than welcome.

Glad to have been of help!

Juan T. Llibre
ASP.NET MVP
===========
"Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
news:CD**********************************@microsof t.com...
That was it. Thanks Juan for your help!

Jorriss

"Juan T. Llibre" wrote:

> Hi, Jorriss.
>
> Try this If you're using .NET Framework 1.1 :
>
> Find the "system_web" directory under wwwroot.
> Under it, you should find a directory named "1_1_4322".
> Delete it.
> Run apsnet_regiis -ea from
> drive:\windowsdirectory\Microsoft.NET\Framework\v1 .1.4322
> That should kill all old 1.1.4322 scripts.
>
> Then, run aspnet_regiis -c
> That should re-install the 1_1_4322 directory and client scripts.
>
> Let us know how you do.
>
>
> Juan T. Llibre
> ASP.NET MVP
> ===========
> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
> news:46**********************************@microsof t.com...
> > An error has occurred (0x80070005).
> > You must have administrative rights on this machine in order to run
> > this
> > tool.
> >
> > "Juan T. Llibre" wrote:
> >
> >> Which error message do you get ?
> >>
> >>
> >>
> >> Juan T. Llibre
> >> ASP.NET MVP
> >> ===========
> >> "Jorriss" <Jo*****@discussions.microsoft.com> wrote in message
> >> news:AD**********************************@microsof t.com...
> >> > I'm getting the same issue when running aspnet_regiis -c. Any one
> >> > from
> >> > MS
> >> > out
> >> > there to help?
> >> >
> >> > "JStemper" wrote:
> >>
> >> >> I'm not sure what you're asking. Which directories/site/etc.. does
> >> >> ASPNET
> >> >> need access to?
> >> >>
> >> >> The site runs fine, except for not having the correct validation
> >> >> jscript
> >> >> files.
> >> >>
> >> >> When I run the ASPNET_regiis app I am logged in as the
> >> >> administrator
> >> >> or a
> >> >> member of the administrator group.
> >> >>
> >> >> Thanks for the help.
> >> >> John
> >> >>
> >> >> "Patrick.O.Ige" wrote:
> >> >>
> >> >> > Did u give the ASPNET account access?
> >> >> > OR are u under the acct..
> >> >> > Enjoy
> >> >> > Patrick
> >> >> >
> >> >> >
> >> >> > "JStemper" wrote:
> >> >> >
> >> >> > > On one of my localhost sites I'm getting a message to run
> >> >> > > aspnet_regiis -c to
> >> >> > > correct some scripting issues.
> >> >> > > When I try to run the listed command I get another error:
> >> >> > >
> >> >> > > "You must have administrative rights on this machine in order
> >> >> > > to
> >> >> > > run
> >> >> > > this
> >> >> > > tool."
> >> >> > >
> >> >> > > I have verified that I have administrative rights on the box as
> >> >> > > my
> >> >> > > normal
> >> >> > > login. I have also logged in as the local administrator, tried
> >> >> > > the
> >> >> > > same thing
> >> >> > > and get the same message.
> >> >> > > I'm running XP Pro SP2 with VS2003. I believe the problem
> >> >> > > started
> >> >> > > after
> >> >> > > applying SP2.
> >> >> > >
> >> >> > > Anyone have any ideas on how to correct this?
>
>
>
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>
>
>

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004

Nov 19 '05 #18

This discussion thread is closed

Replies have been disabled for this discussion.