By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,384 Members | 845 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,384 IT Pros & Developers. It's quick & easy.

Cooliless State - Image unavilabe

P: n/a
Hi,

I am having some problems hosting my website. Everything works fine in
my local machine but when I upload to propduction server, my images
won't load properly. I have my state configuration like
this in my web.config:

<sessionState
mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
cookieless="true"
timeout="90"
/>

My images are set like this in my code behind:
SelfAssignimg.ImageUrl = "images/plus_sign.gif";

In my production server, when I have cookieless set to false, some of the
client browsers disables the cookies, so other problems are cause because of
this.

Does anyone know whats going on?

Thanks in advance.

Regards,
Karthikeyan
Nov 19 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Are you sure you have deployed image files to the production server? Check
if they are there.

What is the connection between image loading and session state setting?

Eliyahu

"karthikeyan" <ka*********@discussions.microsoft.com> wrote in message
news:5C**********************************@microsof t.com...
Hi,

I am having some problems hosting my website. Everything works fine in
my local machine but when I upload to propduction server, my images
won't load properly. I have my state configuration like
this in my web.config:

<sessionState
mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes" cookieless="true"
timeout="90"
/>

My images are set like this in my code behind:
SelfAssignimg.ImageUrl = "images/plus_sign.gif";

In my production server, when I have cookieless set to false, some of the
client browsers disables the cookies, so other problems are cause because of this.

Does anyone know whats going on?

Thanks in advance.

Regards,
Karthikeyan

Nov 19 '05 #2

P: n/a
What browser & version you are using ?
Lalit

"Eliyahu Goldin" <re*************@monarchmed.com> wrote in message
news:eb**************@tk2msftngp13.phx.gbl...
Are you sure you have deployed image files to the production server? Check
if they are there.

What is the connection between image loading and session state setting?

Eliyahu

"karthikeyan" <ka*********@discussions.microsoft.com> wrote in message
news:5C**********************************@microsof t.com...
Hi,

I am having some problems hosting my website. Everything works fine in
my local machine but when I upload to propduction server, my images
won't load properly. I have my state configuration like
this in my web.config:

<sessionState
mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"
cookieless="true"
timeout="90"
/>

My images are set like this in my code behind:
SelfAssignimg.ImageUrl = "images/plus_sign.gif";

In my production server, when I have cookieless set to false, some of the client browsers disables the cookies, so other problems are cause

because of
this.

Does anyone know whats going on?

Thanks in advance.

Regards,
Karthikeyan


Nov 19 '05 #3

P: n/a
Hi,

To answer your questions, we have all the required images in the production
server under Images path. Also we are using IE6.0 version.

Basically we are able to see the images without any problem when we set the
cookieless value as false. If we set this cookieless value as true then the
images are not showing properly, because the session id is getting updated in
the URL. So while we use relative path like "images/plus_sign.gif" then it
is not able to find the images path properly.

Since we are using more number of images it is not possible for us to change
all the image paths with full path.

So please help us how to overcome this problem.

Note: We are having the login authentication pages in different domain
server and other pages are available in different domain server.

This is kind of very very urgent. So please help us as earlier.

Thanks in advance...

Thanks,
Rajagopal.S

"Lalit Singh" wrote:
What browser & version you are using ?
Lalit

"Eliyahu Goldin" <re*************@monarchmed.com> wrote in message
news:eb**************@tk2msftngp13.phx.gbl...
Are you sure you have deployed image files to the production server? Check
if they are there.

What is the connection between image loading and session state setting?

Eliyahu

"karthikeyan" <ka*********@discussions.microsoft.com> wrote in message
news:5C**********************************@microsof t.com...
Hi,

I am having some problems hosting my website. Everything works fine in
my local machine but when I upload to propduction server, my images
won't load properly. I have my state configuration like
this in my web.config:

<sessionState
mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data

source=127.0.0.1;Trusted_Connection=yes"
cookieless="true"
timeout="90"
/>

My images are set like this in my code behind:
SelfAssignimg.ImageUrl = "images/plus_sign.gif";

In my production server, when I have cookieless set to false, some of the client browsers disables the cookies, so other problems are cause

because
of
this.

Does anyone know whats going on?

Thanks in advance.

Regards,
Karthikeyan



Nov 19 '05 #4

P: n/a
I had the same problem in some pcs.
Solution is In the IE menu select Internet Options, Settings, Chek the
option button called "Every visit to the page"
so that browser will always get the latest gif files.
Let me now if it helps.
Lalit
"Rajagopal" <Ra*******@discussions.microsoft.com> wrote in message
news:A3**********************************@microsof t.com...
Hi,

To answer your questions, we have all the required images in the production server under Images path. Also we are using IE6.0 version.

Basically we are able to see the images without any problem when we set the cookieless value as false. If we set this cookieless value as true then the images are not showing properly, because the session id is getting updated in the URL. So while we use relative path like "images/plus_sign.gif" then it is not able to find the images path properly.

Since we are using more number of images it is not possible for us to change all the image paths with full path.

So please help us how to overcome this problem.

Note: We are having the login authentication pages in different domain
server and other pages are available in different domain server.

This is kind of very very urgent. So please help us as earlier.

Thanks in advance...

Thanks,
Rajagopal.S

"Lalit Singh" wrote:
What browser & version you are using ?
Lalit

"Eliyahu Goldin" <re*************@monarchmed.com> wrote in message
news:eb**************@tk2msftngp13.phx.gbl...
Are you sure you have deployed image files to the production server? Check if they are there.

What is the connection between image loading and session state setting?
Eliyahu

"karthikeyan" <ka*********@discussions.microsoft.com> wrote in message
news:5C**********************************@microsof t.com...
> Hi,
>
> I am having some problems hosting my website. Everything works fine in > my local machine but when I upload to propduction server, my images
> won't load properly. I have my state configuration like
> this in my web.config:
>
> <sessionState
> mode="InProc"
> stateConnectionString="tcpip=127.0.0.1:42424"
> sqlConnectionString="data
source=127.0.0.1;Trusted_Connection=yes"
> cookieless="true"
> timeout="90"
> />
>
> My images are set like this in my code behind:
> SelfAssignimg.ImageUrl = "images/plus_sign.gif";
>
> In my production server, when I have cookieless set to false, some
of the
> client browsers disables the cookies, so other problems are cause

because
of
> this.
>
> Does anyone know whats going on?
>
> Thanks in advance.
>
> Regards,
> Karthikeyan


Nov 19 '05 #5

P: n/a
Hi Lalit,

Thanks for your reply. But it doesnt work. Because this is not happening
only for some of the systems. It happens for all the systems. Basically
when i set the cookieless value in config file as "true", the session id is
getting updated with the URL. So when we give the relative path for images,
the URL for the image includes the session id also as below,

http://servername/websitename/sessionid/images/img.jpg

Since the URL has session id also it is not able to find the image in the
above specified path. due to this reason we are facing this problem. So i
am not sure we can overcome this problem by changing any IE settings.

Please help me if you have any more thoughts in this regard.

Thanks,
Rajagopal.S

"Lalit Singh" wrote:
I had the same problem in some pcs.
Solution is In the IE menu select Internet Options, Settings, Chek the
option button called "Every visit to the page"
so that browser will always get the latest gif files.
Let me now if it helps.
Lalit
"Rajagopal" <Ra*******@discussions.microsoft.com> wrote in message
news:A3**********************************@microsof t.com...
Hi,

To answer your questions, we have all the required images in the

production
server under Images path. Also we are using IE6.0 version.

Basically we are able to see the images without any problem when we set

the
cookieless value as false. If we set this cookieless value as true then

the
images are not showing properly, because the session id is getting updated

in
the URL. So while we use relative path like "images/plus_sign.gif" then

it
is not able to find the images path properly.

Since we are using more number of images it is not possible for us to

change
all the image paths with full path.

So please help us how to overcome this problem.

Note: We are having the login authentication pages in different domain
server and other pages are available in different domain server.

This is kind of very very urgent. So please help us as earlier.

Thanks in advance...

Thanks,
Rajagopal.S

"Lalit Singh" wrote:
What browser & version you are using ?
Lalit

"Eliyahu Goldin" <re*************@monarchmed.com> wrote in message
news:eb**************@tk2msftngp13.phx.gbl...
> Are you sure you have deployed image files to the production server? Check > if they are there.
>
> What is the connection between image loading and session state setting? >
> Eliyahu
>
> "karthikeyan" <ka*********@discussions.microsoft.com> wrote in message
> news:5C**********************************@microsof t.com...
> > Hi,
> >
> > I am having some problems hosting my website. Everything works fine in > > my local machine but when I upload to propduction server, my images
> > won't load properly. I have my state configuration like
> > this in my web.config:
> >
> > <sessionState
> > mode="InProc"
> > stateConnectionString="tcpip=127.0.0.1:42424"
> > sqlConnectionString="data
> source=127.0.0.1;Trusted_Connection=yes"
> > cookieless="true"
> > timeout="90"
> > />
> >
> > My images are set like this in my code behind:
> > SelfAssignimg.ImageUrl = "images/plus_sign.gif";
> >
> > In my production server, when I have cookieless set to false, some of the
> > client browsers disables the cookies, so other problems are cause
because
> of
> > this.
> >
> > Does anyone know whats going on?
> >
> > Thanks in advance.
> >
> > Regards,
> > Karthikeyan
>
>


Nov 19 '05 #6

P: n/a
Rajagopal,
R U using ImageButton?
Did you try by setting the property to ImageUrl = Images\MyImage.gif?
For me it is working. In the ViewSource what is the path it is showing for
image?
Jonathan

"Rajagopal" <Ra*******@discussions.microsoft.com> wrote in message
news:6B**********************************@microsof t.com...
Hi Lalit,

Thanks for your reply. But it doesnt work. Because this is not happening
only for some of the systems. It happens for all the systems. Basically
when i set the cookieless value in config file as "true", the session id is getting updated with the URL. So when we give the relative path for images, the URL for the image includes the session id also as below,

http://servername/websitename/sessionid/images/img.jpg

Since the URL has session id also it is not able to find the image in the
above specified path. due to this reason we are facing this problem. So i am not sure we can overcome this problem by changing any IE settings.

Please help me if you have any more thoughts in this regard.

Thanks,
Rajagopal.S

"Lalit Singh" wrote:
I had the same problem in some pcs.
Solution is In the IE menu select Internet Options, Settings, Chek the
option button called "Every visit to the page"
so that browser will always get the latest gif files.
Let me now if it helps.
Lalit
"Rajagopal" <Ra*******@discussions.microsoft.com> wrote in message
news:A3**********************************@microsof t.com...
Hi,

To answer your questions, we have all the required images in the

production
server under Images path. Also we are using IE6.0 version.

Basically we are able to see the images without any problem when we set
the
cookieless value as false. If we set this cookieless value as true
then the
images are not showing properly, because the session id is getting
updated in
the URL. So while we use relative path like "images/plus_sign.gif"
then it
is not able to find the images path properly.

Since we are using more number of images it is not possible for us to

change
all the image paths with full path.

So please help us how to overcome this problem.

Note: We are having the login authentication pages in different domain
server and other pages are available in different domain server.

This is kind of very very urgent. So please help us as earlier.

Thanks in advance...

Thanks,
Rajagopal.S

"Lalit Singh" wrote:

> What browser & version you are using ?
> Lalit
>
> "Eliyahu Goldin" <re*************@monarchmed.com> wrote in message
> news:eb**************@tk2msftngp13.phx.gbl...
> > Are you sure you have deployed image files to the production
server? Check
> > if they are there.
> >
> > What is the connection between image loading and session state

setting?
> >
> > Eliyahu
> >
> > "karthikeyan" <ka*********@discussions.microsoft.com> wrote in
message > > news:5C**********************************@microsof t.com...
> > > Hi,
> > >
> > > I am having some problems hosting my website. Everything works fine in
> > > my local machine but when I upload to propduction server, my
images > > > won't load properly. I have my state configuration like
> > > this in my web.config:
> > >
> > > <sessionState
> > > mode="InProc"
> > > stateConnectionString="tcpip=127.0.0.1:42424"
> > > sqlConnectionString="data
> > source=127.0.0.1;Trusted_Connection=yes"
> > > cookieless="true"
> > > timeout="90"
> > > />
> > >
> > > My images are set like this in my code behind:
> > > SelfAssignimg.ImageUrl = "images/plus_sign.gif";
> > >
> > > In my production server, when I have cookieless set to false, some of
> the
> > > client browsers disables the cookies, so other problems are

cause > because
> > of
> > > this.
> > >
> > > Does anyone know whats going on?
> > >
> > > Thanks in advance.
> > >
> > > Regards,
> > > Karthikeyan
> >
> >
>
>
>


Nov 19 '05 #7

P: n/a
Hi Jonatha,

Thanks for your response.

Actually i am not using image button, am using as below,

<img src="images/ta_branch_off2.gif" alt="Search By Branch" id="imgbranch"
width="120" height="34" border="0">

Also when i right click on the image and check the url then it showing as
like below,

http://servername/websitename/sessionid/images/img.jpg

if i paste the same URL in separate IE then it shows me page cannot be
displayed. If i remove the session id from the URL and run it then i am able
to see the image without any problem.

Thanks,
Rajagopal.S

"Jonathan Smith" wrote:
Rajagopal,
R U using ImageButton?
Did you try by setting the property to ImageUrl = Images\MyImage.gif?
For me it is working. In the ViewSource what is the path it is showing for
image?
Jonathan

"Rajagopal" <Ra*******@discussions.microsoft.com> wrote in message
news:6B**********************************@microsof t.com...
Hi Lalit,

Thanks for your reply. But it doesnt work. Because this is not happening
only for some of the systems. It happens for all the systems. Basically
when i set the cookieless value in config file as "true", the session id

is
getting updated with the URL. So when we give the relative path for

images,
the URL for the image includes the session id also as below,

http://servername/websitename/sessionid/images/img.jpg

Since the URL has session id also it is not able to find the image in the
above specified path. due to this reason we are facing this problem. So

i
am not sure we can overcome this problem by changing any IE settings.

Please help me if you have any more thoughts in this regard.

Thanks,
Rajagopal.S

"Lalit Singh" wrote:
I had the same problem in some pcs.
Solution is In the IE menu select Internet Options, Settings, Chek the
option button called "Every visit to the page"
so that browser will always get the latest gif files.
Let me now if it helps.
Lalit
"Rajagopal" <Ra*******@discussions.microsoft.com> wrote in message
news:A3**********************************@microsof t.com...
> Hi,
>
> To answer your questions, we have all the required images in the
production
> server under Images path. Also we are using IE6.0 version.
>
> Basically we are able to see the images without any problem when we set the
> cookieless value as false. If we set this cookieless value as true then the
> images are not showing properly, because the session id is getting updated in
> the URL. So while we use relative path like "images/plus_sign.gif" then it
> is not able to find the images path properly.
>
> Since we are using more number of images it is not possible for us to
change
> all the image paths with full path.
>
> So please help us how to overcome this problem.
>
> Note: We are having the login authentication pages in different domain
> server and other pages are available in different domain server.
>
> This is kind of very very urgent. So please help us as earlier.
>
> Thanks in advance...
>
> Thanks,
> Rajagopal.S
>
> "Lalit Singh" wrote:
>
> > What browser & version you are using ?
> > Lalit
> >
> > "Eliyahu Goldin" <re*************@monarchmed.com> wrote in message
> > news:eb**************@tk2msftngp13.phx.gbl...
> > > Are you sure you have deployed image files to the production server? Check
> > > if they are there.
> > >
> > > What is the connection between image loading and session state
setting?
> > >
> > > Eliyahu
> > >
> > > "karthikeyan" <ka*********@discussions.microsoft.com> wrote in message > > > news:5C**********************************@microsof t.com...
> > > > Hi,
> > > >
> > > > I am having some problems hosting my website. Everything works fine in
> > > > my local machine but when I upload to propduction server, my images > > > > won't load properly. I have my state configuration like
> > > > this in my web.config:
> > > >
> > > > <sessionState
> > > > mode="InProc"
> > > > stateConnectionString="tcpip=127.0.0.1:42424"
> > > > sqlConnectionString="data
> > > source=127.0.0.1;Trusted_Connection=yes"
> > > > cookieless="true"
> > > > timeout="90"
> > > > />
> > > >
> > > > My images are set like this in my code behind:
> > > > SelfAssignimg.ImageUrl = "images/plus_sign.gif";
> > > >
> > > > In my production server, when I have cookieless set to false, some of
> > the
> > > > client browsers disables the cookies, so other problems are cause > > because
> > > of
> > > > this.
> > > >
> > > > Does anyone know whats going on?
> > > >
> > > > Thanks in advance.
> > > >
> > > > Regards,
> > > > Karthikeyan
> > >
> > >
> >
> >
> >


Nov 19 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.