By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,384 Members | 801 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,384 IT Pros & Developers. It's quick & easy.

Saving large files using HTTP PUT

P: n/a
Hi,

We are receiving an error 'The operation has timed out' when our ASP.NET
application on Web Server stores large files 10MB+ on the App Server using
HTTP PUT. This is a Server to Server communication. This works fine with 4-5
MB files though. Also there is a 15 mb shared bandwidth limitation.
how can we throttle/control the transfer rate to see that we are within the
bandwidth limits ?

Any help is highly appreciated

Thanks
Ramesh

Nov 18 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
The default limit is 4MB. You can override this in web.config or
machine.config by changing the maxRequestSize attribute in the httpRuntime
section.

I don't know that you can control the bandwidth utilization with the default
WS plumbing provided by the framework - maybe there's a way to do it through
IIS.
--
Klaus H. Probst, MVP
http://www.vbbox.com/
"Ramesh" <Ra****@discussions.microsoft.com> wrote in message
news:22**********************************@microsof t.com...
Hi,

We are receiving an error 'The operation has timed out' when our ASP.NET
application on Web Server stores large files 10MB+ on the App Server using
HTTP PUT. This is a Server to Server communication. This works fine with 4-5 MB files though. Also there is a 15 mb shared bandwidth limitation.
how can we throttle/control the transfer rate to see that we are within the bandwidth limits ?

Any help is highly appreciated

Thanks
Ramesh

Nov 18 '05 #2

P: n/a

"Klaus H. Probst" <us*******@simulplex.net> wrote in message
news:u3**************@TK2MSFTNGP09.phx.gbl...
The default limit is 4MB. You can override this in web.config or
machine.config by changing the maxRequestSize attribute in the httpRuntime
section.


Sorry, that's maxRequestLength:

<httpRuntime maxRequestLength="xxxxx" ... />
--
Klaus H. Probst, MVP
http://www.vbbox.com/
Nov 18 '05 #3

P: n/a
We already changed the httpruntime section in the web.config file to accept
files upto 20mb.

"Klaus H. Probst" wrote:
The default limit is 4MB. You can override this in web.config or
machine.config by changing the maxRequestSize attribute in the httpRuntime
section.

I don't know that you can control the bandwidth utilization with the default
WS plumbing provided by the framework - maybe there's a way to do it through
IIS.
--
Klaus H. Probst, MVP
http://www.vbbox.com/
"Ramesh" <Ra****@discussions.microsoft.com> wrote in message
news:22**********************************@microsof t.com...
Hi,

We are receiving an error 'The operation has timed out' when our ASP.NET
application on Web Server stores large files 10MB+ on the App Server using
HTTP PUT. This is a Server to Server communication. This works fine with

4-5
MB files though. Also there is a 15 mb shared bandwidth limitation.
how can we throttle/control the transfer rate to see that we are within

the
bandwidth limits ?

Any help is highly appreciated

Thanks
Ramesh


Nov 18 '05 #4

P: n/a
There is a practical though "undocumented" limit of 3.9MB or so I've always
observed when moving binary data through web services. I've never been able
to get past that, though I've heard some people claim they have. Perhaps
it's a configuration setting or the version of IIS you happen to be running
(IIS is the thing that actually handles the requests, after all). This is
true as far as I'm concerned regardless of the way you're moving the data -
whether it's a simple byte array on a web method, WS-Attachments/DIME or
some other thing.

The solution (for me at least) has been to maintain state on the server or
piggyback state on the web request and chunk the data manually to manageable
sizes (500K or so). This also has the benefit of saving you from timeouts
and whatnot.

--
Klaus H. Probst, MVP
http://www.vbbox.com/
"Ramesh" <Ra****@discussions.microsoft.com> wrote in message
news:8D**********************************@microsof t.com...
We already changed the httpruntime section in the web.config file to accept files upto 20mb.

"Klaus H. Probst" wrote:
The default limit is 4MB. You can override this in web.config or
machine.config by changing the maxRequestSize attribute in the httpRuntime section.

I don't know that you can control the bandwidth utilization with the default WS plumbing provided by the framework - maybe there's a way to do it through IIS.
--
Klaus H. Probst, MVP
http://www.vbbox.com/
"Ramesh" <Ra****@discussions.microsoft.com> wrote in message
news:22**********************************@microsof t.com...
Hi,

We are receiving an error 'The operation has timed out' when our ASP.NET application on Web Server stores large files 10MB+ on the App Server using HTTP PUT. This is a Server to Server communication. This works fine
with 4-5
MB files though. Also there is a 15 mb shared bandwidth limitation.
how can we throttle/control the transfer rate to see that we are
within the
bandwidth limits ?

Any help is highly appreciated

Thanks
Ramesh


Nov 18 '05 #5

P: n/a
be sure to set the page timeouts on the calling and recieving pages. you can
use timers to throttle the bandwidth. to do this correctly, you will need to
create a static class that monitors bandwidth to the server (to handle two
pages posting at the same time). post in chucks, then call the timer with
the chuck size and posting time. delay if required. if there is a dedicated
nic card for the 15mb network, you could monitor its i/o stats.

-- bruce (sqlwork.com)
"Ramesh" <Ra****@discussions.microsoft.com> wrote in message
news:22**********************************@microsof t.com...
| Hi,
|
| We are receiving an error 'The operation has timed out' when our ASP.NET
| application on Web Server stores large files 10MB+ on the App Server using
| HTTP PUT. This is a Server to Server communication. This works fine with
4-5
| MB files though. Also there is a 15 mb shared bandwidth limitation.
| how can we throttle/control the transfer rate to see that we are within
the
| bandwidth limits ?
|
| Any help is highly appreciated
|
| Thanks
| Ramesh
|
Nov 18 '05 #6

P: n/a
Thanks for your quick responses.

We are using a file upload control on an asp.net page to upload the the file.
We are receving the files from clients desktops. MaxRequestLength and
timeout are configured appropriately. The asp.net app uses WebClient to post
the data (using HTTP PUT/WEBDAV) to another server. And this is timing out.
THe whole thing works in DEV and SIT envs. It is failing when bandwidth
limitations are applied. I am wondering if there is a way to slice up the
file and upload in pieces. How that works with PUT/WEBDAV ?

Thanks
Ramesh

"Klaus H. Probst" wrote:
There is a practical though "undocumented" limit of 3.9MB or so I've always
observed when moving binary data through web services. I've never been able
to get past that, though I've heard some people claim they have. Perhaps
it's a configuration setting or the version of IIS you happen to be running
(IIS is the thing that actually handles the requests, after all). This is
true as far as I'm concerned regardless of the way you're moving the data -
whether it's a simple byte array on a web method, WS-Attachments/DIME or
some other thing.

The solution (for me at least) has been to maintain state on the server or
piggyback state on the web request and chunk the data manually to manageable
sizes (500K or so). This also has the benefit of saving you from timeouts
and whatnot.

--
Klaus H. Probst, MVP
http://www.vbbox.com/
"Ramesh" <Ra****@discussions.microsoft.com> wrote in message
news:8D**********************************@microsof t.com...
We already changed the httpruntime section in the web.config file to

accept
files upto 20mb.

"Klaus H. Probst" wrote:
The default limit is 4MB. You can override this in web.config or
machine.config by changing the maxRequestSize attribute in the httpRuntime section.

I don't know that you can control the bandwidth utilization with the default WS plumbing provided by the framework - maybe there's a way to do it through IIS.
--
Klaus H. Probst, MVP
http://www.vbbox.com/
"Ramesh" <Ra****@discussions.microsoft.com> wrote in message
news:22**********************************@microsof t.com...
> Hi,
>
> We are receiving an error 'The operation has timed out' when our ASP.NET > application on Web Server stores large files 10MB+ on the App Server using > HTTP PUT. This is a Server to Server communication. This works fine with 4-5
> MB files though. Also there is a 15 mb shared bandwidth limitation.
> how can we throttle/control the transfer rate to see that we are within the
> bandwidth limits ?
>
> Any help is highly appreciated
>
> Thanks
> Ramesh
>


Nov 18 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.