By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,760 Members | 955 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,760 IT Pros & Developers. It's quick & easy.

The web serve has been locked down and is blocking the Debug verb.

P: n/a
Hello,

I ran the Microsoft Baseline Security analyzer 1.2 on my developement
machine, then as one of the requests. Also updated the machine 1.1 Framework
with service pack 1.

Now everytime I try to run a project on debug or release mode get this
message:

"Error while trying to run the project: Unable to start debuging on the web
server. The web server has been locked down and is blocking the DEBUG verb,
which is required to enable debuging....."

Where do I unblock this on web server, haven't had luck finding this
setting, or what is the solution to this?

Thanks in advance for your help,
Reza

Nov 18 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Search your machine for the URLScan.ini file and open it up. You'll see
sections and entries for what verbs to allow. Simply add DEBUG to the
allowed verbs and away you go.

Have A Better One!

John M Deal, MCP
Necessity Software

Reza Solouki wrote:
Hello,

I ran the Microsoft Baseline Security analyzer 1.2 on my developement
machine, then as one of the requests. Also updated the machine 1.1 Framework
with service pack 1.

Now everytime I try to run a project on debug or release mode get this
message:

"Error while trying to run the project: Unable to start debuging on the web
server. The web server has been locked down and is blocking the DEBUG verb,
which is required to enable debuging....."

Where do I unblock this on web server, haven't had luck finding this
setting, or what is the solution to this?

Thanks in advance for your help,
Reza

Nov 18 '05 #2

P: n/a
Thanks John, that seemed to solve that problem.

On the same cause now getting the message,
"Unable to start debugging on the web server. Could not start ASP.NET or ATL
Server debugging....."

I know what they are but since never had to start them manually, not sure
what to do?!
I found a service for ASP.NET, which started it but still getting the same
msg!

Thanks again for your help.

"John M Deal" wrote:
Search your machine for the URLScan.ini file and open it up. You'll see
sections and entries for what verbs to allow. Simply add DEBUG to the
allowed verbs and away you go.

Have A Better One!

John M Deal, MCP
Necessity Software

Reza Solouki wrote:
Hello,

I ran the Microsoft Baseline Security analyzer 1.2 on my developement
machine, then as one of the requests. Also updated the machine 1.1 Framework
with service pack 1.

Now everytime I try to run a project on debug or release mode get this
message:

"Error while trying to run the project: Unable to start debuging on the web
server. The web server has been locked down and is blocking the DEBUG verb,
which is required to enable debuging....."

Where do I unblock this on web server, haven't had luck finding this
setting, or what is the solution to this?

Thanks in advance for your help,
Reza

Nov 18 '05 #3

P: n/a
Google search on "the web server has been locked down" gave me a bunch of
stuff. First one seemed promising

http://msdn.microsoft.com/library/de...gdebugverb.asp

--
Ben Strackany
www.developmentnow.com

<a href="http://www.developmentnow.com">dn</a>
"Reza Solouki" <Re*********@discussions.microsoft.com> wrote in message
news:EF**********************************@microsof t.com...
Hello,

I ran the Microsoft Baseline Security analyzer 1.2 on my developement
machine, then as one of the requests. Also updated the machine 1.1 Framework with service pack 1.

Now everytime I try to run a project on debug or release mode get this
message:

"Error while trying to run the project: Unable to start debuging on the web server. The web server has been locked down and is blocking the DEBUG verb, which is required to enable debuging....."

Where do I unblock this on web server, haven't had luck finding this
setting, or what is the solution to this?

Thanks in advance for your help,
Reza

Nov 18 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.