467,877 Members | 1,141 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,877 developers. It's quick & easy.

Creating IIS Web Server Virtual Directories

Hello.

Under

C:\Documents and Settings\Administrator\My Documents\My Projects\

I have created a folder, "ASPNET" where I plan to keep my projects.

I have started Administrative Tools -> Internet Information Services and
under "Default Web Site" I have created a virtual folder with the label
"ASPProjects" pointing to C:\Documents and Settings\Administrator\My
Documents\My Projects\ASPNET

I can see my *.aspx files in the right pane of IIS admin - everything looks
fine. However, when I try to open an aspx file, using, for instance

http://localhost/ASPProjects/CheckBoxList.aspx

IE gives me this:

Server Error in '/ASPProjects' Application.
--------------------------------------------------------------------------------

Server cannot access application directory 'C:\Documents and
Settings\Administrator\My Documents\My Projects\ASPNET\'. The directory does
not exist or is not accessible because of security settings.
No matter how I played with the permissions, I still can't make it work.
What am I doing wrong here ?
WinXP Pro SP2.

Thank You,
Alex.

Nov 18 '05 #1
  • viewed: 1317
Share:
3 Replies
You may have already done so, and if yes then please excuse me for asking
this.
Have you created a bin folder under C:\Documents and
Settings\Administrator\My
Documents\My Projects\ASPNET

and have you also copied your web.config and global.asax to the root folder
of your application.

--
Regards,

Deepak
[I Code, therefore I am]
"news.iq.ca" <RE***********************@yahoo.com> wrote in message
news:41a42a0a$1_4@aeinews....
Hello.

Under

C:\Documents and Settings\Administrator\My Documents\My Projects\

I have created a folder, "ASPNET" where I plan to keep my projects.

I have started Administrative Tools -> Internet Information Services and
under "Default Web Site" I have created a virtual folder with the label
"ASPProjects" pointing to C:\Documents and Settings\Administrator\My
Documents\My Projects\ASPNET

I can see my *.aspx files in the right pane of IIS admin - everything
looks fine. However, when I try to open an aspx file, using, for instance

http://localhost/ASPProjects/CheckBoxList.aspx

IE gives me this:

Server Error in '/ASPProjects' Application.
--------------------------------------------------------------------------------

Server cannot access application directory 'C:\Documents and
Settings\Administrator\My Documents\My Projects\ASPNET\'. The directory
does not exist or is not accessible because of security settings.
No matter how I played with the permissions, I still can't make it work.
What am I doing wrong here ?
WinXP Pro SP2.

Thank You,
Alex.

Nov 18 '05 #2
Did you make it an application?

If not go to IIS -> ASPProjects -> Properties -> Virtual Directory Tab
and under Application settings Click the Create button.

Hope this helps
Hello.

Under

C:\Documents and Settings\Administrator\My Documents\My Projects\

I have created a folder, "ASPNET" where I plan to keep my projects.

I have started Administrative Tools -> Internet Information Services and
under "Default Web Site" I have created a virtual folder with the label
"ASPProjects" pointing to C:\Documents and Settings\Administrator\My
Documents\My Projects\ASPNET

I can see my *.aspx files in the right pane of IIS admin - everything
looks fine. However, when I try to open an aspx file, using, for instance

http://localhost/ASPProjects/CheckBoxList.aspx

IE gives me this:

Server Error in '/ASPProjects' Application.
--------------------------------------------------------------------------------

Server cannot access application directory 'C:\Documents and
Settings\Administrator\My Documents\My Projects\ASPNET\'. The directory
does not exist or is not accessible because of security settings.
No matter how I played with the permissions, I still can't make it work.
What am I doing wrong here ?
WinXP Pro SP2.

Thank You,
Alex.

Nov 18 '05 #3
Is your web site running as Administrator? If you move that ASPNET folder to
a different folder (e.g. "c:\inetpub\aspnet") & change the virtual directory
to point to that new location, does it start working?

--
Ben Strackany
www.developmentnow.com

<a href="http://www.developmentnow.com">dn</a>
"news.iq.ca" <RE***********************@yahoo.com> wrote in message
news:41a42a0a$1_4@aeinews....
Hello.

Under

C:\Documents and Settings\Administrator\My Documents\My Projects\

I have created a folder, "ASPNET" where I plan to keep my projects.

I have started Administrative Tools -> Internet Information Services and
under "Default Web Site" I have created a virtual folder with the label
"ASPProjects" pointing to C:\Documents and Settings\Administrator\My
Documents\My Projects\ASPNET

I can see my *.aspx files in the right pane of IIS admin - everything looks fine. However, when I try to open an aspx file, using, for instance

http://localhost/ASPProjects/CheckBoxList.aspx

IE gives me this:

Server Error in '/ASPProjects' Application.
-------------------------------------------------------------------------- ------
Server cannot access application directory 'C:\Documents and
Settings\Administrator\My Documents\My Projects\ASPNET\'. The directory does not exist or is not accessible because of security settings.
No matter how I played with the permissions, I still can't make it work.
What am I doing wrong here ?
WinXP Pro SP2.

Thank You,
Alex.

Nov 18 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Stelrad Doulton | last post: by
reply views Thread by jack112 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.