469,909 Members | 1,564 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,909 developers. It's quick & easy.

Validator Control Problem

Hi!, I'm having a strange issue while deploying a web site with Validator

controls.

In my development machine the Validators function perfecly and also when I

deploy using XCOPY to a web server.

The problem seems to arrise when I decided to change the root folder of the

web page in IIS to point to a different directory. In this case the

validators stop working (although the page continues to work)

To be more precise these are the directories:

The folder configuration is the following

c:\inetpub\wwwroot\siteName\application

The page is working when in IIS home directory I set it to point to

\siteName and I browse to page using http://mysite/application/

When I point the IIS home directory straight to \siteName\application (and

browse directly using http://mysite/ ) Validators stop working.

What could the problem be? What am I missing or what parameters I need to

configure (that forgot probably) in IIS to make the Validators control work

again?
Nov 18 '05 #1
2 1107
Hi Matias,

The <webControls> element in the machine.config specifies the location of
the client script files that are used for validation. ASP.NET is going to
be looking in the aspnet_client folder in the root of the Web site. That's
the root of the Web site, not the application. Therefore, when you change
the physical location of the root of the Web site, you break that
functionality.

If you need to keep the root of the Web site set where you have it, go to a
command prompt and change into the v1.1.4322 directory and run this:

aspnet_regiis -c

That will create the folder in the new root.

Jim Cheshire [MSFT]
MCP+I, MCSE, MCSD, MCDBA
ASP.NET Developer Support
ja******@online.microsoft.com

This post is provided "AS-IS" with no warranties and confers no rights.
--------------------
| From: "Matias" <ma****@maildehotmail.com>
| Subject: Validator Control Problem
| Date: Thu, 11 Nov 2004 18:48:51 -0300
| Lines: 35
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
| Message-ID: <un**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: cm-lconc3-162-15.cm.vtr.net 200.83.162.15
| Path:
cpmsftngxa10.phx.gbl!TK2MSFTFEED02.phx.gbl!TK2MSFT NGP08.phx.gbl!TK2MSFTNGP12
.phx.gbl
| Xref: cpmsftngxa10.phx.gbl microsoft.public.dotnet.framework.aspnet:275459
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi!, I'm having a strange issue while deploying a web site with Validator
|
| controls.
|
| In my development machine the Validators function perfecly and also when I
|
| deploy using XCOPY to a web server.
|
| The problem seems to arrise when I decided to change the root folder of
the
|
| web page in IIS to point to a different directory. In this case the
|
| validators stop working (although the page continues to work)
|
| To be more precise these are the directories:
|
| The folder configuration is the following
|
| c:\inetpub\wwwroot\siteName\application
|
| The page is working when in IIS home directory I set it to point to
|
| \siteName and I browse to page using http://mysite/application/
|
| When I point the IIS home directory straight to \siteName\application (and
|
| browse directly using http://mysite/ ) Validators stop working.
|
| What could the problem be? What am I missing or what parameters I need to
|
| configure (that forgot probably) in IIS to make the Validators control
work
|
| again?
|
|
|

Nov 18 '05 #2
Thanks, I'll try this.
"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> escribió en el mensaje
news:0j**************@cpmsftngxa10.phx.gbl...
Hi Matias,

The <webControls> element in the machine.config specifies the location of
the client script files that are used for validation. ASP.NET is going to
be looking in the aspnet_client folder in the root of the Web site. That's the root of the Web site, not the application. Therefore, when you change
the physical location of the root of the Web site, you break that
functionality.

If you need to keep the root of the Web site set where you have it, go to a command prompt and change into the v1.1.4322 directory and run this:

aspnet_regiis -c

That will create the folder in the new root.

Jim Cheshire [MSFT]
MCP+I, MCSE, MCSD, MCDBA
ASP.NET Developer Support
ja******@online.microsoft.com

This post is provided "AS-IS" with no warranties and confers no rights.
--------------------
| From: "Matias" <ma****@maildehotmail.com>
| Subject: Validator Control Problem
| Date: Thu, 11 Nov 2004 18:48:51 -0300
| Lines: 35
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
| Message-ID: <un**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| NNTP-Posting-Host: cm-lconc3-162-15.cm.vtr.net 200.83.162.15
| Path:
cpmsftngxa10.phx.gbl!TK2MSFTFEED02.phx.gbl!TK2MSFT NGP08.phx.gbl!TK2MSFTNGP12 phx.gbl
| Xref: cpmsftngxa10.phx.gbl microsoft.public.dotnet.framework.aspnet:275459 | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi!, I'm having a strange issue while deploying a web site with Validator |
| controls.
|
| In my development machine the Validators function perfecly and also when I |
| deploy using XCOPY to a web server.
|
| The problem seems to arrise when I decided to change the root folder of
the
|
| web page in IIS to point to a different directory. In this case the
|
| validators stop working (although the page continues to work)
|
| To be more precise these are the directories:
|
| The folder configuration is the following
|
| c:\inetpub\wwwroot\siteName\application
|
| The page is working when in IIS home directory I set it to point to
|
| \siteName and I browse to page using http://mysite/application/
|
| When I point the IIS home directory straight to \siteName\application (and |
| browse directly using http://mysite/ ) Validators stop working.
|
| What could the problem be? What am I missing or what parameters I need to |
| configure (that forgot probably) in IIS to make the Validators control
work
|
| again?
|
|
|

Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Tom Pearson | last post: by
reply views Thread by Bryce Budd | last post: by
2 posts views Thread by Pham Nguyen | last post: by
5 posts views Thread by Richard Payne | last post: by
3 posts views Thread by Angelos Karantzalis | last post: by
reply views Thread by Gonza | last post: by
1 post views Thread by Gonza | last post: by
1 post views Thread by Waqarahmed | last post: by
reply views Thread by Salome Sato | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.