468,456 Members | 1,804 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,456 developers. It's quick & easy.

button event won't fire

Hi,

I have a button event that won't fire. I left it on Friday and it worked
fine. I came back in on Monday and it won't fire.

I tried putting another button and just putting a response.write on its
click handler but it won't fire either telling me no button click events
will fire. But my calendar control on the same page does fire.

In the debugger I put a break point in the calendar event and the button
event. I see it breaking in the calendar selection_changed event but not
the button_clicked events.

I do have a bunch of validators on the page, so here is the full
btnSubmit_click event:
---------------------------------------------
Private Sub btnSubmit_Click(ByVal sender As Object, ByVal e As
System.EventArgs) Handles btnSubmit.Click

If Page.IsValid Then

'some connection code

SaveChatInfo()

SaveGuestsInfo()

Response.Redirect("newchatready.aspx?chatID=" & viewState("ChatID"))

End If

End Sub

-------------------------------------------------------------------


Nov 18 '05 #1
2 3578
Sam,

As your event does not fire, it's more interesting, what's *around* your
event handler ;-)

Could you post the designer code?

Cheers, Philipp


Sam Miller wrote:
Hi,

I have a button event that won't fire. I left it on Friday and it worked
fine. I came back in on Monday and it won't fire.

I tried putting another button and just putting a response.write on its
click handler but it won't fire either telling me no button click events
will fire. But my calendar control on the same page does fire.

In the debugger I put a break point in the calendar event and the button
event. I see it breaking in the calendar selection_changed event but not
the button_clicked events.

I do have a bunch of validators on the page, so here is the full
btnSubmit_click event:
---------------------------------------------
Private Sub btnSubmit_Click(ByVal sender As Object, ByVal e As
System.EventArgs) Handles btnSubmit.Click

If Page.IsValid Then

'some connection code

SaveChatInfo()

SaveGuestsInfo()

Response.Redirect("newchatready.aspx?chatID=" & viewState("ChatID"))

End If

End Sub

-------------------------------------------------------------------

Nov 18 '05 #2

Hey we found the problem.
We installed Service Pack 4 over the weekend which reverts the .Net
Framework (and validator JS script) back to 1.0.

After reinstalling .Net Framework 1.1 its ok.

Sam

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Carlo Marchesoni | last post: by
6 posts views Thread by Michael Johnson Jr. | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.