By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,984 Members | 1,016 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,984 IT Pros & Developers. It's quick & easy.

enable client side debugging

P: n/a
How do you enable debugging so that people see it from the client side? I
have gone in to properties, clicked on edit www service, clicked on the home
directory tab, clicked on the configuration button, clicked on the app
debugging tab and then checked the box that says enable ASP client-side
script debugging. But on the client side they still get the generic debug
message:

--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Have you changed the web.config file to enable client side debugging

AS it says in your error message
<customErrors mode="RemoteOnly"/>

must be changed to
<customErrors mode="Off"/>

"si******@webster.edu" <si****************@discussions.microsoft.com> wrote
in message news:2C**********************************@microsof t.com...
How do you enable debugging so that people see it from the client side? I
have gone in to properties, clicked on edit www service, clicked on the
home
directory tab, clicked on the configuration button, clicked on the app
debugging tab and then checked the box that says enable ASP client-side
script debugging. But on the client side they still get the generic debug
message:

--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current
custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could,
however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable
on remote machines, please create a <customErrors> tag within a
"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the
application's
<customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"
defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.