By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
460,019 Members | 1,435 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 460,019 IT Pros & Developers. It's quick & easy.

visual studio reformatting question

P: n/a
Appologies if this is a wrong newgroup for this question, but i can't find a
visualstudio newgroup (at least not an english one, their is a french and
arabic one)

Anyways, i have a highly annoying problem with visual studio.

Every time i add a new control to the page, visual studio decides to format
my code in its "special format".

So i have code that looks like this:

<table border=0 cellpadding=0>
<tr>
<td>
<asp:TextBox runat=server id=tb />
</td>
</tr>
</table>

Then visual studio reformats it like this.

<table border=0 cellpadding=0>
<tr><td><asp:TextBox runat=server id=tb></asp:Textbox></td></tr></table>
Why? and HOw do i stop this highly ANNOYING function?
Nov 18 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
I am sorry to have to tell you this, but you can't. Even though changes are
made in the VS.NET settings, it seem to ignore it. At best you can use
the "Format the whole document" button (Ctrl + K, Ctrl + D) on the
"HTML Editor" toolbar to reshape the html to a somewhat readable
form.

HTH,

//Andreas
"GrantMagic" <gr***@magicalia.com> skrev i meddelandet
news:eq**************@tk2msftngp13.phx.gbl...
Appologies if this is a wrong newgroup for this question, but i can't find a visualstudio newgroup (at least not an english one, their is a french and
arabic one)

Anyways, i have a highly annoying problem with visual studio.

Every time i add a new control to the page, visual studio decides to format my code in its "special format".

So i have code that looks like this:

<table border=0 cellpadding=0>
<tr>
<td>
<asp:TextBox runat=server id=tb />
</td>
</tr>
</table>

Then visual studio reformats it like this.

<table border=0 cellpadding=0>
<tr><td><asp:TextBox runat=server id=tb></asp:Textbox></td></tr></table>
Why? and HOw do i stop this highly ANNOYING function?

Nov 18 '05 #2

P: n/a
nothing beats Ctrl+Z :-)

Thanks for the advice.
"Andreas Håkansson" <an***************@nospam.com> wrote in message
news:OT**************@TK2MSFTNGP11.phx.gbl...
I am sorry to have to tell you this, but you can't. Even though changes are
made in the VS.NET settings, it seem to ignore it. At best you can use
the "Format the whole document" button (Ctrl + K, Ctrl + D) on the
"HTML Editor" toolbar to reshape the html to a somewhat readable
form.

HTH,

//Andreas
"GrantMagic" <gr***@magicalia.com> skrev i meddelandet
news:eq**************@tk2msftngp13.phx.gbl...
Appologies if this is a wrong newgroup for this question, but i can't
find

a
visualstudio newgroup (at least not an english one, their is a french and
arabic one)

Anyways, i have a highly annoying problem with visual studio.

Every time i add a new control to the page, visual studio decides to

format
my code in its "special format".

So i have code that looks like this:

<table border=0 cellpadding=0>
<tr>
<td>
<asp:TextBox runat=server id=tb />
</td>
</tr>
</table>

Then visual studio reformats it like this.

<table border=0 cellpadding=0>
<tr><td><asp:TextBox runat=server id=tb></asp:Textbox></td></tr></table>
Why? and HOw do i stop this highly ANNOYING function?


Nov 18 '05 #3

P: n/a
Yeah, I use Ctrl + Z frequently to undo the havoc that VS.NET does to the
HTML code, but every now and then I find myself in a sitution where it is
not an option and I have to resort too the "next best thing" :)

I can mention, as a side note, that VS2005 promises to have a robust system
of "dont touch my code" settings ... too bad the final version isn't due
until around
april 2005 =)

//Andreas

"GrantMagic" <gr***@magicalia.com> skrev i meddelandet
news:%2***************@tk2msftngp13.phx.gbl...
nothing beats Ctrl+Z :-)

Thanks for the advice.
"Andreas Håkansson" <an***************@nospam.com> wrote in message
news:OT**************@TK2MSFTNGP11.phx.gbl...
I am sorry to have to tell you this, but you can't. Even though changes are made in the VS.NET settings, it seem to ignore it. At best you can use
the "Format the whole document" button (Ctrl + K, Ctrl + D) on the
"HTML Editor" toolbar to reshape the html to a somewhat readable
form.

HTH,

//Andreas
"GrantMagic" <gr***@magicalia.com> skrev i meddelandet
news:eq**************@tk2msftngp13.phx.gbl...
Appologies if this is a wrong newgroup for this question, but i can't
find

a
visualstudio newgroup (at least not an english one, their is a french and arabic one)

Anyways, i have a highly annoying problem with visual studio.

Every time i add a new control to the page, visual studio decides to

format
my code in its "special format".

So i have code that looks like this:

<table border=0 cellpadding=0>
<tr>
<td>
<asp:TextBox runat=server id=tb />
</td>
</tr>
</table>

Then visual studio reformats it like this.

<table border=0 cellpadding=0>
<tr><td><asp:TextBox runat=server id=tb></asp:Textbox></td></tr></table>

Why? and HOw do i stop this highly ANNOYING function?



Nov 18 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.