By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,784 Members | 1,182 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,784 IT Pros & Developers. It's quick & easy.

SBS2003 and ASP.net

P: n/a
When I'm trying to deploy an ASP.Net app to Small Business Server 2003 I
can't allow the ASPNET user access to the directory because it isn't found in
active directory. I have run aspnet_regiis.exe -i and it does not add the
user. I have other sites on this server that are running ASP.Net apps without
a problem. How do I fix this?
Nov 18 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
I also have an ASP.NET application running on SBS2003. Seems ASPNET account
access setting is not required at all.
I just copy the access right settings from another ADs running ASP.NET
application and it works fine.

"SubstandardSnowman" <Su****************@discussions.microsoft.com> bl
news:EE**********************************@microsof t.com g...
When I'm trying to deploy an ASP.Net app to Small Business Server 2003 I
can't allow the ASPNET user access to the directory because it isn't found in active directory. I have run aspnet_regiis.exe -i and it does not add the
user. I have other sites on this server that are running ASP.Net apps without a problem. How do I fix this?

Nov 18 '05 #2

P: n/a
It looks like you're right. After reading your response I finally found this
article
http://support.microsoft.com/default.aspx?kbid=316721
it says that on Windows 2003 (and SBS 2003) You don't use the aspnet account
but you use the Network Service account. Once I allowed that account read &
execute, list, and read rights it started working.
Thanks for your help.

"Lau Lei Cheong" wrote:
I also have an ASP.NET application running on SBS2003. Seems ASPNET account
access setting is not required at all.
I just copy the access right settings from another ADs running ASP.NET
application and it works fine.

"SubstandardSnowman" <Su****************@discussions.microsoft.com> ¦b¶l¥ó
news:EE**********************************@microsof t.com ¤¤¼¶¼g...
When I'm trying to deploy an ASP.Net app to Small Business Server 2003 I
can't allow the ASPNET user access to the directory because it isn't found

in
active directory. I have run aspnet_regiis.exe -i and it does not add the
user. I have other sites on this server that are running ASP.Net apps

without
a problem. How do I fix this?


Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.