By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,617 Members | 1,751 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,617 IT Pros & Developers. It's quick & easy.

Impersonate Identity doesn't work on the server

P: n/a
Hello,

In my application I have to impersonate users, so I add

<identity impersonate="true" />

to the Web.config file.

As long as I run the application on my PC - everything works fine. As soon
as I put the application on the server - I cannot run the application at
all, I get an "Access denied" error. When I remove impersonation -
everything works OK.

What can I do about it? Whithout impersonation my application won't work.

The server is Windows 2003, and it's a domain controller. We are also using
Windows authentication.

I would appreciate your comments.

Thank you,

--
Peter Afonin
Nov 18 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Well, does the impersonated identity have access to whatever you are trying
to access?

Cheers
Ken
"Peter Afonin" <pe***@gudzon.net> wrote in message
news:ej**************@TK2MSFTNGP15.phx.gbl...
Hello,

In my application I have to impersonate users, so I add

<identity impersonate="true" />

to the Web.config file.

As long as I run the application on my PC - everything works fine. As soon
as I put the application on the server - I cannot run the application at
all, I get an "Access denied" error. When I remove impersonation -
everything works OK.

What can I do about it? Whithout impersonation my application won't work.

The server is Windows 2003, and it's a domain controller. We are also
using
Windows authentication.

I would appreciate your comments.

Thank you,

--
Peter Afonin

Nov 18 '05 #2

P: n/a
Hi Ken,

I'm just trying to run the application, and it doesn't run with impersonated
identity. I don't know what access I should set up.

Thanks,

Peter

"Ken Schaefer" <ke*******@THISadOpenStatic.com> wrote in message
news:uB**************@tk2msftngp13.phx.gbl...
Well, does the impersonated identity have access to whatever you are trying to access?

Cheers
Ken
"Peter Afonin" <pe***@gudzon.net> wrote in message
news:ej**************@TK2MSFTNGP15.phx.gbl...
Hello,

In my application I have to impersonate users, so I add

<identity impersonate="true" />

to the Web.config file.

As long as I run the application on my PC - everything works fine. As soon as I put the application on the server - I cannot run the application at
all, I get an "Access denied" error. When I remove impersonation -
everything works OK.

What can I do about it? Whithout impersonation my application won't work.
The server is Windows 2003, and it's a domain controller. We are also
using
Windows authentication.

I would appreciate your comments.

Thank you,

--
Peter Afonin


Nov 18 '05 #3

P: n/a
I've found the solution in this article:
http://support.microsoft.com/default...b;en-us;824308

Although it's about Win2000 SP4 and I have Win2003, this worked for me.

Thanks,

Peter

"Ken Schaefer" <ke*******@THISadOpenStatic.com> wrote in message
news:uB**************@tk2msftngp13.phx.gbl...
Well, does the impersonated identity have access to whatever you are trying to access?

Cheers
Ken
"Peter Afonin" <pe***@gudzon.net> wrote in message
news:ej**************@TK2MSFTNGP15.phx.gbl...
Hello,

In my application I have to impersonate users, so I add

<identity impersonate="true" />

to the Web.config file.

As long as I run the application on my PC - everything works fine. As soon as I put the application on the server - I cannot run the application at
all, I get an "Access denied" error. When I remove impersonation -
everything works OK.

What can I do about it? Whithout impersonation my application won't work.
The server is Windows 2003, and it's a domain controller. We are also
using
Windows authentication.

I would appreciate your comments.

Thank you,

--
Peter Afonin


Nov 18 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.