By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,739 Members | 1,506 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,739 IT Pros & Developers. It's quick & easy.

Failed to start monitoring changes to

P: n/a
Hi,

My App running on my local machine is trying to access apsx and ascx pages
via a virtual directory (see earlier post) that points to a share on a
different machine.

I can now access .aspx and run .aspx pages ok. However I've added a <@
register tag to a local page that references a .ascx page on the remote share
(via the virtual directory). I now get a 'Failed to start monitoring changes
to ' error on the @register statement.
I've seen this mentioned on the web in a few places but all the solutions
suggest adding access rights for 'APSNET' and 'NETWORK Service' accounts.
Just to make sure access rights aren't the issue the share now has 'Everyone'
full access, but I still get the error.

Any clues?

Nov 18 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Hi kimpton,

From your description, you have a asp.net web application host in a local
virutal dir which point to a remote shared folder(the web pages and
resouces are in that shared folder). Then, you encounter 'Failed to start
monitoring changes
to ' error ,yes?

Based on my experience, such problem does likely be caused by permission
issue since the ASP.NET runtime need to monitor the files and assemlbies in
the application so that whenever there are any changes on them, the certain
component should be recompiled or the app need be restarted.

As you mentioned that the error occur on the "@register " directive, yes?
What's the assembly the @register has referenced? Also, is there any
problem if you visit other pages in the sites or just the page which has
this "@register" diretive suffer th problem?

In addition, since the virutal folder point to a remote shared folder,
what's its UNC "Connect As" account which is configured in the IIS? Is it a
powerful account?

If you have any other findings or question, please feel free to post here .
Thanks.

Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx
Nov 18 '05 #2

P: n/a
Hi,

Thanks for the quick response.

I have a web app on my local server. We also have a collection of shared
aspx and ascx files on a remote server. The local web app has a virutal
directory created in IIS pointing at the share on the remote server with the
aspx and ascx files.

Accessing and executing aspx files works fine. So if my virtual directory is
called 'sharedstuff', this works ok:

http://localhost/appname/sharedstuff/asharedaspx.aspx.

However if a local aspx page includes a register directive to a shared ascx
via the virtual directory I get the 'Failed to start monitoring changes
error', e.g.

<%@ Register TagPrefix="shared" TagName="someascx"
Src="../sharedstuff/asharedascx.ascx" %>

I get error on this line in the error output.

The share on the remote server has 'Everyone' full access.


Nov 18 '05 #3

P: n/a
Hi kimpton,

Thanks for your response. Regarding on your further description, I've done
some tests on my side, and found that the problem is acutally caused by
permission issue. Since the sub web folder is point to a remote shared
folder. And the ASP.NET will use the default processAcount (machine\aspnet
for iis 5 or networkservice for iis6) to do the folder monitor. However,
since the default process account is a local account, it'll failed on logon
remote mahcine no matter the remote folder has been grant "Full Control"
to everyone or not. That's the problem you encountered. (You can find the
error in the remote machine's eventlog).

Currently, I think you need to specify another Account which can be
authenticated on the remote machine as the local's ASPNET worker process
account, you can use either a
Domain User Account or an mapping local account( which exists on both the
local and remote machine and have same username and passworld).

Then, use the following means to speicify it as the ASP.NET's process
account:
1. In machine.config, find the <processModel> element and change the
"userName" and "password"
attributes to the certain account's value

2. You can also specify it for only a certain web application(rather than
the whole machine) in the web.config via the <identity impersonate="true"
userName=".." password=".."/>
This is more recommended.

In addition, do make sure that the account has powerful permssions on the
local machine( to run asp.net application, you can make it in the
administrators group) and has sufficient control to the remote folder on
the remote machine. and the following tech article is also helpful:

#How To Create a Custom Account to Run ASP.NET
http://msdn.microsoft.com/library/de...us/secmod/html
/secmod15.asp
Thanks.
Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx


Nov 18 '05 #4

P: n/a
Hi Steve,

That did the trick. Thanks for helping :-)

cheers
K

"Steven Cheng[MSFT]" wrote:
Hi kimpton,

Thanks for your response. Regarding on your further description, I've done
some tests on my side, and found that the problem is acutally caused by
permission issue. Since the sub web folder is point to a remote shared
folder. And the ASP.NET will use the default processAcount (machine\aspnet
for iis 5 or networkservice for iis6) to do the folder monitor. However,
since the default process account is a local account, it'll failed on logon
remote mahcine no matter the remote folder has been grant "Full Control"
to everyone or not. That's the problem you encountered. (You can find the
error in the remote machine's eventlog).

Currently, I think you need to specify another Account which can be
authenticated on the remote machine as the local's ASPNET worker process
account, you can use either a
Domain User Account or an mapping local account( which exists on both the
local and remote machine and have same username and passworld).

Then, use the following means to speicify it as the ASP.NET's process
account:
1. In machine.config, find the <processModel> element and change the
"userName" and "password"
attributes to the certain account's value

2. You can also specify it for only a certain web application(rather than
the whole machine) in the web.config via the <identity impersonate="true"
userName=".." password=".."/>
This is more recommended.

In addition, do make sure that the account has powerful permssions on the
local machine( to run asp.net application, you can make it in the
administrators group) and has sufficient control to the remote folder on
the remote machine. and the following tech article is also helpful:

#How To Create a Custom Account to Run ASP.NET
http://msdn.microsoft.com/library/de...us/secmod/html
/secmod15.asp
Thanks.
Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx


Nov 18 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.