By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,318 Members | 2,340 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,318 IT Pros & Developers. It's quick & easy.

Can't switch to Design View in VS.Net 2003

P: n/a
I've a repeater and here is a piece of HTML when I use, I can't switch back
to Design view:
<a href=default.aspx?id=<%#container.dataitem("id")%> Some Link</a>

I get this error message:
Could not open in design view. Place quotes around a '<% %>' used as an
attribute value or within a <SELECT> element.

well, actually I used <% %> as an attribute value, why I shouldn't?
would you suggest an alternative?
Nov 18 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Try placing quotes around <% %> :-)
Like this:
<a href='default.aspx?id=<%#container.dataitem("id")% >'>Some Link</a>

Tomas Petricek
Microsoft C# MVP

-----Original Message-----
From: Saber [mailto:saber[--AT--]maghalat.com]
Posted At: Saturday, July 31, 2004 11:29 PM
Posted To: microsoft.public.dotnet.framework.aspnet
Conversation: Can't switch to Design View in VS.Net 2003
Subject: Can't switch to Design View in VS.Net 2003

I've a repeater and here is a piece of HTML when I use, I can't switch
back
to Design view:
<a href=default.aspx?id=<%#container.dataitem("id")%> Some Link</a>

I get this error message:
Could not open in design view. Place quotes around a '<% %>' used as an
attribute value or within a <SELECT> element.

well, actually I used <% %> as an attribute value, why I shouldn't?
would you suggest an alternative?
Nov 18 '05 #2

P: n/a
Thanks dear MVP :)
sorry for such simple question!

"Tomas Petricek" <to***@eeeksoft.net> wrote in message
news:Og*************@TK2MSFTNGP09.phx.gbl...
Try placing quotes around <% %> :-)
Like this:
<a href='default.aspx?id=<%#container.dataitem("id")% >'>Some Link</a>

Tomas Petricek
Microsoft C# MVP

Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.