By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,070 Members | 1,237 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,070 IT Pros & Developers. It's quick & easy.

User Identity

P: n/a
Joe

I check for the NTLogin of a user by
Page.User.Identity.Name,

but when I put the app on the server the value for
Page.User.Identity.Name is ""

I had the <allow users="*/> attribute commented out on my
machine and had <deny users="?"/>

how do I do this on the server to get the user NTLogin
name

thanks
Nov 18 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
Does your web site require authentication? If not, everyone is logging in as
anonymous.

--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"Joe" <an*******@discussions.microsoft.com> wrote in message
news:5a****************************@phx.gbl...

I check for the NTLogin of a user by
Page.User.Identity.Name,

but when I put the app on the server the value for
Page.User.Identity.Name is ""

I had the <allow users="*/> attribute commented out on my
machine and had <deny users="?"/>

how do I do this on the server to get the user NTLogin
name

thanks

Nov 18 '05 #2

P: n/a
Make sure you uncheck Anonymous access in IIS for your vitual directory.
Check Integrated Windows authenticaiton.

Add <authentication mode="Windows" /> to web.config.

I wouldn't mess with the <allow/deny users> until you can read the username.

HTH,
Greg

"Joe" <an*******@discussions.microsoft.com> wrote in message
news:5a****************************@phx.gbl...

I check for the NTLogin of a user by
Page.User.Identity.Name,

but when I put the app on the server the value for
Page.User.Identity.Name is ""

I had the <allow users="*/> attribute commented out on my
machine and had <deny users="?"/>

how do I do this on the server to get the user NTLogin
name

thanks

Nov 18 '05 #3

P: n/a
Joe

Thanks a lot guys, Everyone was logging in anonymously

I have 2 more questions and would appreciate if you guys
could answer

what happens when I make a setup and this is deployed on
the server.Is it anonymous access by default on the
server.

If so how can I authorize users in an intranet to access
the web page without the username/password dialog coming
up and at the same time get the NT Login of the user
Thanks for all your help

-----Original Message-----
Make sure you uncheck Anonymous access in IIS for your vitual directory.Check Integrated Windows authenticaiton.

Add <authentication mode="Windows" /> to web.config.

I wouldn't mess with the <allow/deny users> until you can read the username.
HTH,
Greg

"Joe" <an*******@discussions.microsoft.com> wrote in messagenews:5a****************************@phx.gbl...

I check for the NTLogin of a user by
Page.User.Identity.Name,

but when I put the app on the server the value for
Page.User.Identity.Name is ""

I had the <allow users="*/> attribute commented out on my machine and had <deny users="?"/>

how do I do this on the server to get the user NTLogin
name

thanks

.

Nov 18 '05 #4

P: n/a
> what happens when I make a setup and this is deployed on
the server.Is it anonymous access by default on the
server.
These permissions are managed by IIS. By default, web sites in IIS allow
anonymous access.
If so how can I authorize users in an intranet to access
the web page without the username/password dialog coming
up and at the same time get the NT Login of the user
Use Windows Integrated Authentication.

--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"Joe" <an*******@discussions.microsoft.com> wrote in message
news:5b****************************@phx.gbl...
Thanks a lot guys, Everyone was logging in anonymously

I have 2 more questions and would appreciate if you guys
could answer

what happens when I make a setup and this is deployed on
the server.Is it anonymous access by default on the
server.

If so how can I authorize users in an intranet to access
the web page without the username/password dialog coming
up and at the same time get the NT Login of the user
Thanks for all your help

-----Original Message-----
Make sure you uncheck Anonymous access in IIS for your

vitual directory.
Check Integrated Windows authenticaiton.

Add <authentication mode="Windows" /> to web.config.

I wouldn't mess with the <allow/deny users> until you

can read the username.

HTH,
Greg

"Joe" <an*******@discussions.microsoft.com> wrote in

message
news:5a****************************@phx.gbl...

I check for the NTLogin of a user by
Page.User.Identity.Name,

but when I put the app on the server the value for
Page.User.Identity.Name is ""

I had the <allow users="*/> attribute commented out on my machine and had <deny users="?"/>

how do I do this on the server to get the user NTLogin
name

thanks

.

Nov 18 '05 #5

P: n/a
Joe

Kevin,

Could you please point me to some examples/explain how I
can set Windows Integrate Authentication for my
application.

I can only see a check box for the same in IIS which is
ticked but the user still gets a username/password dialog

could you kindly explain the process

Thanks a lot for your help

Regards

Joeseph
-----Original Message-----
what happens when I make a setup and this is deployed on the server.Is it anonymous access by default on the
server.
These permissions are managed by IIS. By default, web

sites in IIS allowanonymous access.
If so how can I authorize users in an intranet to access the web page without the username/password dialog coming up and at the same time get the NT Login of the user
Use Windows Integrated Authentication.

--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"Joe" <an*******@discussions.microsoft.com> wrote in

messagenews:5b****************************@phx.gbl...

Thanks a lot guys, Everyone was logging in anonymously

I have 2 more questions and would appreciate if you guys could answer

what happens when I make a setup and this is deployed on the server.Is it anonymous access by default on the
server.

If so how can I authorize users in an intranet to access the web page without the username/password dialog coming up and at the same time get the NT Login of the user
Thanks for all your help

>-----Original Message-----
>Make sure you uncheck Anonymous access in IIS for your

vitual directory.
>Check Integrated Windows authenticaiton.
>
>Add <authentication mode="Windows" /> to web.config.
>
>I wouldn't mess with the <allow/deny users> until you

can read the username.
>
>HTH,
>Greg
>
>"Joe" <an*******@discussions.microsoft.com> wrote in

message
>news:5a****************************@phx.gbl...
>>
>> I check for the NTLogin of a user by
>> Page.User.Identity.Name,
>>
>> but when I put the app on the server the value for
>> Page.User.Identity.Name is ""
>>
>> I had the <allow users="*/> attribute commented out on
my
>> machine and had <deny users="?"/>
>>
>> how do I do this on the server to get the user

NTLogin >> name
>>
>> thanks
>
>
>.
>

.

Nov 18 '05 #6

P: n/a
Authentication method is in the Properties dialog of your web site in the
IIS snap-in. You need to disallow anonymous access, and use Windows
Integrated Authentication.

In the user's IE, in the Security tab of the Internet Options dialog,
clicking "Custom Level" will bring up a detailed dialog of settings. At the
bottom is "User Authentication." Set it to automatically log in with current
User Name and Password. This will stop the dialog from coming up, as long as
the user is logged into the domain that the server is using.

--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"Joe" <an*******@discussions.microsoft.com> wrote in message
news:5c****************************@phx.gbl...

Kevin,

Could you please point me to some examples/explain how I
can set Windows Integrate Authentication for my
application.

I can only see a check box for the same in IIS which is
ticked but the user still gets a username/password dialog

could you kindly explain the process

Thanks a lot for your help

Regards

Joeseph
-----Original Message-----
what happens when I make a setup and this is deployed on the server.Is it anonymous access by default on the
server.


These permissions are managed by IIS. By default, web

sites in IIS allow
anonymous access.
If so how can I authorize users in an intranet to access the web page without the username/password dialog coming up and at the same time get the NT Login of the user


Use Windows Integrated Authentication.

--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"Joe" <an*******@discussions.microsoft.com> wrote in

message
news:5b****************************@phx.gbl...

Thanks a lot guys, Everyone was logging in anonymously

I have 2 more questions and would appreciate if you guys could answer

what happens when I make a setup and this is deployed on the server.Is it anonymous access by default on the
server.

If so how can I authorize users in an intranet to access the web page without the username/password dialog coming up and at the same time get the NT Login of the user
Thanks for all your help
>-----Original Message-----
>Make sure you uncheck Anonymous access in IIS for your
vitual directory.
>Check Integrated Windows authenticaiton.
>
>Add <authentication mode="Windows" /> to web.config.
>
>I wouldn't mess with the <allow/deny users> until you
can read the username.
>
>HTH,
>Greg
>
>"Joe" <an*******@discussions.microsoft.com> wrote in
message
>news:5a****************************@phx.gbl...
>>
>> I check for the NTLogin of a user by
>> Page.User.Identity.Name,
>>
>> but when I put the app on the server the value for
>> Page.User.Identity.Name is ""
>>
>> I had the <allow users="*/> attribute commented out on my
>> machine and had <deny users="?"/>
>>
>> how do I do this on the server to get the user NTLogin >> name
>>
>> thanks
>
>
>.
>

.

Nov 18 '05 #7

P: n/a
Joe
Kevin,

I have made the changes accordingly, but what happens
when my application is deployed on a server to be
accessible for all the people in the intranet.

The dialog would come up for all the users.Is there a way
to bypass this.
-----Original Message-----
Authentication method is in the Properties dialog of your web site in theIIS snap-in. You need to disallow anonymous access, and use WindowsIntegrated Authentication.

In the user's IE, in the Security tab of the Internet Options dialog,clicking "Custom Level" will bring up a detailed dialog of settings. At thebottom is "User Authentication." Set it to automatically log in with currentUser Name and Password. This will stop the dialog from coming up, as long asthe user is logged into the domain that the server is using.
--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"Joe" <an*******@discussions.microsoft.com> wrote in messagenews:5c****************************@phx.gbl...

Kevin,

Could you please point me to some examples/explain how I can set Windows Integrate Authentication for my
application.

I can only see a check box for the same in IIS which is
ticked but the user still gets a username/password dialog
could you kindly explain the process

Thanks a lot for your help

Regards

Joeseph
>-----Original Message-----
>> what happens when I make a setup and this is deployed
on
>> the server.Is it anonymous access by default on the
>> server.
>
>These permissions are managed by IIS. By default, web

sites in IIS allow
>anonymous access.
>
>> If so how can I authorize users in an intranet to

access
>> the web page without the username/password dialog

coming
>> up and at the same time get the NT Login of the user
>
>Use Windows Integrated Authentication.
>
>--
>HTH,
>Kevin Spencer
>..Net Developer
>Microsoft MVP
>Big things are made up
>of lots of little things.
>
>"Joe" <an*******@discussions.microsoft.com> wrote in

message
>news:5b****************************@phx.gbl...
>>
>> Thanks a lot guys, Everyone was logging in
anonymously >>
>> I have 2 more questions and would appreciate if you

guys
>> could answer
>>
>> what happens when I make a setup and this is deployed on
>> the server.Is it anonymous access by default on the
>> server.
>>
>> If so how can I authorize users in an intranet to

access
>> the web page without the username/password dialog

coming
>> up and at the same time get the NT Login of the user
>>
>>
>> Thanks for all your help
>>
>>
>> >-----Original Message-----
>> >Make sure you uncheck Anonymous access in IIS for
your >> vitual directory.
>> >Check Integrated Windows authenticaiton.
>> >
>> >Add <authentication mode="Windows" /> to web.config. >> >
>> >I wouldn't mess with the <allow/deny users> until you >> can read the username.
>> >
>> >HTH,
>> >Greg
>> >
>> >"Joe" <an*******@discussions.microsoft.com> wrote in >> message
>> >news:5a****************************@phx.gbl...
>> >>
>> >> I check for the NTLogin of a user by
>> >> Page.User.Identity.Name,
>> >>
>> >> but when I put the app on the server the value for >> >> Page.User.Identity.Name is ""
>> >>
>> >> I had the <allow users="*/> attribute commented

out on
>> my
>> >> machine and had <deny users="?"/>
>> >>
>> >> how do I do this on the server to get the user

NTLogin
>> >> name
>> >>
>> >> thanks
>> >
>> >
>> >.
>> >
>
>
>.
>

.

Nov 18 '05 #8

P: n/a
Hi Joe,

You've got 2 choices: 1. Allow anonymous access. 2. Don't allow anonymous
access. If you want certain parts of the site to be only for intranet users,
I would suggest putting them on a separate web or sub-web (separate
application).

--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"Joe" <an*******@discussions.microsoft.com> wrote in message
news:5f****************************@phx.gbl...
Kevin,

I have made the changes accordingly, but what happens
when my application is deployed on a server to be
accessible for all the people in the intranet.

The dialog would come up for all the users.Is there a way
to bypass this.
-----Original Message-----
Authentication method is in the Properties dialog of

your web site in the
IIS snap-in. You need to disallow anonymous access, and

use Windows
Integrated Authentication.

In the user's IE, in the Security tab of the Internet

Options dialog,
clicking "Custom Level" will bring up a detailed dialog

of settings. At the
bottom is "User Authentication." Set it to automatically

log in with current
User Name and Password. This will stop the dialog from

coming up, as long as
the user is logged into the domain that the server is

using.

--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"Joe" <an*******@discussions.microsoft.com> wrote in

message
news:5c****************************@phx.gbl...

Kevin,

Could you please point me to some examples/explain how I can set Windows Integrate Authentication for my
application.

I can only see a check box for the same in IIS which is
ticked but the user still gets a username/password dialog
could you kindly explain the process

Thanks a lot for your help

Regards

Joeseph

>-----Original Message-----
>> what happens when I make a setup and this is deployed on
>> the server.Is it anonymous access by default on the
>> server.
>
>These permissions are managed by IIS. By default, web
sites in IIS allow
>anonymous access.
>
>> If so how can I authorize users in an intranet to
access
>> the web page without the username/password dialog
coming
>> up and at the same time get the NT Login of the user
>
>Use Windows Integrated Authentication.
>
>--
>HTH,
>Kevin Spencer
>..Net Developer
>Microsoft MVP
>Big things are made up
>of lots of little things.
>
>"Joe" <an*******@discussions.microsoft.com> wrote in
message
>news:5b****************************@phx.gbl...
>>
>> Thanks a lot guys, Everyone was logging in anonymously >>
>> I have 2 more questions and would appreciate if you
guys
>> could answer
>>
>> what happens when I make a setup and this is deployed on
>> the server.Is it anonymous access by default on the
>> server.
>>
>> If so how can I authorize users in an intranet to
access
>> the web page without the username/password dialog
coming
>> up and at the same time get the NT Login of the user
>>
>>
>> Thanks for all your help
>>
>>
>> >-----Original Message-----
>> >Make sure you uncheck Anonymous access in IIS for your >> vitual directory.
>> >Check Integrated Windows authenticaiton.
>> >
>> >Add <authentication mode="Windows" /> to web.config. >> >
>> >I wouldn't mess with the <allow/deny users> until you >> can read the username.
>> >
>> >HTH,
>> >Greg
>> >
>> >"Joe" <an*******@discussions.microsoft.com> wrote in >> message
>> >news:5a****************************@phx.gbl...
>> >>
>> >> I check for the NTLogin of a user by
>> >> Page.User.Identity.Name,
>> >>
>> >> but when I put the app on the server the value for >> >> Page.User.Identity.Name is ""
>> >>
>> >> I had the <allow users="*/> attribute commented out on
>> my
>> >> machine and had <deny users="?"/>
>> >>
>> >> how do I do this on the server to get the user
NTLogin
>> >> name
>> >>
>> >> thanks
>> >
>> >
>> >.
>> >
>
>
>.
>

.

Nov 18 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.