423,103 Members | 1,347 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 423,103 IT Pros & Developers. It's quick & easy.

Error suddenly fixed: BC31011: Unable to load referenced library

P: n/a
Hi,

I used to have this error come up everytime I tried to
build(Ctrl+Shift+B) my ASP.NET app:

(ERROR#1)
Compiler Error Message: BC31011: Unable to load referenced library
'c:\winnt\microsoft.net\framework\v1.1.4322\...': Access is denied.

The workaround solution was to add a space or change the code a bit
and build(Ctrl+Shift+B) it again and it used to work. But a strange
thing happened. Over to the production server we had this error
showing up:

(ERROR#2)
Timeout expired. The timeout period elapsed prior to obtaining a
connection from the pool.

And I was trying to fix the code adding .close or .dispose to all my
SqlClient Objects (sqlDataAdaptor, sqlDataReader, sqlCommand,
sqlConnection etc) and then I noticed that my first error(ERROR#1)
disappeared. It just stopped showing up. Im not sure how it helped
but the error is gone. Earlier, I had tried removing
'c:\winnt\microsoft.net\framework\' folder in the index server to be
indexed but that didnt help.

Anyway, your comments are welcomed. Im specially looking forward to
someone explaining how that helped get rid off the error. Any idea?

Thanx.
Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hi,

my assumption is that due to the fact that you didnt free connection
eventually, in debug mode, your code hold referense that didnt free to
System.data dll. therefore you get unable to load ... . every time that
you change your code ASP.NET file change monitors simply killed the
exidting "code" that runs thus compilition works. again just assumption
...

Natty Gur[MVP]

blog : http://weblogs.asp.net/ngur
Mobile: +972-(0)52-8888377
*** Sent via Devdex http://www.devdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.