470,573 Members | 1,713 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,573 developers. It's quick & easy.

Error when i run my page

i am getting the following error when i run my page
i know that it has something to do with the fact that i am running cassini
and not iis because i have windows xp home.
but i need to find a way around this so that i my run and test my web pages.

here is the error:
Server Error in '/' Application.
----------------------------------------------------------------------------
----

Configuration Error
Description: An error occurred during the processing of a configuration file
required to service this request. Please review the specific error details
below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.

Source Error:

Line 37: by Microsoft that offers a single logon and core profile
services for member sites.
Line 38: -->
Line 39: <authentication mode="Windows" />
Line 40:
Line 41:

Source File: C:\Asp\Pimp\web.config Line: 39
----------------------------------------------------------------------------
----
Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET
Version:1.1.4322.573

WStoreyII

thanks for all the help
Nov 18 '05 #1
4 1003
The answer is in the Error Message itself. If you open IIS, right click
on any Virtual Directory, You will see a button called Create. If you
click this button an Application is created within which the ASP.NET
application will run. This is required because you have a web.config
file in this folder. Now find out how to achieve this in Cassini .

Regards,

Trevor Benedict R
MCSD

*** Sent via Devdex http://www.devdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #2
Trevor,

I do appreciate you trying to help. But the answer is not in the error. If
you had actually read the post you would see that it says that i am having
this problem because I DO NOT HAVE IIS. And thanks to microshaft i can not
have it, unless i pay there stupid rate for win xp pro. So please read a
post through all the way before you respond.

"Trevor Benedict R" <tr********@yahoo.com> wrote in message
news:Of**************@TK2MSFTNGP12.phx.gbl...
The answer is in the Error Message itself. If you open IIS, right click
on any Virtual Directory, You will see a button called Create. If you
click this button an Application is created within which the ASP.NET
application will run. This is required because you have a web.config
file in this folder. Now find out how to achieve this in Cassini .

Regards,

Trevor Benedict R
MCSD

*** Sent via Devdex http://www.devdex.com ***
Don't just participate in USENET...get rewarded for it!

Nov 18 '05 #3
Checkout this link

(USE THIS AT YOUR OWN RISK)
http://www.15seconds.com/issue/020118.htm
Regards

Trevor Benedict R
MCSD

*** Sent via Devdex http://www.devdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #4
> this problem because I DO NOT HAVE IIS. And thanks to microshaft i can
not
have it, unless i pay there stupid rate for win xp pro.
"microshaft" makes a FREE ASP.Net development toolkit called "Web Matrix"
which you can download from http://www.asp.net. It includes a FREE
ASP.Net-compatible web server. How dare they do such a thing? Still, I am
sure you can afford the "stupid rate" that they are charging for this
product.

Oh yes. "microshaft" is also making a number of light-weight versions of
Visual Studio.Net available for FREE:

http://lab.msdn.microsoft.com/express/

The B**tards!

--
HTH,
Kevin Spencer
..Net Developer
Microsoft MVP
Big things are made up
of lots of little things.

"WStoreyII" <pa**********@sbcglobal.net> wrote in message
news:jn******************@newssvr29.news.prodigy.c om... Trevor,

I do appreciate you trying to help. But the answer is not in the error. If you had actually read the post you would see that it says that i am having
this problem because I DO NOT HAVE IIS. And thanks to microshaft i can not have it, unless i pay there stupid rate for win xp pro. So please read a
post through all the way before you respond.

"Trevor Benedict R" <tr********@yahoo.com> wrote in message
news:Of**************@TK2MSFTNGP12.phx.gbl...
The answer is in the Error Message itself. If you open IIS, right click
on any Virtual Directory, You will see a button called Create. If you
click this button an Application is created within which the ASP.NET
application will run. This is required because you have a web.config
file in this folder. Now find out how to achieve this in Cassini .

Regards,

Trevor Benedict R
MCSD

*** Sent via Devdex http://www.devdex.com ***
Don't just participate in USENET...get rewarded for it!


Nov 18 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

28 posts views Thread by Steve Bywaters | last post: by
10 posts views Thread by Brian Conway | last post: by
6 posts views Thread by Thomas Connolly | last post: by
6 posts views Thread by ST | last post: by
11 posts views Thread by George | last post: by
3 posts views Thread by Don | last post: by
1 post views Thread by livre | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.