468,241 Members | 1,545 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,241 developers. It's quick & easy.

Framework 1.1 and Forms Authentication

Hi,

I have different asp.net applications as sub applications within an application and was using Framework 1.0. And I use forms authentication across the applications. In the web.config file of outer application I have

<authentication mode="Forms">
<forms name=".ASPXAUTH" loginUrl="Default.aspx" path="/" timeout="20"/>
</authentication>

While in the web.config of the Sub applications I have

<authentication mode="Forms">
<forms name=".ASPXAUTH" loginUrl="../Default.aspx" timeout="20"/>
</authentication>

So I was able to access the pages in the Sub applications as long I was authenticated.

Now when I upgrade to Framework 1.1, this does not work. I able to login, but not able to access any pages in the sub application. When I try to reach to any page in the sub application, it simply throws me back to defualt page. For some reason the sub applications are not recognizing the aspxauth cookie.

I would appreciate any response in this regard.

Thanks.

Nov 18 '05 #1
2 1339
Set the name="" to the same name - DONE

Config File <machineKey>
Set the validationKey to the same value in each app
Set the decryptionKey to the same value in each app
(see help file)

NOTE: This will still not allow passing session values back and forth, but
it will allow a user to be authed in two apps. The apps do not have to be
web and subweb either.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

************************************************
Think Outside the Box!
************************************************
"Dotnet Guy" <Dotnet Gu*@discussions.microsoft.com> wrote in message
news:F1**********************************@microsof t.com...
Hi,

I have different asp.net applications as sub applications within an application and was using Framework 1.0. And I use forms authentication
across the applications. In the web.config file of outer application I have
<authentication mode="Forms">
<forms name=".ASPXAUTH" loginUrl="Default.aspx" path="/" timeout="20"/>
</authentication>

While in the web.config of the Sub applications I have

<authentication mode="Forms">
<forms name=".ASPXAUTH" loginUrl="../Default.aspx" timeout="20"/>
</authentication>

So I was able to access the pages in the Sub applications as long I was authenticated.
Now when I upgrade to Framework 1.1, this does not work. I able to login, but not able to access any pages in the sub application. When I try to reach
to any page in the sub application, it simply throws me back to defualt
page. For some reason the sub applications are not recognizing the aspxauth
cookie.
I would appreciate any response in this regard.

Thanks.

Nov 18 '05 #2
Thanks Greg.
It works but my session does not time out in 20 min. I have this in each of my apps.

<forms name=".ASPXAUTH" loginUrl="Default.aspx" path="/" protection="All" timeout="20"/>

Thanks in advance.
"Cowboy (Gregory A. Beamer) [MVP]" wrote:
Set the name="" to the same name - DONE

Config File <machineKey>
Set the validationKey to the same value in each app
Set the decryptionKey to the same value in each app
(see help file)

NOTE: This will still not allow passing session values back and forth, but
it will allow a user to be authed in two apps. The apps do not have to be
web and subweb either.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

************************************************
Think Outside the Box!
************************************************
"Dotnet Guy" <Dotnet Gu*@discussions.microsoft.com> wrote in message
news:F1**********************************@microsof t.com...
Hi,

I have different asp.net applications as sub applications within an

application and was using Framework 1.0. And I use forms authentication
across the applications. In the web.config file of outer application I have

<authentication mode="Forms">
<forms name=".ASPXAUTH" loginUrl="Default.aspx" path="/" timeout="20"/>
</authentication>

While in the web.config of the Sub applications I have

<authentication mode="Forms">
<forms name=".ASPXAUTH" loginUrl="../Default.aspx" timeout="20"/>
</authentication>

So I was able to access the pages in the Sub applications as long I was

authenticated.

Now when I upgrade to Framework 1.1, this does not work. I able to login,

but not able to access any pages in the sub application. When I try to reach
to any page in the sub application, it simply throws me back to defualt
page. For some reason the sub applications are not recognizing the aspxauth
cookie.

I would appreciate any response in this regard.

Thanks.


Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Anonieko Ramos | last post: by
11 posts views Thread by xenophon | last post: by
7 posts views Thread by Adam Bates | last post: by
4 posts views Thread by =?Utf-8?B?R3V1czEyMw==?= | last post: by
5 posts views Thread by Rory Becker | last post: by
reply views Thread by NPC403 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.