469,645 Members | 1,546 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,645 developers. It's quick & easy.

External command can't find user created *.dll on C#.NET

I'm trying to run an external command-line file using user create
C:\DLL\*.dll files as following code

Process.Start("c:\test.exe"

The test.exe has no problem when I run on the dos prompt as I se
path, C:\DLL, on system variable

Thanks for your hel

Nov 18 '05 #1
2 1061
Hi,

if you trying to run process from ASP.NET the default ASP.NET user don't
have rights to run other processes. you need to change to user with
appropriate rights

Natty Gur[MVP]

blog : http://weblogs.asp.net/ngur
Mobile: +972-(0)58-888377
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #2
Hi Natty
Thanks for your respond. I'm not sure the process
run on ASP.NET. I am a new at this environment
It worked when I tested first wit
Process.Start("notepad.exe")
When I tried to run Process.Start("test.exe"),
which uses several *.dll files, the error message is
"This application has failed to start because a.dll was not found".
Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Kathy Benson | last post: by
4 posts views Thread by Erohsik | last post: by
2 posts views Thread by Matt | last post: by
8 posts views Thread by Charles Law | last post: by
4 posts views Thread by =?Utf-8?B?U0g=?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.