467,877 Members | 1,186 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,877 developers. It's quick & easy.

solution requires web project in default site

single machine - W2Kserver , IIS5 , VS.NET 2003

I spent some time struggling with what looked like the dreaded asp.net
debugging configuration problem but none of the solutions for this did any
good.
Outside of the ide I am able to browse to an existing web app with no
problem and I can load the web app project in the visual studio ide and run
it 'without debugging' . But I am unable to run it with debugging within the
ide - "Error while trying to run project." note that there isn't the usual
" Can't start debugging ... " stuff. I am also unable to create any new web
apps - "The web server reported the following " .. blah blah ... "500
internal server error".
This is happening with web projects on a web site other than the default -
on a whim i tried creating a webapp on the default site & surprise surprise
it works. Ok - so maybe this is a permissions problem on all sites other
than the default site (?) - but not so fast - as it turns out , having this
default site webapp included in the solution has the unexpected side effect
of now allowing me to run & create web apps in non-default sites !!! If i
remove this default site web app from the solution everything keep working
fine. If i restart studio things are still working ok. BUT if i restart
IIS I am right back to where i started - unable to create or run non-default
site web apps in the ide. If i re-add the default site web app to the
solution - everything is peachy once again. I can restart studio & IIS to
my hearts content and have everything work just fine as long as i include a
default site web app in the solution.
this is not restricted to any particular solution , and is 100% reproducable
in all current solutions and by creating a new blank solution

Any one have any ideas what is going on here ?

gerry
Nov 18 '05 #1
  • viewed: 1846
Share:
5 Replies
Hi Gerry,

As for this issue, I'd like to state my understanding first:
You are developing ASP.NET web application on a W2Kserver machien with
IIS5, VS.NET 2003,( .net framwork1.1)?
Currently, you have two different website in the IIS (one is the default
site). You have a solution which contains several projects , two of them
are web project which are created on another website(no the default one,
yes?), however , you found you will have problem when use debug mode to run
the web project in VS.NET.
Also, you found you even can't create a new web project under the new site
as long as there is no default site webproejct included in your solution
and if there is one default site's web project, you 're ok to create or
debug web application in the new site, yes?
If there is anything I misunderstand, please feel free to correct me.

Regarding on this issue, I'd like to confirm some further things:
1. Are all the webprojects originally in your solution created locally on
the w2k server machine in the IIS's new site(other than the default site)?
2. Have you tired opening them separately from the solution , just as a
single web applicatoin via VS.NET? I think you can open the webproject's
".csproj.webinfo" or the solution's ".sln" file , there is the webproject's
url address info in them, check them to see whether they're specified to
the correct value.

2. Since you have mulit websites in the IIS on the win2k server, how do you
distinct them, via port? or host headers?
Then, when you create a new web project on the new website, how do you
specify the ip address? It would be helpful if you have a check on the IIS
setting between the default site and the new site.

3. Such error like 500 when creating web project on webserver sometimes
caused by the permission setting in the website. If so , please
1)open up IIS (start -> Run -> Type inetmgr. This will open up the
Internet Services Manager.
2) Right-Click on the default website and choose Properties
3) Choose the Home Directory Tab
4) Then ensure that the Read checkbox is checked and the execute
permission is "read only"

Please have a look at the above items. If you have any new findings or
question, please feel free to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx


Nov 18 '05 #2
Hi Steven , thanks for the response , see answers inline :

"Steven Cheng[MSFT]" <v-******@online.microsoft.com> wrote in message
news:0r**************@cpmsftngxa10.phx.gbl...
Hi Gerry,

As for this issue, I'd like to state my understanding first:
You are developing ASP.NET web application on a W2Kserver machien with
IIS5, VS.NET 2003,( .net framwork1.1)?
Currently, you have two different website in the IIS (one is the default
site).
Correct.
You have a solution which contains several projects , two of them
are web project which are created on another website(no the default one,
yes?), however , you found you will have problem when use debug mode to run the web project in VS.NET.
Correct. ( any number of web projects )
Also, you found you even can't create a new web project under the new site
as long as there is no default site webproejct included in your solution
and if there is one default site's web project, you 're ok to create or
debug web application in the new site, yes?
Correct.
If there is anything I misunderstand, please feel free to correct me.

Regarding on this issue, I'd like to confirm some further things:
1. Are all the webprojects originally in your solution created locally on
the w2k server machine in the IIS's new site(other than the default site)?
Yes.
2. Have you tired opening them separately from the solution , just as a
single web applicatoin via VS.NET?
Yes - when i try to run I am prompted to save a new solution for the project
with same result.
I think you can open the webproject's
".csproj.webinfo" or the solution's ".sln" file , there is the webproject's url address info in them, check them to see whether they're specified to
the correct value.
Yes the url specified in both of these files is correct :
http://dev.domain.ca/WebApplication1...cation1.csproj
2. Since you have mulit websites in the IIS on the win2k server, how do you distinct them, via port? or host headers?
host headers.
Then, when you create a new web project on the new website, how do you
specify the ip address?
I specify the url ie, http://dev.domain.ca/WebApplication1 , I am then
prompted to locate the physical disk location because Studio defaults the
file share path to \\dev.domain.ca\wwwroot$\WebApplication1 which should
actually be c:\InetPub\dev.domain.ca\WebApplication1
It would be helpful if you have a check on the IIS
setting between the default site and the new site.
sorry - I am not sure which settings you are referring to - other than home
directory & host header , both sites are (apparently) identical.
3. Such error like 500 when creating web project on webserver sometimes
caused by the permission setting in the website. If so , please
1)open up IIS (start -> Run -> Type inetmgr. This will open up the
Internet Services Manager.
2) Right-Click on the default website and choose Properties
3) Choose the Home Directory Tab
4) Then ensure that the Read checkbox is checked and the execute
permission is "read only"
Read is checked and Script Only ( i assume that is what you meant to say )
is selected.
this is true for all sites.
Please have a look at the above items. If you have any new findings or
question, please feel free to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx



Nov 18 '05 #3
I decided to try re-creating the website and it cleared up the problem.
I am assuming that there was some problem perhaps buried in the IIS meta
data that is fixed up by deleting & recreating the sites.

thanks for your time with this.
let me know if you want any further info regarding this issue for future
reference.

gerry


"gerry" <ge**@hotmail.com> wrote in message
news:%2******************@TK2MSFTNGP09.phx.gbl...
Hi Steven , thanks for the response , see answers inline :

"Steven Cheng[MSFT]" <v-******@online.microsoft.com> wrote in message
news:0r**************@cpmsftngxa10.phx.gbl...
Hi Gerry,

As for this issue, I'd like to state my understanding first:
You are developing ASP.NET web application on a W2Kserver machien with
IIS5, VS.NET 2003,( .net framwork1.1)?
Currently, you have two different website in the IIS (one is the default
site).
Correct.
You have a solution which contains several projects , two of them
are web project which are created on another website(no the default one,
yes?), however , you found you will have problem when use debug mode to

run
the web project in VS.NET.


Correct. ( any number of web projects )
Also, you found you even can't create a new web project under the new site as long as there is no default site webproejct included in your solution
and if there is one default site's web project, you 're ok to create or
debug web application in the new site, yes?


Correct.
If there is anything I misunderstand, please feel free to correct me.

Regarding on this issue, I'd like to confirm some further things:
1. Are all the webprojects originally in your solution created locally on the w2k server machine in the IIS's new site(other than the default

site)?
Yes.
2. Have you tired opening them separately from the solution , just as a
single web applicatoin via VS.NET?
Yes - when i try to run I am prompted to save a new solution for the

project with same result.
I think you can open the webproject's
".csproj.webinfo" or the solution's ".sln" file , there is the webproject's
url address info in them, check them to see whether they're specified to
the correct value.


Yes the url specified in both of these files is correct :
http://dev.domain.ca/WebApplication1...cation1.csproj
2. Since you have mulit websites in the IIS on the win2k server, how do

you
distinct them, via port? or host headers?


host headers.
Then, when you create a new web project on the new website, how do you
specify the ip address?


I specify the url ie, http://dev.domain.ca/WebApplication1 , I am then
prompted to locate the physical disk location because Studio defaults the
file share path to \\dev.domain.ca\wwwroot$\WebApplication1 which should
actually be c:\InetPub\dev.domain.ca\WebApplication1
It would be helpful if you have a check on the IIS
setting between the default site and the new site.


sorry - I am not sure which settings you are referring to - other than

home directory & host header , both sites are (apparently) identical.
3. Such error like 500 when creating web project on webserver sometimes
caused by the permission setting in the website. If so , please
1)open up IIS (start -> Run -> Type inetmgr. This will open up the
Internet Services Manager.
2) Right-Click on the default website and choose Properties
3) Choose the Home Directory Tab
4) Then ensure that the Read checkbox is checked and the execute
permission is "read only"


Read is checked and Script Only ( i assume that is what you meant to say )
is selected.
this is true for all sites.
Please have a look at the above items. If you have any new findings or
question, please feel free to post here.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx




Nov 18 '05 #4
Hi Gerry,

Thanks for the followup. Yes, the metabase of the IIS may be a potential
cause. Also, it is possible that the ASP.NET1.1 installation may be
corrupted. Next time maybe you can also try using the aspnet_regiis.exe
tool to uninstall and reinstall the asp.net , just type the following
command:
aspnet_regiis -u
aspnet_regiis -i

Anyway, I'm glad that you clearup the issue. If you meet any further
problem, please always feel free to post here. Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #5
Thanks Steven ,
I did try aspnet_regiis -i , but it never occurred to me to use
aspnet_regiis -u 1st.
I will keep this in mind for future reference.

"Steven Cheng[MSFT]" <v-******@online.microsoft.com> wrote in message
news:JZ*************@cpmsftngxa10.phx.gbl...
Hi Gerry,

Thanks for the followup. Yes, the metabase of the IIS may be a potential
cause. Also, it is possible that the ASP.NET1.1 installation may be
corrupted. Next time maybe you can also try using the aspnet_regiis.exe
tool to uninstall and reinstall the asp.net , just type the following
command:
aspnet_regiis -u
aspnet_regiis -i

Anyway, I'm glad that you clearup the issue. If you meet any further
problem, please always feel free to post here. Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Get Preview at ASP.NET whidbey
http://msdn.microsoft.com/asp.net/whidbey/default.aspx

Nov 18 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Sorin Dolha | last post: by
10 posts views Thread by Tim Mulholland | last post: by
4 posts views Thread by Problem doesn't solve | last post: by
4 posts views Thread by Anbu | last post: by
2 posts views Thread by Jaap | last post: by
reply views Thread by jack112 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.