By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,110 Members | 1,639 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,110 IT Pros & Developers. It's quick & easy.

Unable to set server side table's cell widths as percentages

P: n/a
Hello.

Is it possible to build up a dynamic server side table, and specify
the column widths as percentages? I've tried this:

Set the table width to 100%, then:

FirstColumn.Width = New Unit(50, UnitType.Percentage)
SecondColumn.Width = New Unit(30, UnitType.Percentage)
ThirdColumn.Width = New Unit(20, UnitType.Percentage)

But the widths get ignored.

If I use Unit.Percentage(50), this also gets ignored.

TIA for any suggestions.
-dnw.
Nov 18 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
When it comes to the column width, browsers consider your instructions as
recommendations. Usually it is possible to layout your page nicely without
specifying exact column width.

Eliyahu

"Dot net work" <do***@hotmail.com> wrote in message
news:77**************************@posting.google.c om...
Hello.

Is it possible to build up a dynamic server side table, and specify
the column widths as percentages? I've tried this:

Set the table width to 100%, then:

FirstColumn.Width = New Unit(50, UnitType.Percentage)
SecondColumn.Width = New Unit(30, UnitType.Percentage)
ThirdColumn.Width = New Unit(20, UnitType.Percentage)

But the widths get ignored.

If I use Unit.Percentage(50), this also gets ignored.

TIA for any suggestions.
-dnw.

Nov 18 '05 #2

P: n/a
I'm sorry, I have made a mistake.

The syntax that I used was fine.
I had the server table positioned inside a small html table. What I
needed to do was set *that* table's overall width to 100%
I now have this working.
-dnw.


*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.