By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,824 Members | 1,247 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,824 IT Pros & Developers. It's quick & easy.

SoapException - unusual behavior

P: n/a
I have a web page. It uses web service (on localhost) to get data. I'm able
to get to my web service properly, data is returned. Then, via JavaScript,
I HTTP post to another site. Instead of seeing the other site, I see the
SoapException...
<?xml version="1.0" encoding="utf-8" ?>
- <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
- <soap:Body>
- <soap:Fault>
<faultcode>soap:Client</faultcode>
<faultstring>System.Web.Services.Protocols.SoapExc eption: Unable to handle
request without a valid action parameter. Please supply a valid soap action.
at System.Web.Services.Protocols.Soap11ServerProtocol Helper.RouteRequest()
at System.Web.Services.Protocols.SoapServerProtocol.I nitialize() at
System.Web.Services.Protocols.ServerProtocol.SetCo ntext(Type type,
HttpContext context, HttpRequest request, HttpResponse response) at
System.Web.Services.Protocols.ServerProtocolFactor y.Create(Type type,
HttpContext context, HttpRequest request, HttpResponse response, Boolean&
abortProcessing)</faultstring>
<detail />
</soap:Fault>
</soap:Body>
</soap:Envelope>

I thought this message only happened for web service issues, yet my web
service was fine. Is there somewhere I should be looking?
Thanks for ideas! --Marty
Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Please disregard - I found the cause of my issue. Instead of using HTTP
Post to go to another site, I was accidentally posting to my own form again!

"Marty McDonald" <mc******@wsdot.wa.gov> wrote in message
news:Ot**************@TK2MSFTNGP10.phx.gbl...
I have a web page. It uses web service (on localhost) to get data. I'm able to get to my web service properly, data is returned. Then, via JavaScript, I HTTP post to another site. Instead of seeing the other site, I see the
SoapException...
<?xml version="1.0" encoding="utf-8" ?>
- <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
- <soap:Body>
- <soap:Fault>
<faultcode>soap:Client</faultcode>
<faultstring>System.Web.Services.Protocols.SoapExc eption: Unable to handle request without a valid action parameter. Please supply a valid soap action. at System.Web.Services.Protocols.Soap11ServerProtocol Helper.RouteRequest()
at System.Web.Services.Protocols.SoapServerProtocol.I nitialize() at
System.Web.Services.Protocols.ServerProtocol.SetCo ntext(Type type,
HttpContext context, HttpRequest request, HttpResponse response) at
System.Web.Services.Protocols.ServerProtocolFactor y.Create(Type type,
HttpContext context, HttpRequest request, HttpResponse response, Boolean&
abortProcessing)</faultstring>
<detail />
</soap:Fault>
</soap:Body>
</soap:Envelope>

I thought this message only happened for web service issues, yet my web
service was fine. Is there somewhere I should be looking?
Thanks for ideas! --Marty

Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.